Forums/Pioneer Gear/rekordbox / remotebox

Rekordbox and itunes bridge

Martin Beijer
posted this on November 28, 2012 21:05

Having trouble with the bridge within rekordbox 2.0.1 which I never had before. I pointed out my itunes library xml file and it locates all the files and playlists inside the bridge function but after i import them they can not be found. This means I cant analyze and put them on my external hard drive. 

It's weird because I can play all the songs fine directly from itunes which rekordbox cant find through bridge. 

Kind of hassle for me since i first create all my playlists in itunes and then import them. 

File formats are AIFF/mp3

Anyone had similar problem? Because I can't change anything else inside rekordbox preferences that will fix this. Even reinstalled rekord~.

 

Comments

User photo
Kristina

I am having the same exact issue.

Beyond frustrated.

Have reached out to all my Pio contacts to see if I can get an answer. Will report back here and please do the same!

Hundreds of playlists and I would rather not risk re-installing if I can avoid it.

Like your case, everything in iTunes is fine, (10.7) but none of the new playlists or folders are being bridged into RB, even after hitting "refresh". (December 5th was the last successful bridge session)

 

Curious if the problem is easily fixed by upgrading to the new 2.0.2 software? Although I am avoiding that so far because other DJs I know who did the update said you are unable to drag and drop to device, amongst other bugs..

 

Would really like to get this back up and running in 2.0.1 without having to re-install :(

 

Hoping for a solutiion soon!

December 15, 2012 14:21
User photo
Kristina

I am having the same exact issue.

Beyond frustrated.

Have reached out to all my Pio contacts to see if I can get an answer. Will report back here and please do the same!

Hundreds of playlists and I would rather not risk re-installing if I can avoid it.

Like your case, everything in iTunes is fine, (10.7) but none of the new playlists or folders are being bridged into RB, even after hitting "refresh". (December 5th was the last successful bridge session)

 

Curious if the problem is easily fixed by upgrading to the new 2.0.2 software? Although I am avoiding that so far because other DJs I know who did the update said you are unable to drag and drop to device, amongst other bugs..

 

Would really like to get this back up and running in 2.0.1 without having to re-install :(

 

Hoping for a solutiion soon!

December 15, 2012 14:21
User photo
Martin Beijer
My solution right now is putting everything back in without using itunes bridge, not fun to change my workflow but seems like there is no other solution?!:(
December 16, 2012 03:15
User photo
Martin Beijer
I just drag and drop to rekordbox
December 16, 2012 03:15
User photo
Kristina

Hey Martin,

After 4 hours last night, I finally figured it out!

Hopefully your issue is the same and this will work for you. :) Let me know!


BRIDGING ISSUE FIX IN MY CASE:

You do NOT need to update to 2.0.2 if you don’t want to.

It will NOT fix the bridging issue. (I tried.)

Did find a fix though!


Culprit was the iTunes Library File under “Preferences”.

I had already checked this spot several times and didn't see a problem. But, when I had all but given up after attempting many things including: reinstalling, migrating DB to another computer, updating to 2.0.2. etc... , I decided to look there once last time and this time something finally caught my eye I hadn't noticed before...

It defaults at:

Users/xxxxxx/Music/iTunes/iTunes Music Library.xml (which APPEARED at a glance correct.)

But I took a wild guess and changed it to:

Users/xxxxxx/Music/iTunes/iTunes Library.xml

and BOOM! fixed!

Notice, these files look almost identical, the only difference is the word “Music”.

No clue where this all got off course as I changed absolutely nothing on my end, but as soon as I did that, everything is a go.

I don't understand why/when iTunes decided to start having 2 xml files called library? Right now it's a mystery and I'm waiting to hear back from Pioneer on it. Will post here when I do.

In the meantime, I really hope this works for you like it did for me!

Good luck!

 

December 16, 2012 07:35
User photo
Martin Beijer
Thats weird, i just browsed to my itunes library and put it in. Will try what you did right away, thanks for the info katarina!
December 16, 2012 09:46
User photo
Martin Beijer
Kristina* sorry:)
December 16, 2012 09:47
User photo
Kristina

It's ok Martin ;) Hope it worked for you!

December 18, 2012 09:34