Question

4 Followers
1
Avatar

[OPEN] Rekordbox and itunes bridge

Having trouble with the bridge within rekordbox 2.0.1 which I never had before. I pointed out my itunes library xml file and it locates all the files and playlists inside the bridge function but after i import them they can not be found. This means I cant analyze and put them on my external hard drive. 

It's weird because I can play all the songs fine directly from itunes which rekordbox cant find through bridge. 

Kind of hassle for me since i first create all my playlists in itunes and then import them. 

File formats are AIFF/mp3

Anyone had similar problem? Because I can't change anything else inside rekordbox preferences that will fix this. Even reinstalled rekord~.

Martin Beijer

Please sign in to add your answer.

24 answers

0
Avatar

I am having the same exact issue.

Beyond frustrated.

Have reached out to all my Pio contacts to see if I can get an answer. Will report back here and please do the same!

Hundreds of playlists and I would rather not risk re-installing if I can avoid it.

Like your case, everything in iTunes is fine, (10.7) but none of the new playlists or folders are being bridged into RB, even after hitting "refresh". (December 5th was the last successful bridge session)

 

Curious if the problem is easily fixed by upgrading to the new 2.0.2 software? Although I am avoiding that so far because other DJs I know who did the update said you are unable to drag and drop to device, amongst other bugs..

 

Would really like to get this back up and running in 2.0.1 without having to re-install :(

 

Hoping for a solutiion soon!

Kristina
0
Avatar

I am having the same exact issue.

Beyond frustrated.

Have reached out to all my Pio contacts to see if I can get an answer. Will report back here and please do the same!

Hundreds of playlists and I would rather not risk re-installing if I can avoid it.

Like your case, everything in iTunes is fine, (10.7) but none of the new playlists or folders are being bridged into RB, even after hitting "refresh". (December 5th was the last successful bridge session)

 

Curious if the problem is easily fixed by upgrading to the new 2.0.2 software? Although I am avoiding that so far because other DJs I know who did the update said you are unable to drag and drop to device, amongst other bugs..

 

Would really like to get this back up and running in 2.0.1 without having to re-install :(

 

Hoping for a solutiion soon!

Kristina
0
Avatar

My solution right now is putting everything back in without using itunes bridge, not fun to change my workflow but seems like there is no other solution?!:(

Martin Beijer
0
Avatar

Hey Martin,

After 4 hours last night, I finally figured it out!

Hopefully your issue is the same and this will work for you. :) Let me know!

BRIDGING ISSUE FIX IN MY CASE:

You do NOT need to update to 2.0.2 if you don’t want to.

It will NOT fix the bridging issue. (I tried.)

Did find a fix though!

Culprit was the iTunes Library File under “Preferences”.

I had already checked this spot several times and didn't see a problem. But, when I had all but given up after attempting many things including: reinstalling, migrating DB to another computer, updating to 2.0.2. etc... , I decided to look there once last time and this time something finally caught my eye I hadn't noticed before...

It defaults at:

Users/xxxxxx/Music/iTunes/iTunes Music Library.xml (which APPEARED at a glance correct.)

But I took a wild guess and changed it to:

Users/xxxxxx/Music/iTunes/iTunes Library.xml

and BOOM! fixed!

Notice, these files look almost identical, the only difference is the word “Music”.

No clue where this all got off course as I changed absolutely nothing on my end, but as soon as I did that, everything is a go.

I don't understand why/when iTunes decided to start having 2 xml files called library? Right now it's a mystery and I'm waiting to hear back from Pioneer on it. Will post here when I do.

In the meantime, I really hope this works for you like it did for me!

Good luck!

 

Kristina
0
Avatar

Thats weird, i just browsed to my itunes library and put it in.

Will try what you did right away, thanks for the info katarina!

Martin Beijer
0
Avatar

Ok, I'm having the same issue, except that solution didn't work for me. I even tried saving a new version of the .xml file, but to no avail. Here is what puzzles me: when I go to "view all missing files," THE FILE PATHS ARE ALL CORRECT. Every single "missing" file has the correct file path listed, but for some reason, Rekordbox WILL NOT find the file there. Why? This is so frustrating :(

Kelsey Saunders
0
Avatar

CORRECTION: The file paths are all correct, except it's adding "file:///" to the front of the path. This makes it so that Rekordbox can't find it. Why? How can I make it stop doing that?

Kelsey Saunders
0
Avatar

I'm using RB 2.2.4 on OSX 10.9.5 with iTunes 12.0.1.26. I'm not using RB 3 because I can barely get that version to work, so I downgraded.

Kelsey Saunders
0
Avatar

sadly, 6 months later, still issues. what are you doing pioneer?

some files are found and some not, and when I go to "relocate" it says the file is already in the library, when I try to play it, it says can not find the file.

Valentino
0
Avatar

I found out I had to rename every file the contains a "-" in the file name or description, and also if the producer is set rekordbox will not find them.

 

Valentino
0
Avatar

If anyone here is still looking for a solution, I found a workaround. I have both Rekordbox 2 AND 3 installed on my computer. I use RB3 to import the tracks into my library and analyze them. Then, I close it and open Rekordbox 2. They share the same library, so all of my tracks and their analysis are there in RB2. And any time I need to "relocate" or re-add a file, I make sure to do it in RB3, because RB2 can't do it for some reason.

I still refuse to use RB3 for everything because it takes 3 hours to update a flash drive, while RB2 takes 30 minutes Go figure.

Kelsey Saunders
0
Avatar

@Kelsey > That is not recommended -- while both use the same database, there are features supported by v3 which are not implemented under v2, as a result there may be some incomplete or damaged data when switching between versions of the application.

Pulse
0
Avatar

@Valentino > Can you provide more detail on the issue with the hyphen "-" in the filename / description? I'd like to pass that on to the engineers.

Also, if you can tell us what the original file location and actual file location (after the move) are, that might help better understand the process you went through and why it could not locate the files.

Pulse
0
Avatar

If you don't recommend my solution then...fix the issue? Sorry, but that's quite a frustrating answer...

Kelsey Saunders
0
Avatar

I know, and the engineers are working on trying to resolve the issue -- but it's a tricky one as not everyone is having the same problem the same way.

Pulse
0
Avatar

Hello

I never moved the file.

I imported files from itunes to rekordbox. The files did show in the collection, however when I tryed to play them, rekord would complain file can't be found.

I realiced many of those files had a - in the name. After renaming them in itunes, rekordbox was able to read them. Other files had other issues, when I deleted some of their tags in itunes, rekordbox was finaly able to read them.

 

Valentino
0
Avatar

btw after I found those issues with itunes, I was thinking to better import new files directly to rekordbox and not to use itunes anymore.

The issue I'm now facing: if I want to delete a file, I have to delete it in the collection and then also on the disk.

Is there a way around this so I can have files automatically deleted from the disk when I delete them in the collection?

Valentino
0
Avatar

@Valentino > That suggestion has been put forward to be introduced in a future release of rekordbox.

Thank you for the additional information regarding the hyphens. Are you using a non-English language in your operating system? If so, can you tell me what language the system is set to?

Pulse
0
Avatar

here the details on my language location settings. 

Do you have an answer on my questions on deleting/organizing files?

Valentino
0
Avatar

@Valentino > The engineers have said:

We assume one of the reasons why the imported track from iTunes to rekordbox via Bridge is missing may be that the path of the track written in iTunes.xml and the actual location are not matched. Some characters in the titles which users specified may not be properly handled by iTunes. It would be a good idea to use English alphabets in track folders and file names if you want to avoid this issue.

Also, if you select “Automatically sort iTunes Music folder” in iTunes preferences, when track titles are changed in iTunes, the folders and file names will be changed accordingly. Please disable this setting and try again.

To answer your question regarding deleting them from the drive when removing the file from your collection, that is a feature which has been requested but will not be available until a future update.

Pulse