Have a feature request or suggestion? Post your idea here!

Post

3 followers Follow
0
Avatar

Switching to external mixer mode (need help asap...)

I did not know that ddj rb had lower sound than other pioneer controllers and had it configured as in the guide. Last weekend it was the first time playing at a club with my new ddj rb and the sound was unexpectedly weak.
I've been seeking help from every source except here. To make this short: the past days i tried everything in the preferences and somehow once i have switched the mixer mode to external (while the ddj rb connected) even if it's not available when ddj rb is connected. and the sound got louder almost twice than it was in internal mode.Maybe that's because in internal mode i can't control the master on rekordox( top right,it's just fozen) and on external is on full as set on the ddj rb..
Can you tell me how to use the controller on loudest sound possible.
When in "external mode"and the "booth output" set on "master" that powerful sound is just what i need...
Please don't make me regret buying your product.. Sorry for the long text,thank you and have a nice day!

Hristijan Jovanoski Answered

Official comment

Avatar

@Hristijan > The DDJ-RB has a standard +4dBu line level output for the RCA master output.

As the driver for the DDJ-RB isn't designed to be used in EXTERNAL MIXER mode, that was likely a glitch that you were able to engage it. The only thing that may have made it louder is if you also added "Booth Output" to the master, as it would have been sending additional signal.

My recommendation is to ensure that you're running a master signal that is close to the red, but not pinned there or clipping, and then on whatever device you're connecting the master output to, turn up the level so it's appropriate for the input signal level.

Pulse
Comment actions Permalink

Please sign in to leave a comment.

7 comments

0
Avatar

But when i put the master on full with ddj rb the channel level is never high and the sound isn't as powerful and with stong bass as when i play with my laptop's soundcard on rekordbox.

Tell me how to use the full potential of the soundcard because I didn't buy the controller to use it only at home.

Hristijan Jovanoski 0 votes
Comment actions Permalink
0
Avatar

Are you ensuring that the channel trim is turned up and the master knob (on the hardware) is also such that the level meters on the hardware are above the green (but not into the red)?

What are you connecting the RB to?

Pulse 0 votes
Comment actions Permalink
0
Avatar

The master on the controller is set to maximum  and the trim at 12 o'clock and still not giving the powerful sound it should
is there any setting at preferences that could not allowing too much sound?

Btw i am connecting to a phillips dvd surround ( the problem is not at the laptop or speakers because i double checked everything . )

Hristijan Jovanoski 0 votes
Comment actions Permalink
0
Avatar

Your Phillips surround system has the ability to turn the volume up/down, yes? So are you not able to turn that up?

Pulse 0 votes
Comment actions Permalink
0
Avatar

My xdj rx2 controller when connected with my macbook the mixer on the laptop cannot be controlled (trim,high, mid and low are not highlighted anymore) . It can be controlled from the hardware . I would still love to have the controls over the laptop too. When clicked on the mixer at the bottom in red it shows (Invalid operation . use connected dj mixer /controller in External mixer mode) . On the controller in utility too the mixer mode cannot be changed.

 

Kindly help asap. Appreciate your assistance

Snedden Kinny 0 votes
Comment actions Permalink
0
Avatar

@Snedden > Change the mode while the XDJ is disconnected from the computer; set it to MIDI mode for use with the software.

Pulse 0 votes
Comment actions Permalink