Have a feature request or suggestion? Post your idea here!

Post

6 followers Follow
0
Avatar

Display Missing Tracks NOT Working

Hi there

When I want to clear out some tracks I don't play, I have always just deleted them from the hardrive and then used display missing files to show me those files in Rekordbox that don't have a file attached to them (having deleted them) and then just select all and remove those in the list from the collection.  Here is a track that I deleted and you can see the exclamation mark near the preview waveform and when Iclick on it or right click on it, it recnises its missing but "Display Missing Tracks" from the File menu does not meaning I can't now simply remove from collection in one sweep all tracks I don't play / want any more.  Is it a bug?  Can you test it please?  Using latest version on Windows 11.

Thanks

DJ Mista G

Post is closed for comments.

21 comments

1
Avatar

Something else that doesn't seem quite right also once I've clicked Display All Missing Files.  The 'OK' pop-up doesn't behave properly either....  I'll probably try a clean install???

DJ Mista G 1 vote
Comment actions Permalink
0
Avatar

@Pioneer - when I try relocate, it scans various folders but doesn't find it.  The file is still in deleted items.  I've deleted about 10 tracks....  and still get all files exist.  Can you try the same your end and see what happens?

DJ Mista G 0 votes
Comment actions Permalink
0
Avatar

@Pioneer, I've ran a backup and analysis and still not displaying all missing files yet it does still on a per-track basis when I bring it up.  WOndering if its a software issue in the latest update/s?  Always used to work before....  

DJ Mista G 0 votes
Comment actions Permalink
0
Avatar

I even tried reanalysing a few tracks in a list and it still displays it as FILE MISSSING but not from Display Missing Files

 

DJ Mista G 0 votes
Comment actions Permalink
0
Avatar

This is the same issue I'm having. The "File is Missing" exclamation mark pops up, & then when I hover my mouse over it, the exclamation mark disappears. But when I try to update my USB's, it skips over "File is Missing" tracks, which I then have to re-hover over, to get it to work. I've never had this issue before. Only since the update. I've spent all of Friday & Saturday dealing with this. 

Concerned Fan 0 votes
Comment actions Permalink
0
Avatar

Ill I want to do is to see a list of all the missing tracks so I can delete from collection when I delete tracks from the hardrive.  I like to keep my library fairly lean...

DJ Mista G 0 votes
Comment actions Permalink
0
Avatar

I'm on PC - I guess its whatever the "Display Missing Files" button is looking at that isn't working, we know that Rekordbox knows on an individual basis that a file is missing but not multiple....  Must be some business rules criteria that aren't being met for it to think all files exist...?

DJ Mista G 0 votes
Comment actions Permalink
0
Avatar

Okay... think I've discovered the issue for Windows at least.  Went to start menu and as I started to enter re (for remove programs), I accidentally clicked on REkordbox out of habit. Then weirldy, the upgrade pop-up came up.  I decilined having already upgraded and tried dispaly all missing files and it WORKED!  So it appears that Rekordbox during the upgrade on Windows, isn't removing the old version properly from the last 2 upgrades....

As you can see 6.8, 6.9 and 7.0 are still there....  I've removed 6.8 and 7.0 leaving 6.9.  Will try the upgrade again

DJ Mista G 0 votes
Comment actions Permalink
0
Avatar

Yes, I have this exact same issue with the pop-up window not doing anything. Then I sometimes get the rainbow wheel of death. This 6.7.0 is so buggy I cannot DJ with it with a controller now. I’m using USB’s, which was a whole drama in itself to get updated with all the random missing file notifications. I started my set at a five star hotel in a nervous cold sweat, but so far so good. 

Concerned Fan 0 votes
Comment actions Permalink
0
Avatar

Looks like I have 2 profiles for the forum...  anyway I fixed it by realising that the last 2 upgrades haven't removed the old versions...  weird....  check your PC and see if 6.9 is still there by going to 'remove programs'.  Might be the issue.  I had 6.8, 6.9 and 7.0 so removed all but 6.9 and leaving as is.  All works fine including displaying missing tracks and usbs export perfectly no issues....  

DJ Mista G 0 votes
Comment actions Permalink
0
Avatar

I fixed mine ...  the updates have not been uninstalling previous versions so I'm back on .6.9 and all is fine, see above.  Re Cloud Sync.....I am using my own version of cloud sync.  I have a separate SSD (D Drive) on my laptop that I use exclusively for Rekordbox music and the Database file.  I have Dropbox installed on this drive so it syncs everything with the cloud WHEN I turn dropbox on.  My default is off and I only turn it on when I add tracks to the library OR if I've done lots of playlist work so that the Database updates.  (All my other Dropbox files such as Copy's of the all the files on the SSD (so its double backed up), Copy's of BACKUPS from Rekordbox (minus music as already have those) and personal files I store in the VAULT, away from the default Dropbox location so they don't interfere).  It works perfectly.  

DJ Mista G 0 votes
Comment actions Permalink
0
Avatar

Yes, I use Cloud Sync with a yearly dropbox plan, as I'm on the creative plan.

(Which is a whole other can of worms. 3-4 times a week, every week for as long as I can remember, I am randomly logged out of my rekordbox account on my iPhone & iPad. Never happens on my mac, though. Then I need to re-login & click sync Cloud accounts & it needs to load up from 1% again, which takes time. This usually occurs when I'm in a location with patchy internet, but it also happens at random.)

Concerned Fan 0 votes
Comment actions Permalink
0
Avatar

Concerned Fan thanks now I don't think I'm going crazy. 

This happens to me easily every couple of weeks if not more. It tears through my data plan and takes hours until its complete. Now on top of it I am also plagued with 6.7.0 saying load error cannot load track and if I go to another and re load the same track it works fine.

DJ JOEY BROWN 0 votes
Comment actions Permalink
0
Avatar

@Pioneer - Guess what, I finally went to 6.7.0 and uninstalled 6.6.8 and it failed again to recognise missing tracks.  So I redownloaded 6.6.8, installed and removed 6.7.0 and its fine again.  Definitely still an issue.  My thoughts that it was previous versions were still installed was incorrect.

DJ Mista G 0 votes
Comment actions Permalink
0
Avatar

I too am having this problem  Ive just moved my collection from PC to hard drive. 'Display all missing files' in RB6.7.2 is telling me that "All files exist", yet loads of them are missing. I've manually relocated a few on the hard drive but obviously not keen on doing this for the whole collection

 

Justin Gage 0 votes
Comment actions Permalink
0
Avatar

Same issue here, I'm pretty sure is a bug related to Cloud Sync.

From the library, it shows "The file could not be found". 

But Display all missing files says "All file exists" (BUG!)

The file was saved in the DROPBOX folder and also synced with cloud manager.

The file has been DELETED from the DROPBOX folder, and also DELETED form the trash bin. Of course the file is not in dropbox cloud anymore.

From the iPhone the file is listed in the collection (which is correct), but if I try to download it from cloud, it says that the file CAN NOT BE FOUND (which is correct).

I'm on version 6.7.2 with Creative Plan.

This is a very annoying bug, and this ticket is open since March 24th. What we can do to help you in troubleshooting and get it done? If you guys want to have a screen sharing session let us know, I'm sure a bunch of user will be more than happy to do that.

 

 

 

FABIO MARASTONI 0 votes
Comment actions Permalink