Have a feature request or suggestion? Post your idea here!

Post

6 followers Follow
0
Avatar

[CLOSED] DJM 900 Firmware issue

My first DJM 900 was replaced due to issues with another DJM 900. which I just received. The firmware on this mixer is 1.11 I am using a mac book pro with10.6.8 after I download the v120 app and place the djm 900 in update mode when I select the app to open. the app does not take me to the set up screen nothing happens. I thought it may be a bad download so I download the app again and I still get nothing. When I go into the systems/network the Ethernet is yellow and there is a ip address and sub. When I open recordbox the djm 900 works and everything is connected. I tried going straight from the mixer to the mac with a Ethernet cable and still no luck trying to get the djm 900 updated to the new update.

 

Any help would be appreciated. I called pioneer teck support they could not help and said I should try the forums

Super Lou

Post is closed for comments.

16 comments

0
Avatar

That's what I thought, I have all firewall off and on the previous DJM 900 I had no problems updating firm. There is no difference from when I had the first DJM 900 and 2nd

Super Lou 0 votes
Comment actions Permalink
0
Avatar

I tried again, with no cables except the power cable and the Ethernet to the mac. All fire walls are off still no luck. Any chance the other DJM mixer which was bad had an address which its trying to read?

Super Lou 0 votes
Comment actions Permalink
0
Avatar

make sure on your network card it's set for DHCP. So it can negotiate a ip addres with the DJM900.

Robert Rodriguez 0 votes
Comment actions Permalink
0
Avatar

You may possibly have one of the old units that were recalled. I would call in Pioneers with the serial number.

DecoDJs.com

DecoDJs 0 votes
Comment actions Permalink
0
Avatar

Thanks iamel, I suspected that apparently same ash had 3, one I bought then returned do to recall, 2nd one has a defect, now they are checking the 3rd one to see if it's part of the old batch............ Called teck support twice today. They were no help or did they give me any directions I was told to post on the forums. I am very disappointed in there phone support. After I hung up my 15 year old son laughed and said that guy just totally blew you off.......... 

 

Thanks for everyone's support on the forums I really appreciate it

Super Lou 0 votes
Comment actions Permalink
0
Avatar

I see you posted this issue to two different threads; the other says you've resolved the issue, so I'll consider this solved!

Pulse 0 votes
Comment actions Permalink
0
Avatar

Hi pulse I never resolved the issue the second mixer which pioneer support said was bad was not. The 3 rd djm mixer would not load firmware from mac either so I tried it on two different pc and was able to upload firmware to djm 900 my MacBook pro will not connect to the djm 900 when I connect it to the eithernet. I open systems/ network and the color dot which I believe should be green is yellow? The fire wall are off the djm 900 mixer is connected to MacBook pro with nothing else connected to the mixer but the eithernet cable ? Any help would be appreciated

Super Lou 0 votes
Comment actions Permalink
0
Avatar

i know this discussion is fairly old but i am having the same issue with my mixer which i purchased today. can someone help plese?

Adam Gonzales 0 votes
Comment actions Permalink
0
Avatar

When I upgraded the firmware from 1.20 to 1.21, the color dot for the ethernet connection on the MacBook Pro was yellow (not green). It had an APIPA address (something in the 169.254.x.x range).  I was able to upgrade the firmware on the DJM-900 fine from a 2011 15" MacBook Pro. I'll have to check the OS version but from a quick search on the Internet, it's 10.6.6, 10.6.7,10.7, or 10.7.2.

R 0 votes
Comment actions Permalink
0
Avatar

Same here - I updated the firmware from 1.2 to 1.21 (the instructions were shocking - some Chinese field worker must've typed them) via a standard LAN cable to my iMac. The indicator was yellow, not green, but it worked anyway. I ensured that all fields in the Ethernet connection window were empty (i.e. no DNS).

Fabian Henckmann 0 votes
Comment actions Permalink
0
Avatar

Hello everyone,
This is my First time logging in. I purchased the Djm 900 srt in February of 2014 and I noticed the pre installed serato audio drivers have never has really worked well with this mixer. However if I use my SL box using the same computer it works great. So in researching forums I figured that I may need to update my djm firmware. However I am experiencing the same issues as Super Lou above. I'm having issues trying to update my firmware. My version on the mixer says it's 1.0. I follow the update instructions to connect my MacBook pro to the mixer with the Ethernet cable. The connection varifies the Ethernet connection and computer are connected but the connection stays in the yellow color mode and does not give me IP address to get through to make the update. I hope to get some advice and help here soon.

Thanks

Frank Gallardo 0 votes
Comment actions Permalink
0
Avatar

Pulse

thanks for the quick reply. Yes, I have tried various ways including following the user manual instructions. None of them seem to work. I spoke with a tech from Pioneer today. He advised that I send the unit in for warranty repair.  I hope your team is able to fix the problem. I hope the repair time is not too long as I really need it for upcoming work...

. Thanks for getting back to me.

Frank Gallardo 0 votes
Comment actions Permalink
0
Avatar

@Frank > As you've sent it in for repair, I'm going to mark this thread as solved. If you require further assistance with this issue in future, please start a new topic and link back to this thread. Thanks!

Pulse 0 votes
Comment actions Permalink