Have a feature request or suggestion? Post your idea here!


2 followers Follow

[SOLVED] RMX-1000 & Ableton, plugin/firmware issue?

Hi. I have been bounced around between Ableton and Pioneer's customer support for almost 3 weeks now, and nobody has been able to give me a straight answer on this. I cannot get my RMX to communicate with the plugin in Ableton. Under MIDI preferences, I have only Track input set to on, and input devices set the RMX-1000; just like it says in the tutorial video here on the forums. I am running Ableton Live 8 on OS X Mountain Lion. Can somebody plz help me!? :(


The Ableton engineer I talked to suggested that maybe my unit was not communicating with the plugin correctly because of a defect; because isn't it supposed to automap to the plugin?


Also, I have updated my remixbox and plugin software to the latest versions; I tried updating the firmware, but it just downloads a UPD file that for some reason can not be accessed by my macbook. 

Ian Cheyne

Post is closed for comments.



Yes i've got the exact same problem. I'm running Ableton Live 8/Logic Pro 9 on OS X Lion.

It seems that the RMX has not been mapped to the plug-in. It will allow me to map other parameters outside of the the plugin to the hardware, but I cannot use the controller to effect the plugin.

I've exhausted all options, installed all the latest versions, gone back to old versions to see if that worked and updated the firmware etc.


Any ideas of what's going on here please?

Dan O'Donnell 0 votes
Comment actions Permalink

I resolved my issue by putting the latest firmware .upd file on my RMX's SD card, putting it into the hardware, and updating it that way. There is a youtube video that shows this process, by a user, I believe it is titled "RMX-1000 Setup and Firmware Update". It is towards the end of the video that he explains the process of how to update the RMX's hardware using the hardware. 

Ian Cheyne 0 votes
Comment actions Permalink