Have a feature request or suggestion? Post your idea here!

Post

3 followers Follow
1
Avatar

Rekordbox LINC function problem solved!.... or is it?

Hey! - after a lot of testing and testing... i finally got it working! ... though my airport has to be offline all the time?

Setup:

2x CDJ-2000

1x DJM-900

1x MacBook Pro

All linked through a router.

So when my airport is ON i can see the players and mixer in Rekordbox, but my CDJ's doesn't show Rekordbox when i press LINK on them.

If i try to drag and drop a tune, it freezes...

Soo... i were updating the mixer with the new Firmware, and i downloaded the new Driver for the mixer... and suddenly it all worked!

- happy as i were, i wanted to tell everyone about this on the forum, because i weren't the only one with the problem.

And i turned on the Airport..  as soon as it got on and i got connection to the internet, the music stopped.

-> so... at the moment the link function works the way it's supposed when airport is off... but how can i make it work when its ON ?

Didn't have the same problem 'till after 1.5, which maybe triggered something?

I really hope Pioneer or someone else can use this info to solve this problem. 

Cheers

Soltauw 

Soltauw

Please sign in to leave a comment.

20 comments

0
Avatar

I noticed this problem too. Airport turned off, it al works fine. Airport turned on, music stops en sometimes both Rekordbox and CDJ2000 will freeze. Problem occurs with Rekordbox 1.4.1 and 1.5.

Twan Hovens 0 votes
Comment actions Permalink
0
Avatar

I had a similar issue with 1.4.1, here's what I posted in the other thread:

I'm not having this issue with RekordBox 1.5, but I was having a similar issue on my old MacBook Pro (I upgraded a couple of months ago) and 1.4.1.

I THINK it was caused by my USB 3G card drivers interfering with my TCP/IP stack for my ethernet card. What I had to do was remove my 3G card drivers, and then either disable and re-enable my ethernet card or reboot altogether.  Even after the 3G card drivers were gone altogether, often I had to reboot or disable and re-enable my  ethernet card for it to work.  I had the exact same problems Soltauw described.  Seems to be all good with 1.5 on my new MacBook Pro though (I have no use for my 3G card though and haven't tried installing the drivers though.)

 

I'm guessing the router you're using is also your internet gateway? Is your router wireless? My suggestion: Spend the money. buy a cheap hub (They're really cheap these days) and isolate your CDJs from your home network.

AngusGibbins 0 votes
Comment actions Permalink
0
Avatar

My CDJ's are alreadu on a seperate HUB.

* Macbook with airport on DSL router

* Macbook with ethernet to HUB/Switch, my CDJ's are also hookud up to this HUB. Ther's is no physical connection between the CDJ's and the DSL router.

Airport turned off (no internet, no Time capsule), CDJ's work fine

Airport turned on, everything stops (Rekordbox 1.4.1 and 1.5)

Twan Hovens 0 votes
Comment actions Permalink
0
Avatar

@AngusGibbens -> this might be the reason, since i installed the 3G driver shit a week ago i think. -

 - I've removed it, but it still doesnt work?

Im quite new to mac, so i would love if you could perhaps write a few guidelines to how you disabled the ethernet card and so on? :)

Cheers Soltauw..

Hopefully we will have all bugs fixed soon! <3

Soltauw 0 votes
Comment actions Permalink
0
Avatar

@Twan Hovens > Have you ensured that none of your connections have internet sharing enabled?

Pulse 0 votes
Comment actions Permalink
0
Avatar

But yes as Twan says.. the router im using has nothing to do with my internet - i bought a seperate one to control the cdjs, the mixer and the laptop´.. so it shouldnt be a problem area...

Soltauw 0 votes
Comment actions Permalink
0
Avatar

@Soltauw Do a search on Google mate, let me know if you don't have any luck and I'll see if I can post some screenshots tonight when I'm home from work.

I'm not exactly sure what it did but it seemed with my problem the 3G card drivers changed something that interfered with my LAN connection settings, even uninstalling it didn't restore it completely.

If I still had my old MacBook Pro I'd do a bit more testing with it and see if I could figure out what it was exactly. I gave it to my girlfriend though :(

AngusGibbins 0 votes
Comment actions Permalink
0
Avatar

Hi again 

Angus... unfortunately i still have problems with the link...  

Only works when airport is switched off

Tried to find solutions on the net, but didn't help :/

Any chance you could give me a guide or something?

Cheers Soltauw 

Soltauw 0 votes
Comment actions Permalink
0
Avatar

Same here, only works with airport switched off. Nothing to find on the internet for this problemm

Twan Hovens 0 votes
Comment actions Permalink
0
Avatar

The engineers have found the problem with airport and LINK and there will be an update for this in the next release (likely with 1.6).

Pulse 0 votes
Comment actions Permalink
0
Avatar

Is there any news on this topic? 

Perhaps, a date for the next release?

//Soltauw 

Soltauw 0 votes
Comment actions Permalink
0
Avatar

Unfortunately you wont get an ETA date for the next release here, many have tried and many have failed, the only thing I can say is just be patient

MrChukkel 0 votes
Comment actions Permalink
0
Avatar

Try this.

 

Open System Preference, open Network. At the bottom of the connection list there is a settings drop down, select 'Set Service Order', then drag Ethernet to the top. Click OK, then Apply and now you should be able to use Rekordbox Link, even with Airport on and connected to the internet.Let us know if it worked for you.

David Eserin 0 votes
Comment actions Permalink
0
Avatar

Try this.

 

Open System Preference, open Network. At the bottom of the connection list there is a settings drop down, select 'Set Service Order', then drag Ethernet to the top. Click OK, then Apply and now you should be able to use Rekordbox Link, even with Airport on and connected to the internet.Let us know if it worked for you.

David Eserin 0 votes
Comment actions Permalink
0
Avatar

Works for me :-). Strange, if I put Ethernet on top, then bluetooth and then Airport it doesn't work. With ethernet on top and second the airport it works fine.

Thanks a lot.

Twan Hovens 0 votes
Comment actions Permalink