Have a feature request or suggestion? Post your idea here!

Post

18 followers Follow
2
Avatar

Rekordbox 1.5.2 Feedback

Very Solid,

No Crashing and i hope it is fixed for many others,

With this and MT fixed we are looking like were onto a winner!!

Well done guys!

Nick Hilton

Post is closed for comments.

60 comments

0
Avatar

Cheers 'Nix, your feedback is appreciated.

Been testing this with a while and very stable thus far.

Gavin 0 votes
0
Avatar

Thank you so much for this update!! :) Finally I can see all my artwork in RB from my aiff files.

But I have one question: After re import my aiffs (I moved them from my iTunes libary and in to my "RB media folder", so I from now can skip the Bridge function)

 Why does the new tag show VBR in the bitrate column, when it showed 1411kbps when I used the Bridge function before?

TouchDown 0 votes
0
Avatar

Kinda odd on my end... right after installing I had the "uninstall rekordbox 1.5.1" selected, and the "start rekordbox 1.5.2" selected. Clicked "Okay" and started opening, but didn't show any of my information after about 3-5 seconds, then instantly crashed. lol

Error displayed, and I clicked "Reopen". Then it loaded fine. I'm not exactly sure why it crashed, but probably just something with the load up.

The only thing I seem to have a problem with... is a lot of my Cover Art has disappeared and been moved around. lol

I now have Dash Berlin on a couple Arty tracks, Armin on a D-Mad track, Stoneface & Terminal on an Arty and a Juventa track... yeah it's all over the place. This might have something to do with my Dropbox though. So I will investigate a bit and report back. I'll probably end up starting from scratch again.

Update: I'm not sure what caused the artwork change, but I just selected everything in RB (/Command + A), right clicked and selected "Reload Tag". Now they are under the proper tracks, but there might be a couple still missing the cover art all together.

Foster 0 votes
0
Avatar

@Foster > Interesting - I'll have to dump in some random artwork to see how things work on this end though I've been on 1.5.2 with a while and never noticed. Please let us know how the rest of the tracks fair.

Gavin 0 votes
0
Avatar

ugh. i hate itunes.  I will never forgive that program for what it just did to me.

Put in all my aiff files into iTunes that were downloaded from beatport and erased the ones on my desktop.  put them into rekordbox from iTunes and every single one had the "label" removed from the tags.  

anyway, i had a couple downloaded aiff files from today on my desktop that i put directly into rekordbox and they show up as VBR in the Bitrate field. However the ones through iTunes show 1411 kbps.

jamboe 0 votes
0
Avatar

refresh tags worked out that "label" issue.  guess i blamed iTunes too early.

jamboe 0 votes
0
Avatar

@travellingporn > Try reloading the tags. Has the artwork displayed correctly before?

Gavin 0 votes
0
Avatar

This was not explicitly answered in TouchDown's question:  Can we now skip the iTunes Bridge step when importing tracks into Rekordbox?  I hope so, that would eliminate at least 5min from my workflow, as well as having yet another separate iTunes library to manage.

pope 0 votes
0
Avatar

Yes you can skip the bridge function:) All the tags and the arwork is working except -1411 kbps- is shown as -VBR- in the bitrate column when using aiff, as mentioned in my comment above. Not a very big problem, just a little strange.

TouchDown 0 votes
0
Avatar

@pope > You never had to use the bridge function anyway...

@Touchdown > Noted re: VBR issue - will test and report.

@travellingporn > Great! Thanks for posting back.

Gavin 0 votes
0
Avatar

Found a few bugs - RB1.5.2

Rekordbox is crashing when a short track WITHOUT A GRID (is to short so RB won't try to find any bpm for it) is loaded into the player and clicking on one of the arrows beneath the waveform (the arrows that lets u move the grid).

Nobody needs to click on those arrows when that sort of tracks are loaded, but i just wanted to let u know .

OS - vista ultimate

The other problem/problems are bigger and more complicated to explain it/them. I need to send an audio file and the steps needed for replicating it.

@ Gavin

Can i have an email address?

It wont happen on any file. It is a track with a few loops at different bpm on it, sort of tracks the hip hop djs gather a few different loops on them. When changing the tempo (the grid) of a portion of that track , the program will act strange in that spot, when clicking on "4 beat loop" it will create a 3 beat loop . The cdj2000 will do the same if the 4 beat loop/ loop cutter is pressed in that spot of the track.

Marian Eugen 0 votes
0
Avatar

Hello

I have that problem that my rekordbox crash every time i try to delete or import songs, and when i scroll down i lagg some times, i waited for this update because i have lion on my 6 month ole mac book pro. have any of u seen that before ?

Christoffer Edwards 0 votes
0
Avatar

@Christoffer Edwards > Yes, I have the same problem, it does not scroll smooth.  this was also a recent thing for myself as it used to work perfectly.  i thought it might because I've reached a limit, in terms of files, allowing it to be smooth.  (1500ish)

It happens on my iMac and my macbook, both running Lion.

jamboe 0 votes
0
Avatar

same here, I just started noticing that more and more and I have 22,000 files so you having 1500 should be fine. When I first open RB it seems smooth but if I go to another app and come back to RB, it lags a lot

BriChi 0 votes
0
Avatar

i only have 2800 songs, can't import more it keep crashing every time i try  :S

Christoffer Edwards 0 votes
0
Avatar

Good job Pioneer! Can't believe I'm still using 1.3, as I'm afraid to be the guinea pig for the new versions, which after months of waiting turn out to be more buggy. Is there anyone that is not experiencing issues with 1.5.2?

kooba 0 votes
0
Avatar

i'm not :)  but that does not mean it is perfect, i have some issues with RB but nothing thats a show stopper

BriChi 0 votes
0
Avatar

to be fair, this was happening to me before the update. 

really, this has happened ever since i first tried to Bridge with iTunes.  

Before, when i had my tracks on my desktop and didn't use iTunes at all, it was as smooth as butter.

jamboe 0 votes
0
Avatar

I'm not using itunes and never would, so maybe I should give this a try. Anyone have issues unrelated to itunes?

kooba 0 votes
0
Avatar

If you are using Windows, be careful.  This 1.5.2 update is buggy.  Just do a search on this forum and you'll see people complaining (including myself).  You will be better off with 1.5.1.

 

If you are using Mac O/S you might be lucky.  I really believe that this update was targetted to this audience.

GlasEye2 0 votes
0
Avatar

At long last... my aiffs tag by them selves, and artwork too!  I had to reload the tag individually though, otherwise it seems my comments would be lost forever.

 

Win 7, working just fine for me after a couple hours of use.

Tycho 0 votes
0
Avatar

Individually because I was copying my comments, reloading the tag, then pasting the comments back in.  Thankfully most of my music was in mp3.

Tycho 0 votes
0
Avatar

how do i reload tags for all my songs? or do i have to reload them one by one?

aaron elliott 0 votes
0
Avatar

@aaron > Press "Command + A" to select all, then right click on a track and select "Reload Tag". If you have a large collection, it may take a while and could become unresponsive as it updated everything.

Foster 0 votes
0
Avatar

so besides aiff files or reloading tags, is the program stable? all i need is for it to not crash. has anyone tested it over ProDJ Link using a router? i'm on osx btw.

djchuckc 0 votes