Have a feature request or suggestion? Post your idea here!

Post

7 followers Follow
0
Avatar

No Link Icon

Everything was alright yesterday but today there's no link icon on RekordBox 2.0.1. There's no firewall on the laptop Win7 as it's only used for music, The CDJ900 link fine when I use a dive in the usb port so it must be something to do with RB. i've checked the task manager and the PSvLinkSysMgr.exe and PSvNFSd.exe are both running. The last time this happend it took a fresh install to cure it so what gives?

Si BooGie

Please sign in to leave a comment.

27 comments

0
Avatar

@Si BooGie > Whats your setup?

Did you have any Windows software updates recently? Have you enabled the Windows firewall to allow traffic? Do you have any anti-virus installed?

Gavin 0 votes
Comment actions Permalink
0
Avatar

@Gavin > this is a clean re-install of windows and re-install of RB, the firewall isn't enabled and there's no AV as this is strictly for RB. This laptop isn't used for the web or anything else. The link was working fine then I turned it on today and nothing. I had this problem before which made me do a complete format and re-install of windows and RB so I could remove any issue caused by anything else. RB was running like a dream no crashes,analysing music quicker. I'll do a re-install but what files do I copy over without risking copying over the file that controls the link as I have a feeling that part of RB is corrupted.
The network cables are fine, the network show as connected, the decks connect to eachother allowing the use of a USB drive between them. This has to be a RB issue.

Si BooGie 0 votes
Comment actions Permalink
0
Avatar

I have the same problem - it has a mind of it's own.  Pioneer are trying to make it too much like iTunes... basically for dummies. There's no manual control or advanced settings for people who know what they're doing.

What I want is a way to set the IP address (NOT DHCP!) in the CDJ2000NXS and DJM900NXS.... then in Rekordbox I want to specify the IPs of my equipment.  I'm sick of waiting for the unreliable searching of Rekordbox which not only adds to network traffic but also CPU load.

60-80% of the time Rekordbox cannot find my equipment (connected to a linksys router, all via cables).  My android phone can however connect.  I have no firewall or AV running and it's Windows 7.  If I turn everything off and on about 10 times then eventually it will detect it.

Also had more luck if I disable the default gateway and default DNS servers on my DHCP, so the router is basically acting as a switch (and the laptop then can't use the internet, nor can the phones, which is not acceptable).

 

Pioneer - PLEASE give us more control over what Rekordbox does!  Stop behaving like Apple.

 

Thanks

Matt

Matt D 0 votes
Comment actions Permalink
0
Avatar

Ok. So once again I've done a re- install of RB. It took a deep clean of everythin, registry etc as it seems RB leaves a lot behind. I tried it without a deep clean and it didn't work.

Si BooGie 0 votes
Comment actions Permalink
0
Avatar

Same deal. I did a fresh install of windows 7. Rekordbox was working like a charm now it wont link. I also have checked my windows firewall and have no anti virus what could we all be missing?

Ruesue 0 votes
Comment actions Permalink
0
Avatar

Give up using Rekordbox on laptop/PC until Pioneer give us the control to enter manual IPs into the decks AND specify those IPs into Rekordbox.  I honestly feel like an Apple user since I bought into this Rekordbox business!

Matt D 0 votes
Comment actions Permalink
0
Avatar

Here's another problem that needs sorting. I have a custom built desk with a built in power lead so on switch covers the decks, mixer, rmx and my router which us housed inside the desk. The problem is RB won't offer the link icon unless the router is on but also won't offer the link icon if the decks are on. This mean I have to lift the decks out every time to power cycle them. Why can't RB recognise a network present

Si BooGie 0 votes
Comment actions Permalink
0
Avatar

I have this problem today too and I am a mac user using Snow Leopard.  What the funk has happened?  It linked via a cable 4 nights ago and today it won't???? no updates done to rekordbox or the cdj's since????

 

I can link via wifi ok, not ethernet though...

Phillip 0 votes
Comment actions Permalink
0
Avatar

I'll be happy if Pioneer just accept that there's a fault and say they're fixing it.

 

Mr Pioneer??

Matt D 0 votes
Comment actions Permalink
0
Avatar

My Rekordbox will not link up with my PC wirelessly either, its version 2.01, windows 7 enterprise, firewall disabled.

This is so frustrating, it was working fine before updating the firmware on my XDJ and now it will not connect no matter what I do.

Please provide us with more control over the wireless portion, there is absolutely NO way to tell whats going on, just sitting there waiting for the magic symbol to appear.

I currently have a £900 brick which is useless.

Please sort it out.

 

Nik 0 votes
Comment actions Permalink
0
Avatar

Sorry.  Mine are linking fine wireless, but not via ethernet.  For all you people having trouble connecting up wireless - Are you using a dedicated router for the players that is not your internet router connected to your modem?  If not, you need to.  Rekordbox will not link on a router shared with your modem.

Phillip 0 votes
Comment actions Permalink
0
Avatar

Rekordbox doesn't know if it's connected to an internet router or separate switch + modem.  It simply needs to connect to a box which provides it an IP (or not - if there's no DHCP server on the network then the mixer will assign an IP I've found).  Rekordbox simply scans the network looking for CDJs within it's subnet I think.

Would be nice to have more technical explanation from Pioneer about how it actually works so we can do some troubleshooting.

There's only one thing I've found in the manual that might help, though I'm not home until tomorrow to test the theory.  It states that the Player number on the CDJs has to be the same as the channel that it's connected to on the mixer.  So, for example, you can't list it as Player 1 and 2 and then connect it to Channel 2 and 3 on the mixer.  Apparently.  I'll try it tomorrow and see.

Matt D 0 votes
Comment actions Permalink
0
Avatar

I have started a thread about the link function not working. It is terrible on Wifi, it just does not work. Version 1.6 just sits there flashing the link icon but too fast too connect, and 2.01 does not even give a link icon. I cant use my XDJ at all.

Nik 0 votes
Comment actions Permalink
0
Avatar

If you are using a XDJ Aero, why aren't you running it with Rekordbox 2.0.1 on your laptop? Are you using version 1.1.2 on your mobile device? These versions are far more stable than previous versions on both the Nexus and Aero series products. I have demoing these units for the last week with positive results on Mac platforms. I also cleaned my entire rekordbox collection and reimported all tracks via the bridge when going from 1.6 to 2.0. It was the best thing I did and my library is thanking for for it. These simple tips can help minimize errors in communication between devices. I had nothing but issues with the first two versions of the rekordbox app. All smooth sailing since.

Phillip 0 votes
Comment actions Permalink
0
Avatar

I've FIXED the problem I've been having!  Since getting these decks I've been totally unable to get a stable connection with Rekordbox. I have to restart everything about 10 times and if I'm lucky I might get the LINK icon in RB.  Android phones over WIFI always worked though which was strange.

 

Well, I think I've solved it!  Restarted all the kit 5 times and works every time now. Been playing for 2 hours going through RB dragging music onto the decks.

 

The solution???  Page 13 of the manual states that the mixer CHANNEL NUMBER and the CDJ PLAYER NUMBER must match!  I had my decks connected to ch 2 & 3 but were set as Player No. 1 & 2.  This also explains why the platter wasn't changing colour correctly as it should.

 

Now it's set as Player No. 2 & 3 to correspond to the mixer and it works perfectly! Every time!  :-D   Sooooo happy.

 

Setup: CDJ2000NXS x2, DJM900NXS, Linksys WRT610N, Decks+Mixer connected via cable, laptop/phones via WIFI.  Router is acting as a switch with a 2nd router serving DHCP and a separate server serving DNS.  Router connects via WIFI to the main router and all equipment has internet access.

Matt D 0 votes
Comment actions Permalink
0
Avatar

I take it all back!  It's absolutely shite.  Nothing has changed on my network and it's back to not working again.  1 in 10 reboots (of everything!) will fix it and i can play for a while.

Never known such unstable software / connection with anything before. This is horrendous.  And for 6,000 euros I expect better.

What are pioneer doing about the link issues?  All my equipment now has static DHCP assignments so the IPs don't change.  Connected via cable or wifi doesn't matter, hardly ever works. 

 

:-(

 

Customer's shouldn't have to do so much work to get a simple thing working after spending so many thousands of euros/dollars

Matt D 0 votes
Comment actions Permalink
0
Avatar

Yes, I agree with you, the link portion of the software does not work. I have raised a support ticket, I suggest you immediately do the same, or nothing will be done about this. I have not been able to use my XDJ Aero for over a week now, and although the phone support guy to be fair has been good and rung me back, I still havent heard anything.

They MUST know this is a big issue, please can someone acknowledge this problem?

Nik 0 votes
Comment actions Permalink
0
Avatar

I've tried and tried but can't find anywhere to contact them.

Matt D 0 votes
Comment actions Permalink
0
Avatar

I have been using my Aero without problem for the last fortnight. The software DOES work. When you connect your Aero to your smartphone. You need to press LOAD to connect to the Aero, not Connect. Connect is used for when you want to connect to Rekordbox.

Phillip 0 votes
Comment actions Permalink
0
Avatar

@Si BooGie, @Matt D, @Ruesue, @Phillip > Could you please post the log files:

PSvLinkAPILog.txt

PSvLinkSysMgrLog.txt

PSvNFSdLog.txt

They can be found in the following locations:

Windows7: C:\Users\user_name\AppData\Roaming\PioneerLog

Mac : ~user/Library/Logs

N.B. The files are overwritten on each startup.

Pulse 0 votes
Comment actions Permalink
0
Avatar

@Gavin > I resolved my issue, to a certain extent.  Due to my router and decks being on one power supply that is built in to my desk they are powered on together when I turn the mains on this mean RB won't pick up the decks unless I power cycle the decks. It's not a big issue but it does make me think what would happen if I took my laptop to a club and plugged it in, would I have to power cycle the deck there to get a connection? Chances are I would.

Do you want me to post the log files before or after the power cycle or do you want both?

Si BooGie 0 votes
Comment actions Permalink
0
Avatar

If it's about timing for when you connect the devices, it should eventually connect, unless there's just some weird glitch with your router.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Can anyone help me I have a xdj aero and I can't get it to connect to work llaptop I can establish a link as I can use the rotary controls and move up and down the tracks on the laptop but I can't load any tunes to either deck, then it eventually just says connection lost does anyone have any idea why

Bren Keverne 0 votes
Comment actions Permalink
0
Avatar

Pulse.....I have also the problem that from one day suddenly my laptop cannot connect with the systems anymore. Can you have a look at my logs please ? FYI...I only have this problem with my Windows7 O/S......with my Mac it works fine.

 

 

Ollever Buschan 0 votes
Comment actions Permalink
0
Avatar

@Ollever > Chances are it has something to do with your firewalls or network adapters using conflicting addresses.  Can you disable any network not in use by rekordbox / the players?

Pulse 0 votes
Comment actions Permalink
0
Avatar

yeppo...Pulse...finally no stress anymore......I had 2 VMWare network adapter running.....when I disable them the link is back......what a pain in the ass.......anyway....what a relief !!  Thx man !!

Ollever Buschan 0 votes
Comment actions Permalink
0
Avatar

@Ollever > Rekordbox and ProDJ link aren't designed to be used on your local network. They are much better off on their own, separate, network.

Gavin 0 votes
Comment actions Permalink