Have a feature request or suggestion? Post your idea here!

Post

7 followers Follow
0
Avatar

ongoing link issues

Hi there,

Basically to cut a long story short my cdj2000's connected to rekordbox wireless for ages through my laptop but recently that has just stopped and now the only way i can connect them is when they are wired. sometimes i get the link shown below but the cdj icons wont appear when wireless, i have tried all sorts including switching off the firewall etc, i was hoping the newest updates would sort this. both rekordbox and my cdj firmware are all up to date.  please can someone help? i also get buffering when playing tracks midway through a mix at times which can be very annoying although this appears to have calmed down.  the decks are connected through a hub.

 

Cheers

Adam

Insomniad1210

Please sign in to leave a comment.

17 comments

0
Avatar

Hey there, I ran into this issue before...but it only occurred when my rekordbox laptop couldn't communicate with my cdjs (loss of power, d/c cdjs/switch/router/wifi)

Having more details of your setup would help but do the following.

Shut down everything and unplug everything (hub, etc).

Turn on your laptop and go into rekordbox like you usually do.

Turn on your "hub" and wait for 2 minutes.

Connect your laptop to your hub (assuming its wireless from the look of your picture)

Once connected to your hub, connect the cat5 cables into your one/two cdj.

Turn on your cdjs and give them about 1 minute.

YOu should now see the LINK icon in rekordbox and if you click on it (as you mentioned, it worked before) it should work now.

Troubleshooting.  

If the following does not work, try changing the cables that are uses on the cdjs.

If that does not work, check to see if something is wrong with yoru hub power adapter.

If that does not help, try it with a different hub.

I cant help any further because I am not sure what kind of hub you have.  Is it a switch or a router?  There is no such thing as a hub unless you are speaking of a usb hub which doesn't work with usb..only routers and switches. 

Painless Wolf 0 votes
Comment actions Permalink
0
Avatar

Hey sorry about the poor description, i typed my message before going to bed,  appreciate your help mate.  I have attached more pics, I completely forgot I had a message saying "please permit it on the cdj to show icons"  any idea what the hell this means lol? i have attached a pic.  i also use a virgin super hub (wouldn't be surprised if this is causing my issues) shown on one of the pictures i have attached and you can see that my cdj 2000's are both connected to that via Ethernet cables and the Ethernet in the middle is the cable that plugs in to my laptop (also attached)  its very strange but when i have it plugged in to my laptop wired i switch off the wireless on my laptop and it connects and the icons appear but then i can switch wireless back on and the icons still stay active but as soon as i take it out the link tab vanishes along with the icons and just wont connect wireless.

 

i tried what you suggested and at first i thought it was going to work but the link message was just there but with no icons again.  now it just keeps flashing on and off again but with no icons still, more and more beginning to think its more related to the super hubs wireless capabilities as it works fine when i have it actually connected to my laptop.

the reason i replaced my old router originally was because of issues with my decks :S for the reason i stated with the buffering and tunes stopping mid mix.  the super hub sorted this to an extent but now i am having this problem and just not sure if its pioneers updates or whether its my super hub or both. i do not have another router to hand but i might try borrowing someone elses to see if that makes a difference.  think i might just stick to my trusty old technics. i wasnt able to go on my decks for a while and there may have been an update on the super hubs firmware since then as well when things have suddenly stopped working

 

appreciate your help, if you need any more info just let me know, thanks for your time

 

Adam

Insomniad1210 0 votes
Comment actions Permalink
0
Avatar

when i connect one of my cdjs directly from the deck to my laptop this connects fine as well

Insomniad1210 0 votes
Comment actions Permalink
0
Avatar

anyone?

just tried with my gf's macbook pro and its exactly the same :S

Insomniad1210 0 votes
Comment actions Permalink
0
Avatar

@Insomniad1210 > According to the engineers this is the expected behavior under the current hardware specifications.

Pulse 0 votes
Comment actions Permalink
0
Avatar

thanks for getting back to me pulse, will there be a solution to this problem, should i just wait?  i was thinking of buying a new router just to see if that worked but would that be pointless then?

Insomniad1210 0 votes
Comment actions Permalink
0
Avatar

I am going to do a video on how I set my thing up and we will see if that helps you. :D

Painless Wolf 0 votes
Comment actions Permalink
0
Avatar

cheers buddy, nice set up as well :) still no luck, think i'm just screwed lol pretty annoyed tbf.  going to just go ahead and get another router as well to see if that helps

Insomniad1210 0 votes
Comment actions Permalink
0
Avatar

Thanks. Just get the netgear switch that they suggested, it cost $100.  Give that and a shot...if it dont work just return it to the store you bought it.  Try not to buy a router, buy a switch first, my model or theirs.

Painless Wolf 0 votes
Comment actions Permalink
0
Avatar

Hi, I have the same problem here that my CDJs couldn't get access to recordbox at my computer.   I connect everything through DJM2000 via LAN cables.

MY reckordbox version is 2.0.7  My firmware on both CDJ are 4.2.0 and MY DJM2000 firmware is 3.19

 

I connect lan cable from my mac mini to com1 on DJM and connect LAN cables from CDJS to channel 1 & 2.    Usually after I press link on my  computer I will see see rekordbox is one of an options but now I only see CONTROL MODE and DJM-2000.   And on my computer screen says "Please permit it on the CDJ to show icons"     

Electum Goldensun 0 votes
Comment actions Permalink
1
Avatar

Please Help, what I have to do with "Please permit  it on CDJ to show icons" because on CDJ there was no rekordbox option available anymore!!    

Only thing I can do is to transfer my music to USB and plug it into CDJ then both of them are LINK.

But I don;t want to transfer to USB every time, I want to just connect with my computer like before.  Is it still posible?

Electum Goldensun 1 vote
Comment actions Permalink
0
Avatar

Is there any update to this problem?

Wireless have worked before but now i also get this message when connecting wireless.

Wired works. Wireless i get "please permit it on the CDJ to show icons",  what is this message suppose to mean?! 

Show ICONS? Can somebody tell me how to premit them to show icons?

Bjoervik 0 votes
Comment actions Permalink
0
Avatar

Im using Rekordbox 2.0.7 and CDJ 2000 v4.10. Windows 8, x64. Firewall disabled.

Bjoervik 0 votes
Comment actions Permalink
0
Avatar

Hi Guys,

I just gave up tbh and use my stuff wired, pretty annoying really considering its pioneer and you would expect them to sort it.  technics1210's forever!  I haven't had that message pop up in a while.  The link sometimes comes up but then when I click it it's just the same but without the message like shown in my first message back in OCTOBER!

maybe there is a way to get an older version of rekordbox back, not sure if that is possible or if i have tried that already.

Insomniad1210 0 votes
Comment actions Permalink
0
Avatar

just click on the reckordbox-icon on the cdj, then you get a message that you need to click the rotary-button to accept wireless link. Do that on one of the cdj's linked, and you have access to all recordbox tunes on the wireless laptop

Øystein Hansen 0 votes
Comment actions Permalink
0
Avatar

This problem is still happening I have tried installing new firmware, rekordbox upgrades and downgrades. I've tried new LANs and routers. tried a million cables. my XDJs link together OK so its not that. I wish Pioneer would tell us a bit about the software being used, perhpas there is some problem there. is it zeroconf  or something?  perhpas some windows cache needs flushing.  the XDJs link together OK and that proves the network is working and that the autoconf, whatever it is is working.  I've only got switches, if I had a HUB I'd tcpdump and try to work out what is going on.

teknopaul 0 votes
Comment actions Permalink