Have a feature request or suggestion? Post your idea here!

Post

5 followers Follow
1
Avatar

CDJ2000's just say "wait" when linked to Rekordbox 2.0.1

Hi guys,

I upgraded to Rekordbox 2.0.1 and it was working absolutely fine for a while. 

 

All of a sudden, whenever I press link on my CDJ2000's, they simply show a spinning circle saying "WAIT".  I've waited over 10 mins and still nothing happens.

 

The only thing I can think of that I changed in Rekordbox was that I changed the "category" order, by moving 'folder' to the top of the list.  

However, I've since tried moving 'folder' to the bottom of the list, and even removing all the categories that it will allow me to remove, yet the problem remains.

 

The CDJ's and my mixer (DJM900) show up fine in Rekordbox.  They are connected via a switch, and have worked fine in the past.  I have tried disabling windows firewall completely, disabling anti virus, disabling wireless connections etc, but with now luck.

 

Has anyone experienced this continuous "WAIT" before when trying to link CDJ's to Rekordbox?  

 

I have absolutely no idea what else to try, so any help would be much appreciated.

 

Thanks!

Nemes1s

Please sign in to leave a comment.

7 comments

0
Avatar

Try reformatting your media device and put 1 track in it to test it out first and after that put as much as you had on it.

Also, what kind of media do you have? usb HDD, SD card, USB flash drive? 

Painless Wolf 0 votes
Comment actions Permalink
0
Avatar

Sorry, I mean actually playing tracks directly FROM Rekordbox.

So, if I open Rekordbox, click Link in Rekordbox, the CDJ's and DJM show up as icons, I then press LINK on the CDJ2000, it shows Rekordbox as a link option, and if click into it,  then it simply says "wait" with a spinning circle around it.   :(

I think it's related possibly to the Rekordbox database becoming corrupted.  If I delete 'datafile.edb' then it works.   However, I really don't want to have to delete the database file as then I'll lose all my collections/tags/colours/ratings etc.

Any idea would be much appreciated.  

Nemes1s 0 votes
Comment actions Permalink
0
Avatar

i too have got the same problem,just updated to 2.0.1 now it says wait and nothing happens but when i store version 1.4.1 it works

Marvin Mphoola 0 votes
Comment actions Permalink
0
Avatar

No one seems to be offering solutions unfortunately Marvin.  The only way I could fix it was to delete the Rekordbox datafile.edb.  It works again now, but I lost the whole collection, so I'm just praying it never happens again.  Hope you got yours sorted out ok in the end.

Nemes1s 0 votes
Comment actions Permalink
0
Avatar

no needed to uninstal database. just uninstall old version of rekordbox, and then install new version and re-analized files. same problem have.

Sonare 0 votes
Comment actions Permalink
0
Avatar

I get this problem. Just closing RB and starting it again usually sorts it (and sometimes I have to power cycle the CDJ as well) - but it's not good.

Geoff 0 votes
Comment actions Permalink
0
Avatar

@James Pollock > I've had an engineer contact me in relation to your issue.

As you are using rekordbox on Windows, please replace "DBServer.dll" in the following folder: 

C:\Program Files\Pioneer\rekordbox 2.0.2

with the one for your download here: 

https://www.dropbox.com/s/w7s3l99k8liqban/DBServer.dll

To replace it, an administrator account will be required:

http://windows.microsoft.com/en-US/windows7/How-do-I-log-on-as-an-administrator

Gavin 0 votes
Comment actions Permalink