Have a feature request or suggestion? Post your idea here!

Post

6 followers Follow
2
Avatar

[CLOSED] updated to Rekordbox 3.2.0 - crashed within 5 minutes

Like some others I've been having constant crashing since updating to Yosemite.

When I saw there was a Rekordbox update I had hoped the troubles may be at an end... but still the same as before. Whilst playing tracks in the preview pane, it lasted about 5-6 minutes before crapping itself.

 

The important functions of the software are still working, the bugs are a real nuisance though.

 

Any suggestions?

crash log available if required.

 

o/s: Yosemite 10.10.2

processor: 2.7 GHz Intel Core i7.

memory: 8 GB 1333 MHz DDR3.

graphics: Intel HD Graphics 3000 512 MB

 

Mike Barty

Post is closed for comments.

50 comments

0
Avatar

Sorry Pulse! Rekordbox has crashed on the first track playing... Lasted about 2.5 minutes

Richie Barthez 0 votes
Comment actions Permalink
0
Avatar

Thanks for trying it out @Richie, that tells our engineers at least that wasn't the solution and there's something else worth investigating. Can you go to your Finder, from the menu select Go > Go to Folder... and enter this location: ~/Library/Pioneer/rekordbox/Crashes

Attach the most recent crash logs pls!

Pulse 0 votes
Comment actions Permalink
0
Avatar

@Pulse Strange but this only shows the latest crash date as 31st Jan ?

Could it be elsewhere?

Richie Barthez 0 votes
Comment actions Permalink
0
Avatar

Interesting, I wonder if it hadn't generated a crash report or if they were sneaky and moved it... why don't you post that one anyhow.

Pulse 0 votes
Comment actions Permalink
0
Avatar

@Pulse yeah there's probably been at least 10 - 15 crashes since 31 Jan. 

Richie Barthez 0 votes
Comment actions Permalink
0
Avatar

@Pulse Earlier I repeated the process and changed the value back to "0" and back to "1" again. It hasn't crashed since - I've also analysed my entire library without any crashes. I think that might might be the solution for mac users ?? 

Richie Barthez 0 votes
Comment actions Permalink
0
Avatar

REKORDBOX is a JOKE... Is getting WORST than TRAKTOR and SERATO.. Keeps Crashing. CAN SOMEONE FROM PIONEER PLEASE TELL ME WHAT TO DO IN THE MEANTIME TO SPOT THE CRASHING. it has to be something to stop this. any code etc?

JuanCarlos Sanchez 0 votes
Comment actions Permalink
0
Avatar

@JuanCarlos. Seriously try the change that Pulse suggested. I know it's not ideal but if it fixes the issues for now then great! Make sure you copy and paste the "1" bit. Don't re-type it. 

My crashing seems to have stopped since!! 

Richie Barthez 0 votes
Comment actions Permalink
0
Avatar

@Richie Barthez if I try this it would stop crashing? and what are the chances that by changing this digit nothing else is going to break?

JuanCarlos Sanchez 0 votes
Comment actions Permalink
0
Avatar

@JuanCarlos - As another frustrated Yosemite user - It has worked for me and I've been using Rekordbox a fair bit since making the change earlier. It's worth a try as I know how annoying the crashes are (especially when you've made loads of changes and lost the lot on previous crashes) 

Richie Barthez 0 votes
Comment actions Permalink
0
Avatar

I've changed the above setting and this seems to have stopped the crashing which is a positive thing

 

...but it also has the side effect of creating even more lag in every area of the software - it makes my macbook seem like it's an old slow piece of crap computer when I know this machine is rapid and handles everything I throw at it in a blink...

 

some work to do at Pioneer hq I think !

Mike Barty 0 votes
Comment actions Permalink
0
Avatar

@MikeBarty - Weirdly enough I've been working on Rekordbox all night too without a single crash but it's been super fast without any lag... but I had iTunes open as I was working between the two libraries and updating tags. What's weird is I have just shut down iTunes and proceeded to work in Rekordbox and now Rekordbox has got a 30 second or so lag. If I click on something it goes stupidly slow. I have no idea why this is happening but try having iTunes open and see if that reduces the lag.

Richie Barthez 0 votes
Comment actions Permalink
0
Avatar

@Richie > Thanks for reporting back, good to hear it's at least not crashing! That gives the engineers something to work on.

@JuanCarlos > You have nothing to lose by changing the settings file, and everything to gain. Instead of jumping into the thread with a rant about how nothing works properly, how about you be polite and in exchange we'll be happy to help you get things working?

@Mike > The change in performance is expected as the OpenGL is a graphics programming language to render 2D and 3D content onscreen. With it disabled, the hardware must process the graphics instead of the software (which is more efficient, but apparently interfering with something causing the crashes).

Pulse 0 votes
Comment actions Permalink
0
Avatar

I've now changed the settings back to the original 0 value and still hasn't crashed after 15 mins of playing tracks on the dual preview pane (always just laptop for me, no pioneer hardware connected)

Lag has gone back to a lesser extent but it's still very sluggish, there's definitely something not right somewhere.

 

hope they can solve the issues soon

 

 

Mike Barty 0 votes
Comment actions Permalink
0
Avatar

interesting.... so have we then established that it's something to do with the way the software uses OpenGL with Yosemite ? 

Mike Barty 0 votes
Comment actions Permalink
0
Avatar

The engineers seem to think so, hence their recommendation to change the setting!

Pulse 0 votes
Comment actions Permalink
0
Avatar

@Richie Barthez I try what you and @Pulsed suggested. So far no crashes... Well right now Im only Disabeling (Lock) the track analysis to my tracks. this is the new feature on the 3.2 version. it was crashing but it stop. Im going to edit some tracks in the next days I`ll let you know if it crash or not.

JuanCarlos Sanchez 0 votes
Comment actions Permalink
0
Avatar

Marking this topic as closed; the "Waveform Drawing" checkbox in the rekordbox settings should resolve crashing issues and work is continuing to improve the quality of the application for those complaining about the quality of the waveform after disabling this feature.

Pulse 0 votes
Comment actions Permalink