Have a feature request or suggestion? Post your idea here!

Post

2 followers Follow
0
Avatar

[SOLVED] Loading Track into Deck with Keyboard Broken in v3.2.1

As of Rekordbox version 3.2.1, loading a track into a Deck by hitting the Return or Enter key no longer works.  Only double-clicking or using a mouse-dragging a track onto a player will load a track onto a Deck.  Really annoying, makes Rekordbox much more slow and inefficient to use.

smilinggoat

Please sign in to leave a comment.

28 comments

0
Avatar

Same issue.

I mapped Cursor Left for player 1 and Cursor Right for Player 2.

Now it's asking for key combinations such as Option+Left or Ctrl+Left. I can't have a single key shortcut.

Please rectify Pioneer!

Shªun_N 0 votes
Comment actions Permalink
0
Avatar

Thanks for your reply, DJ S-Type. I was looking through Keyboard preferences in Rekordbox and I couldn't find a place to assign a keyboard shortcut to loading onto a deck. How is yours set up?  Thanks!

smilinggoat 0 votes
Comment actions Permalink
0
Avatar

Well, I have it set to Option+Left / Option+Right but they don't work.

None of my key combinations work.

Also, Link doesn't work anymore!

Pioneer... what have you done?

Shªun_N 0 votes
Comment actions Permalink
0
Avatar

Link should be working, but I've just looked through the keyboard assignments and don't see any for loading tracks to the (virtual) players.

Pulse 0 votes
Comment actions Permalink
0
Avatar

If your link isn't working, it could be due to the firewall not allowing the new application (if you have the firewall enabled); each version of the program appears as a different application looking to get through the firewall and rules must be set accordingly every update.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Ah, actually, turns out it's a selection issue.  If you click on a track in a playlist, the selection of that track will stay GRAY, meaning that the track selection is not "in focus".  You have to hit Tab to bring the playlist selection into focus and have the playlist show up BLUE. Then the track can be loaded with Return or Enter. Really confusing.

So it looks like the bug is not in the keyboard, but the lack of switching focus to the playlist when a track is clicked.

smilinggoat 0 votes
Comment actions Permalink
0
Avatar

If I click on a track in the playlist, it turns purple. Pressing Enter loads the track and the focus is now the player, turning the selection grey.

Where is the problem?

Pulse 0 votes
Comment actions Permalink
0
Avatar

When I click on a track in the playlist, it stays gray.  Pressing Enter does nothing.  If I hit Tab, the track in the playlist turns purple. Pressing Enter loads the track.

Clicking on a track does not bring the playlist into keyboard focus, the keyboard focus remains on the player (thick white playhead indicator) until Tab is pressed.

Rekordbox 3.2.1, Mac OS X 10.10.3

smilinggoat 0 votes
Comment actions Permalink
0
Avatar

Exactly how I'm finding it smilinggoat.

I still can't drag tracks onto my players though :(

Shªun_N 0 votes
Comment actions Permalink
0
Avatar

@smilinggoat > Where are you clicking on the track? Anywhere I click, on any track within the playlist, turns purple.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Anywhere I click on a track in a playlist, this happens. I've attached a video showing my clicking and keystrokes.

smilinggoat 0 votes
Comment actions Permalink
0
Avatar

Okay, there is something odd going on there - because any time I click in my playlist, the track selection follows in purple.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Problem solved - Trashed 3.2.1 and reverted to 3.1.0

Selected tracks highlight blue/purple and don't loose focus.

Link is also now working again with 3.1.0, however I have had to disable my Firewall. Odd really I it worked before with all services in Firewall settings.

Also, with 3.1.0 I was able to assign one-button shortcuts but for some reason now I have to use a two-key combination.

Maybe rekordbox 3.3 soon?

Shªun_N 0 votes
Comment actions Permalink
0
Avatar

Okay, so the reason the single-key mapping was removed is there was a change in specification with 3.2.1 - if you type in “a” when a cursor is within the track list, it will jump to the track name starting from “a” in the track list.  If you assign a single key to “Link Export: Load track to player”, the cursor will automatically jump to a track whose name starts from the key you typed, so you will fail to load the track you wanted. This is why the specification was changed. 

Pulse 0 votes
Comment actions Permalink
0
Avatar

How about the selection of tracks not in focus?
As smilinggoat says, and I can confirm, you have to press Tab in order to make
the track list in focus.
On 3.1.0 which I am using, you sinply click the track and it becomes highlighted.

Shªun_N 0 votes
Comment actions Permalink
0
Avatar

Thanks for your help, Pulse, but I wouldn't count that as an answer solving this.  It certainly seems like a bug if clicking on the playlist does not bring it to the foreground for keyboard selection.

smilinggoat 0 votes
Comment actions Permalink
0
Avatar

The answer was for that one issue, and because there are two separate issues in this thread, I hadn't yet gotten around to the 2nd ticket which has this as the possible solution for the focus (you guys beat me to the punch!)...

Go to the Preferences > View and toggle the waveform setting:

Screen Shot 2015-04-10 at 12.41.09 PM.png

Pulse 0 votes
Comment actions Permalink
0
Avatar

Just tried toggling the waveform drawing, restarting Rekordbox in between toggles.  No dice, keyboard focus still does not work properly.  Thanks.

smilinggoat 0 votes
Comment actions Permalink
0
Avatar

Hey guys, regarding the focus - could you please go into the preferences and on the View tab, try unchecking this box:

Screen_Shot_2015-04-21_at_10.29.07_PM.png

...and test the focus issue again?

Pulse 0 votes
Comment actions Permalink
0
Avatar

(You may still need to press the tab key before pressing return / enter to load a track.)

Pulse 0 votes
Comment actions Permalink
0
Avatar

Hi Pulse, unchecking "Display Cue Markers on Preview" did the trick. When it is turned off, keyboard focus works as expected.  Thanks.

smilinggoat 0 votes
Comment actions Permalink
0
Avatar

@smilinggoat

Does this work as normal now withouy having to use tab to focus?

Shªun_N 0 votes
Comment actions Permalink
0
Avatar

Once a track is purple in the playlist, it will remain purple, and allow selecting different tracks using keyboard arrows or mouse clicks without them turning gray, thus allowing enter or return to be used to load a track as expected.  Once a track is loaded onto a player, the playlist selector becomes gray (as expected) and keyboard control is focused on the player. Clicking on a track in the playlist or hitting tab returns the purple selector to the playlist area as expected.

 

In other words, unchecking "Display Cue Markers on Preview" restores expected playlist selection behavior.

smilinggoat 0 votes
Comment actions Permalink
0
Avatar

Engineers are working on that, until now, at least you have the work-around.

Pulse 0 votes
Comment actions Permalink
0
Avatar

3.2.1 now working.

I rarely use the rekordbox player so my track list is pretty much always in focus now.

@smilinggoat - Are you on Mac? I use a program called BetterTouchTool which you can create custom shortcuts and app-specific.

I've now assigned my desired one-click keyboard shortcuts for rekordbox which makes things easier :)

Shªun_N 0 votes
Comment actions Permalink