Have a feature request or suggestion? Post your idea here!

Post

2 followers Follow
0
Avatar

Cue button not working

Hey so the issue I am having is that the Cue button on my CDJ900 is having difficulty engaging and more often than not, not engaging at all. I have had this happen before, and I took it in to a pioneer service center, but they said they were "unable to repeat the issue", but once I got it back from them it seemed to be working fine. But as of this month it has started up again and is driving me nuts. Any suggestions on how to fix it? I've included a video to help clearly show the issue and thank you ahead of time for the help.  http://www.youtube.com/watch?v=JMPa80ZNNGM

 

p.s. it has the most recent firmware and has the issue with both CDs, WAVs, and Mp3s.

djachillle

Please sign in to leave a comment.

3 comments

0
Avatar

@djachillle > Seems to me the blister-switch under the cue button on the left player is problematic; if you're under warranty it will be replaced at no-cost.  Please contact technical support from the contacts at the right to locate an authorized repair shop near you or send it to Pioneer official.

Pulse 0 votes
Comment actions Permalink
0
Avatar

@Pulse> Thank you for the help. It is not under warranty anymore, but I'm willing to pay to have it fixed. Would you happen to have pioneer's official support center's address?

djachillle 0 votes
Comment actions Permalink
0
Avatar

@djachillle > Sorry, you'll have to use the contacts at the right.

Pulse 0 votes
Comment actions Permalink