Have a feature request or suggestion? Post your idea here!

Post

3 followers Follow
0
Avatar

Traktor Pro 2 issues

I've had my DDJ T1 working fine with Traktor Pro 2 (2.0.3), however, I updated to the latest version (2.1.2) and now I can't work Traktor at all.

On startup, I get "could not read the default settings file for audio auto configuration. Please rerun the installer". Another message displays "Missing controller TSIs".

I've no idea why this would happen all of a sudden when it's been working fine beforehand. I've uninstalled, reinstalled, even restored my system to a previous date but still these messages popup, and so I have a £750 piece of equipment which I cannot use. I've messed around with all the settings I can imagine. The setup wizard can't even be started!

NI forums and support don't seem to be bothered. I've spent hours & hours browsing the 'net for solutions but to no avail. Would a reinstallation of Windows be the answer? Anyone else experiencing these issues?

Shªun_N

Please sign in to leave a comment.

4 comments

0
Avatar

@S-TYPE > My suggestion would be for you to go get Revo Uninstaller and use it in the advanced mode to remove ALL of the Traktor / NI files from your computer, then install Traktor once again.  If that doesn't help, let me know.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Hi,

I actually used Perfect Uninstaller & deleted all traces & leftover files. Also deleted the system registry for everthing Native Instruments. Re-installed TP2 and it worked, thankfully!

 

Cheers

Shªun_N 0 votes
Comment actions Permalink
0
Avatar

Did you ever get it sorted? It sound as though the TSI didn't import correctly so would need to be done manually. It's possible that the audio config is also part of the file but check what sound card is selected if the option is avaialble.

I use TSP 2 so I'm not sure what the menu looks like on the Pioneer edition

Si BooGie 0 votes
Comment actions Permalink
0
Avatar

@DJ REDSS > While I appreciate your enthusiasm for contributing to the threads here on the forums, you can see from his last post that he did get it working.

Pulse 0 votes
Comment actions Permalink