Have a feature request or suggestion? Post your idea here!

Post

2 followers Follow
0
Avatar

[SOLVED] Retina Macbook Pro + Pioneer DJM 900 + Traktor = :-(

Having problems getting the timecode (either vinyl or CD) to work by plugging my retina MBP directly into a Pioneer DJM 900. I've set it up in exactly the same way as I did my non-retina Macbook and although I can play audio (from my mac through the pioneer) - it just won't see the timecode signal... works fine with my Audio 10 but really want it to work with the 900 as that's why I bought Traktor in the first place.

I'm using Pioneer's driver etc and I've checked everywhere and can't seem to find anyone else with this problem - guessing it might be a Retina problem?

Any help would be awesome!

DJ Octo

Post is closed for comments.

9 comments

0
Avatar

@Octo > Have you tried this since? Have you tried the setup without using the Audio 10?

Gavin 0 votes
Comment actions Permalink
0
Avatar

Gavin....  I've tried a bunch of times and since no new drivers have come out since then; no I haven't tried it recently.... And yes I've tried using it without the Audio 10 - that's the problem; it doesn't work with the control vinyl WITHOUT the audio 10; therefor I have to use the audio's outputs and avoid plugging straight into the mixer via USB (which is what I could, and want to be able to do)

DJ Octo 0 votes
Comment actions Permalink
0
Avatar

Have you configured the DJM-900 routing within the Pioneer settings program? If you haven't routed the signal as TIMECODE, it won't go to the software from the inputs.

Pulse 0 votes
Comment actions Permalink
0
Avatar

I had it all working like a dream on the non-retina MBP - then went all wonky with the retina with exactly the same settings... sound comes out but won't see control vinyl... I'm wondering if it's something to do with the USB3 ports on the MBP?

DJ Octo 0 votes
Comment actions Permalink
0
Avatar

@DJ Octo > Thanks, I've asked the engineers if they have experienced issues with the retina-generation MBP's and I'll follow-up with you when I get a response.  Thanks for your patience.

Pulse 0 votes
Comment actions Permalink
0
Avatar

@Pulse ...awesome news!! FYI I played with A-Trak recently and explained this situation to his sound tech (because we were both using the 900 and I was using the Audio10) and he said that's one reason they hadn't switched to the retina yet - not that they'd had that problem; but were worried about smooth transitions.

Anyway, thanks again for following up - I'm very curious to hear what your tech guys find out!

DJ Octo 0 votes
Comment actions Permalink
0
Avatar

@DJ Octo > The engineers have tested this issue using a MBP Retina, but it worked without any problem. They did not find any problem when using USB 3 either. They would like to know more specific information about the setup to help sort out this issue:

  1. Firmware version of DJM-900NXS 
  2. Model number of MBP Retina (can be found under Apple > About This Mac > More Info > System Report > Model Identifier)
  3. OS version he uses 
  4. Do you use Traktor Scratch Pro 2? If so, which version? 
  5. If the above  #4 is NO, name and version of the Traktor product. 
  6. Can you input audio from the computer to DJM-900NXS without using Timecode? 
  7. When you select [Input Routing] for a deck from [Preferences] of Traktor and use Timecode, does the level meter on the deck selected for Input Deck move?

Thanks!

Pulse 0 votes
Comment actions Permalink
0
Avatar

I had the same problem with my DJM850 but as Pulse said it was down to the timecode setting; open your utility program and click on the Mixer Output tab then set the channels connected to your turntables/CDJs to timecode (I've attached a screen shot of my settings) and it's done! It's not very clear and like you my non retina macbook worked straight away without changing anything but the retina needs to get setup. You only need to do it once though after that it works like a dream!

Kevin Ping 0 votes
Comment actions Permalink