Have a feature request or suggestion? Post your idea here!

Post

1 follower Follow
0
Avatar

[CLOSED] Mystery with Traktor Pro Audio Preferences & Mixer

Hey guys!

I've have recently changed to a mac book pro. I have the following external setup: 2 x CDJ 900 & DJM 700.

Before you start reading, I know DJM 700 isn't usb compatible and I don't want to connect the mixer to the laptop via MIDI, using any type of soundcard.

 

My Problem : Before when I was using a Windows laptop I was able to get the Channel 1 & 2 + Master channel on the mixer (DJM-700) working as usual, while having the cdj 900s connected to Traktor. This means that I can mix externally while having just the cdj 900s connected to Traktor.

I connect the cdjs via usb (no problem).

Now here's the problem with the Channel 1 &2 + the master output on the mixer. I want  to use the mixer as you usually do, having the master out put from the mixer and Deck A = Channel 1, Deck B = Channel 2, while having the cdj 900s connected to Traktor. I was able to do this on my laptop running Windos. I could still get the master output from my mixer to the laptop (Traktor) and mix, while the cdjs were connected in Traktor at the same time, loading tracks via using Control Mode (USB Midi).

Here is the weird part:

When everything is connected and audio preferences are set up in Traktor (see below). While playing  both tracks from Deck A & B at the same time, all the audio comes out of channel 2 on the mixer. Not like it usually does on the mixer = Track on deck 1= Channel 1 , Track on deck 2 = Channel 2. And both decks at the same time = main.

To clarify:

On the mixer, the master channel is dead. And both tracks are coming out of channel two, showing green bars.

I guess the audio settings in Traktor is wrong. I've done the setup wizard, but can't find a solution.

Before, when using Windows. I was able to get the Channel 1 & 2 + Master channel on the mixer working as usual, while having the cdj 900s connected to Traktor.

 

External connections:

Cdjs (900) are connected to Traktor via USB. Cdjs are also connected via RCA to the DJM-700.

My master output from the mixer is connected to my loudspeakers as usual, and then the loudspeakers (Line in) are connected via AUX into the laptop (via the headphone jack). I've connected the Line in from the loudspeakers to the laptop headphone jack to get the master output from the mixer to traktor.

This is the exact same external setup I had when it was working on Windows.

 

Preferences in Traktor:

Preferences -> Audio Device = PIONEER CDJ 900.

I can choose from two PIONEER CDJ 900 from the Audio Device tab, I get the same audio result no matter which one I use. (Same as before on Windows)

 

Preferences -> Output Routing -> Mixing Mode = External (Because I'm using the DJM 700)

When picking the Output for Deck A (L & R) + Deck B (L & R). I can only pick:

1: Front Left

2: Front Right

 

Before when I was using Windows I was able to pick: 1: CDJ 900, 2: CDJ 900, 3: CDJ 900, 4: CDJ 900

On Output for Deck A I put:

L: 1: CDJ 900,

R: 2: CDJ 900

On Output for Deck B I put

L: 3: CDJ 900

R: 4: CDJ 900

 

Using these exact audio preferences and external setup, I was able to mix with DJM 700 as usual with all the channels and master output working, while having the CDJs connected to Traktor. How can I do this on my new Mac Book Pro? I think the problem is in Traktor -> Audio preferences.

 

Please help me, thanks!

Axel Jacobsson

Post is closed for comments.

3 comments

0
Avatar

@Alex > You only need to post your issue once - we'll get to it.

It sounds to me like you haven't run the CDJ Aggregator to separate the audio channels on your Mac.

Gavin 0 votes
Comment actions Permalink
0
Avatar

This topic has been closed due to inactivity. Should you require future assistance with this issue, please create a new topic describing the problem and provide the URL of this topic as reference.

Pulse 0 votes
Comment actions Permalink