Have a feature request or suggestion? Post your idea here!

Post

4 followers Follow
0
Avatar

Rekordbox freezes + no waveforms after recovering missing files

I keep my music on my external HD drive in 3 folders. (about 20.000 mp3 files).
I've imported them all in the collection to analize and tag.
I did a test where i have changed the name of 1 of my folders with the predictible outcome that now Rekordbox doen't find the files anymore.
When i try to recover the missing files i do all that is required and recordbox does find and play again the files.

BUT!!

Now all the waveforms and tags are gone and Rekordbox keeps on crashing!!!!!
What is this?? Is there a solution?
This way it means that, once you've imported your songs to the collection in Rekordbox, you never ever can change or replace your music folder anymore! And if you do, even by mistake, you'll loose 100= hours of work!!

Thanks if anyone can help with this!

Tim Staes

Official comment

Avatar

This was actually fixed in 4.0.1 but was omitted from the release notes.

Pulse
Comment actions Permalink

Please sign in to leave a comment.

22 comments

0
Avatar

Nobody?
Problem is only on a Mac. On windows this is working fine...

Tim Staes 0 votes
Comment actions Permalink
0
Avatar

@Tim > You posted at 5:58am, and asked for an update a mere 5 hours later?

I don't know if you've noticed that there are literally hundreds of new posts daily and I'm having a bit of a hard time addressing all of them, especially when I need to ask many back-and-forth questions because the users aren't providing sufficient details in their posts to be able to provide any kind of genuine support. So without further ado...

  • What is the operating system version?
  • What exactly was the change in directories (please provide the old/new paths)?
  • Is the database located externally?
  • Are you sharing the same database between Windows and Mac installations?
Pulse 0 votes
Comment actions Permalink
0
Avatar

Hello!

  • OSX Yosemite 10.10.5
  • Ive just changed my main folder 'music' to 'music1' to test how rekordbox behaves when you restore missing files.
  • Master database is located on my external HD (makes no difference with files on my harddrive because rekordbox has also this problem when my folder is located on my harddrive)

Today i did the same test on a different Imac with the same results. So it is without a doubt a problem between OSX and Rekordbox.

So again the problem:
Renaming a folder - Rekordbox tells files are missing - relocate (correct way) - Rekordbox finds again the songs in the collection and can play them - when closing Rekordbox and restart again, Example of waveforms are missing and Rekordbox crashes after 5 minutes (before crashing i still can play the songs) really strange that the example waveforms are missing

Thanks for the help!

PS : i also did this test on a windows pc - no problems at all

Tim Staes 0 votes
Comment actions Permalink
0
Avatar

I had this issue, have you exported any playlists to the same HDD to use in the CDJs?
If you have files will be created in the ".pioneer" this caused Rekordbox to constantly crash and lag.

Lee Murphy 0 votes
Comment actions Permalink
0
Avatar

Have the same problem, but haven't seen any crashes. Just no previews on any relocated files.

DJphasim 0 votes
Comment actions Permalink
0
Avatar

Seems to be a bit of a hiccup in reassigning the correct waveforms and overviews. I'll pass this along to the engineers. Thanks!

Pulse 0 votes
Comment actions Permalink
0
Avatar

Thanks Pulse for the update! I have noticed that it's fixed now!

Tim Staes 0 votes
Comment actions Permalink
0
Avatar

Still doesn't work in 4.0.1... all my files have been analyzed and are locked. I moved the music into a different folder and I still don't see the preview. In fact, it's so annoying I don't even use the preview column anymore.

DJphasim 0 votes
Comment actions Permalink
0
Avatar

@Slimshady > Did you quit / re-load rekordbox after relocating the tracks?

Pulse 0 votes
Comment actions Permalink
0
Avatar

I figured it out. For all files that get relocated in 4.0.1, the problem doesn't occur anymore. The preview remains and doesn't go away.

However, any previews that were lost because a file was relocated in v4.0 (which is like 85% of my files) does not generate a new preview. That just isn't a workable solution. I just want to emphasize that re-analyzing these file IS NOT a solution because I've spent a significant amount of time doing this already and the files are locked. They are gridded correctly.

What's the next step?

DJphasim 0 votes
Comment actions Permalink
0
Avatar

I would suggest the ability to re-generate a preview without affecting the existing grid. Basically, it is just re-scanning the file for cue-points and generating the wave, not the beatgrid.

DJphasim 0 votes
Comment actions Permalink
0
Avatar

The preview is generated with the overall waveform, you'll have to either load them one by one to have it rebuilt or simply re-analyse them.

Pulse 0 votes
Comment actions Permalink
0
Avatar

It doesn't work. Do you want me to host a GotoMeeting so you can see?

DJphasim 0 votes
Comment actions Permalink
0
Avatar

I have no problems anymore. I can change songs from folder to folder or rename folders, all is ok now.
(i'm on a Mac OSX Yosemite - RB 4.0.1)

Tim Staes 0 votes
Comment actions Permalink
0
Avatar

@Tim Yep, it works if you change folders now and can re-locate the preview. But all files that were previously moved and lost their preview in 4.0 still don't have previews. See the video. Trying to find out how to rebuild those waveforms on a analyzed and locked file.

DJphasim 0 votes
Comment actions Permalink
0
Avatar

Try unlocking one of the files - it won't re-analyse it, but it may rebuild the overview waveform.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Nope. It doesn't rebuild the waveform. I've already tried that.

DJphasim 0 votes
Comment actions Permalink