Have a feature request or suggestion? Post your idea here!

Post

11 followers Follow
0
Avatar

Help! Rekordbox & Firewall

I am using Rekordbox DJ on a macbook pro, and every single frickin' time I open the app, I get the message Do you want the application “rekordbox.app” to accept incoming network connections?.

I click allow each time but it still keeps popping up. I've tried removing it and re-adding it to my allow incoming connections apps in the firewall preferences but to no avail.

I have also tried clicking deny but that doesn't help either. It just keeps popping up every time I open Rekordbox.

Help? :)

cpoynter

Official comment

Avatar

This happens every time a program is updated. The program is simply trying to send / receive traffic on those ports and the firewall monitor is alerting you. If the setting is not being retained, the problem is on the OS side, not rekordbox. Try disabling the firewall completely.

Pulse
Comment actions Permalink

Please sign in to leave a comment.

41 comments

0
Avatar

I believe this is actually more an Apple thing, not a Pioneer thing. It's similar to how everytime you install a program, plugin, etc. you have to input your password. It's a failsafe by Apple to ensure nothing compromises your system, no matter how obnoxious it is. :)

lostnthesound 0 votes
Comment actions Permalink
0
Avatar

...but is there anything I can do?

This happened with Rekordbox 4.0.1 but not with 4.0.2. Now it's happening again with 4.0.3.

cpoynter 0 votes
Comment actions Permalink
0
Avatar

This very annoying. It should only happen the first time but its EVERY time i open it. Interestingly, Rekordbox is listed under Settings-Firewall and set to 'accept incoming' yet we till get a prompt. Interestingly none of my other mac applications ask for this so I wondering how pioneer is handing the request to open a HTTP or SSL connection..

DJ Chase 0 votes
Comment actions Permalink
0
Avatar

Out of curiosity, how many of those other apps that you refer to require a link from external hardware to the CPU via a hardwired network connection?

lostnthesound 0 votes
Comment actions Permalink
0
Avatar

lostnthesound -- none. But I don't use a link. I'm talking about even using rekordbox in standalone mode nothing connected. For example beatgridding on my laptop with no hardware.

The HTTP request it *.rekordbox.com and is to check in to see if there is a new version. Hopefully this will be addressed by the team using a different method of checking. I can count at least 20+ apps on my macbook that 'check in' each time you run to see if there's an update, but this is the only one that gets the prompt. I don't know enough about mac software development but I'm guessing its the way the request is made. Perhaps they're not using a standard port. 80 or 443 would be the best way to go (ideally 443 since thats for HTTPs). The non standard ports get blocked for obvious security reasons.

Pulse - Turning off your firewall is never a good idea!

DJ Chase 0 votes
Comment actions Permalink
0
Avatar

OK now I completely understand. My apologies, I misread your problem and interpreted that the message kept popping up every time you opened rekordbox with your hardware and network connection attached. Now I see where you are coming from, since every time you simply open rekordbox without any hardware connected. Sorry for the miscommunication. Let me talk to some of my Apple/Linux buddies to see if perhaps there's a Terminal conmandline that can resolve this annoyance for you since whitelisting isn't doing the trick.

lostnthesound 0 votes
Comment actions Permalink
0
Avatar

@Harry > I know, but that's a troubleshooting method to work-around the issue of the firewall. Personally, I use LittleSnitch, which allows me to have much more granular control over the network traffic. If I create a rule for rekordbox, it never asks me again, so the problem is clearly with your Mac firewall.

Application:

Updater:

Pulse 0 votes
Comment actions Permalink
0
Avatar

I don't understand a lot of the geeky stuff you guys are talking about... soooooo... back to my original question... I want to keep my firewall ON but have this annoying pop-up stop appearing. What can I do? It doesn't happen with any other program on my computer.

cpoynter 0 votes
Comment actions Permalink
0
Avatar

Yeah, I've tried that. I've also tried removing it from the list, restarting my computer, re-adding it, etc etc, but it doesn't make a difference.

cpoynter 0 votes
Comment actions Permalink
0
Avatar

@cpoynter > Try this...

Open System Preferences > Security & Privacy > Firewall and click the Firewall Options button.

Open the Finder, go to Applications > rekordbox 4 > rekordbox.app file - right click on it and click Show Package Contents. From there, open the Contents\Mac OS folders and then you should find the rekordbox application core. Drag that into the firewall window.


You might have been allowing the application wrapper (rekordbox.app), but something's not sticking, this may help.

Pulse 0 votes
Comment actions Permalink
0
Avatar

@cpoynter > Sorry but it would seem the problem is isolated to the firewall within the operating system. The choices I see for you...

  • Ignore the problem and just allow it every time you run the program.
  • Turn off the firewall when using rekordox.
  • Install a 3rd party firewall (like Little Snitch).
  • Reinstall your operating system.

I know it's a nuisance but I don't feel it's going to be isolated to rekordbox.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Ok i found a way to get rid of that annoying firewall question to accept incoming connection.

What i did  (1) take the rekordbox app out of the firewall 

(2) In you application folder if you have the reckordbox box app in a reckordbox folder take it out and place it out and place it in the application folder, so now you will have one reckordbox app in and out of the reckordbox folder see image below.

(3) Go back into you firewall option and add the reckordbox app that you place out of the rekordbox folder

I did this with my internet connection off and reckordbox not running.

 

Hope this make sense and work for you .

 

 

DJDNYCE 0 votes
Comment actions Permalink
0
Avatar

 

Correction

In your application folder if you have the reckordbox  app in a reckordbox folder take it out and place it in the application folder, so now you will you have one reckordbox app in and out of the reckordbox folder see image below.

DJDNYCE 0 votes
Comment actions Permalink
0
Avatar

You sir, are a genius. I'm glad this got sorted out, but I gotta say I am disappointed that Pioneer's attitude is "not our problem," when Rekordbox is the only app that causes the problem.

Oh well. The program is a work in progress, so it can only get better!

cpoynter 0 votes
Comment actions Permalink
0
Avatar

Hmm... now that I've turned my computer off overnight, and then back on this morning, the firewall pop-up is back.

cpoynter 0 votes
Comment actions Permalink
0
Avatar

So now you create two copies of the rekordbox.app, which one do you end up running?

Would making a symbolic link work? I'm worried about having two copies of rekordbox on my computer when the next version comes out and I need to upgrade.

I wish pioneer would just fix this annoyance rather than having us do backdoor tricks to get it to play nice with the default mac firewall!!

 

DJ Chase 0 votes
Comment actions Permalink
0
Avatar

I think I know why this is happening.

I've been digging around the Rekordbox keychain and plist and it looks like the application IS NOT signed. There is no signing certificate. We can sign the app ourselves, but for a commercial application Pioneer should spend the few minutes to sign the app so it abides by the default mac firewall rules.  Not sure why they didn't do this.

Source: a bunch of threads on stackoverflow regarding some apps not following firewall prefernces

 

DJ Chase 0 votes
Comment actions Permalink
0
Avatar

The application should be signed, but it may be not match other certificates because of the change in the legal company name. It should be resolved by March, but I don't see how this could be the problem with only 2 people reporting the issue.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Same problem here. Mac OS x Sierra, firewall ON, rekordbox.app always asks for permission for incoming network connections. 
app is not signed so firewall blocks it automaticly even if folders and app is added to trusted.

Running Rekordbox V 4.2.5

Ricardo M. Cunha 0 votes
Comment actions Permalink
0
Avatar

@Pulse, 

With firewall OFF the message doesn't appear. 
It surely is because of the missing signed application state

Regards,

Ricardo

Ricardo M. Cunha 0 votes
Comment actions Permalink
0
Avatar

@Ricardo > Did you follow the instructions above to allow the various app components through the firewall? I know it works on Sierra because I have it working here!

Pulse 0 votes
Comment actions Permalink
0
Avatar

Yes i did @Pulse, i added exceptions in the firewall for all the described files but no luck unfortunately.

The only thing i have running that may be causing such behavior is native Gatekeeper, but like i told you.... not signed app is most likely the reason.

Regards

Ricardo M. Cunha 0 votes
Comment actions Permalink
1
Avatar

I haven't checked this thread in awhile but I need to add that after the most recent update, I started getting TWO boxes popping up when I open Rekordbox. The first one is still as described above, and now there is a second on that says "Do you want the application “PSvLinkSysMgr.app” to accept incoming network connections?"

 

cpoynter 1 vote
Comment actions Permalink
0
Avatar

I am also getting 

"Do you want the application “PSvLinkSysMgr.app” to accept incoming network connections?"

I am running macOS High Sierra and I have added the Rekordbox app to the Firewall exceptions.

Please advise.

smilinggoat 0 votes
Comment actions Permalink
0
Avatar

@smilinggoat > Does it work if you disable the firewall completely?

Pulse 0 votes
Comment actions Permalink