Have a feature request or suggestion? Post your idea here!

Post

2 followers Follow
0
Avatar

ddj sz mapped to Traktor

Hi,

Hoping some one can help as I'm pretty new to all this stuff. I've current got a Pioneer ddj sz and up until today I've been using Serato as my digital software. I decided I wanted to try the Traktor software knowing the ddj sz was capable. I have updated the controller and Traktor to the latest software and download the latest mapping file from the pioneer site. I have installed all as pre guildlines/ instruction which seemed to go well until I tried using the track decks. The problem I have is there is only sound coming from one channel for both track decks? I have turntables contacted to the other two channels which are fine. I've opened settings in Traktor to check audio output etc but all seems fine. Any changes I do make have no effect at all.

What am I doing wrong guys ? I've spent the last 5 hours on it :(

Any help would be much appreciated

dene sawyer

Please sign in to leave a comment.

49 comments

0
Avatar

I'm using real life vinyl. I remember recording on traktor using my old Traktor s4, but that only had one sound card and wasnt really classes as an external mixer like the SZ. must be a way of doing it? lol

dene sawyer 0 votes
Comment actions Permalink
0
Avatar

No worries, that's what I'm here for! I just tried to emulate this with my DJM-900SRT and here's what I did...

  • assign your output 9/10 to MIX REC (you've already done this)
  • in Traktor's prefs, on the Input Routing page, assign the Input FX Send to be the SZ 9/10
  • on the Mix Recorder page, select the external input to be Input FX Send as well, and you should now see the vinyl input on the recorder
Pulse 0 votes
Comment actions Permalink
0
Avatar

Hi,

I have gone ahead and done this but I get the same result in regards to loud increasing buzz?

dene sawyer 0 votes
Comment actions Permalink
0
Avatar

Within Traktor, simply unassign the inputs for the channels you have the turntables connected-to.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Right I have just turned the recording volume dowm from 0.0db to -9.9 db which stops the buzzing sound and you can actually play my vinyl. does this help any mate? or is this how it should be?

dene sawyer 0 votes
Comment actions Permalink
0
Avatar

You should be able to record at 0dB. Did you disable the inputs to Traktor for the channels to which the turntables are connected?

Pulse 0 votes
Comment actions Permalink
0
Avatar

I have also just noticed when using internal mode my 2 digital usb decks will only play through 1 channel for some reason?

dene sawyer 0 votes
Comment actions Permalink
0
Avatar

That would happen based on a change in output assignments for the audio device.

Pulse 0 votes
Comment actions Permalink
0
Avatar

I haven't change anything other than what we have spoke about? if i change back to external its fine just internal where the issue is?

dene sawyer 0 votes
Comment actions Permalink
0
Avatar

Right my friend looks like I'm sorted :) unassign those turntable inputs has sorted the job. I switched over to internal not realizing when trying to figure things out waiting for your last message.

Anyway big thank you from me. You have been great helping me with this I couldn't of asked for better. Top man. Cheers.

dene sawyer 0 votes
Comment actions Permalink
0
Avatar

It's a bit of a pain to get everything sorted properly the first time, but once you've got it configured, away you go! Enjoy!

Pulse 0 votes
Comment actions Permalink
0
Avatar

Yeah your totally right about that lol. Well happy it's sorted now though I can finally get some mixing done.

Again really appreciate your time you've a massive help.

Take it easy pal.

dene sawyer 0 votes
Comment actions Permalink
0
Avatar

I did exactly what you said with ASIO and it sounds like a robot.

 

This is my routing-

Audio Setup in Traktor:

Audio Device:  Pioneer ddj SZ Asio

Built in Soundcard my M-audio Profire 26/26 Asio

 

Output Routing-  External

Pioneer ddj sz output 1-10 straight down

Input Routing-  Pioneer DDJ Sz 1-10 straight down

I went in to Traktor x86 and copied and paste in Program file 32 bit Traxtor and renamed the 64 bit

 

Traktor is opening up in 32 bit mode cause I clicked on Traktor logo upper left hand on info and not seeing the 64 bit version so it must be the 32 version.  

 

Hit play and robot.  what am I doing wrong myself.

 

I even see my recording levels for the mix recorder working.

 

DJ Tranz 0 votes
Comment actions Permalink
0
Avatar

fixed it my sample rate was below standard in the Pioneer utility tool

DJ Tranz 0 votes
Comment actions Permalink