Have a feature request or suggestion? Post your idea here!

Post

4 followers Follow
0
Avatar

Issues with external USB DAC adapter (FiiO)

I use an external USB DAC adapter, a FiiO E-7. This software refuses to play any of my audio files when I load them up. When I switch to the default Windows audio drivers, it starts to behave. Please fix this so I can use rekordbox again!!!

 

Thanks!

Jeff Katz

Please sign in to leave a comment.

29 comments

0
Avatar

@Jeff > Please check the samplerate in the rekordbox preferences on the audio settings page when you have the FiiO E-7 selected as the output device; that could be the reason no audio files are able to play.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Sample Rate stuck at 44100 Hz. There aren't any options to change it up - also my bad, it's an E10, not E-7

Jeff Katz 0 votes
Comment actions Permalink
0
Avatar

Can you post a screenshot of the audio preference page in rekordbox?

Pulse 0 votes
Comment actions Permalink
0
Avatar

What comes up if you click the Driver button; do you get the E10's audio interface control app?

Pulse 0 votes
Comment actions Permalink
0
Avatar

Ah, no, that just takes you to the drive page - I was hoping more to see if it took you over to the control panel for that audio interface. There's got to be something in conflict between rekordbox and the device settings causing it not to play. For most default sound cards it's because the sample rate doesn't match. Can you check that?

Pulse 0 votes
Comment actions Permalink
0
Avatar

@Jeff > That's the Windows audio settings; is there no manufacturer's control panel for that unit?

Pulse 0 votes
Comment actions Permalink
0
Avatar

If you mean as far as software goes?... I never installed any kind of software from FiiO. Just plug and play. Windows 10 installed the drivers and everything automatically for me. Is there some other control panel lurking around here I'm not seeing that I'm supposed to...? lol (sorry, still new to Windows 10)

Jeff Katz 0 votes
Comment actions Permalink
0
Avatar

No worries, I finally looked at the product page and see it wouldn't really have the need for its own control panel!

I see on the Windows sound device list, it says SPDIF out -- typically that is the digital output. Is there another listing for simply the headphone output?

Pulse 0 votes
Comment actions Permalink
0
Avatar

Not that I know of. All things relative to my audio settings are in those imgur links.

All I did was a fresh install of Windows 10, plugged in my FiiO, downloaded rekordbox, and none of my music works anymore. :(

Jeff Katz 0 votes
Comment actions Permalink
0
Avatar

@pulse - I was just looking at the rekordbox site, and is there any way that I can download a previous version of the software so I can actually get back to working on my mixes? This downtime has been a killer - I don't like using other dj software because I've gotten pretty accustomed to rekordbox already

Jeff Katz 0 votes
Comment actions Permalink
0
Avatar

@pulse - Ok, this confirms it. Windows 10 will not work with rekordbox for me. I may have to make a virtual desktop to go back to Windows 7 for this and hopefully it should be okay again. If you need any tech specs for this bug report lmk and I can post up the dxdiag for my setup. And thanks again! :)

Hopefully another update gets released soon so all these issues get worked out :D

Jeff Katz 0 votes
Comment actions Permalink
0
Avatar

Hi, 

I am having issues with my external USB DAC as well. (FiiO e10k.)
It works perfect with any other application and only gives an issue with RekordBox.

What happens is that the audio plays extremely slow when running over the FiiO. (Sound output is stuttering / playing in extreme slow motion.. tsk.... tsk...tsk...tsk...)

Funny thing is that it works again after every RekordBox Update.
It just stops working after launching the program a few times.

As this is quite annoying... is there any update on this topic to give yet?

Sid Kolemeyer 0 votes
Comment actions Permalink
0
Avatar

Sorry guys, still waiting on the engineers to provide some insight. I've asked for an update.

Pulse 0 votes
Comment actions Permalink
0
Avatar

No info yet, I've posted that you're still experiencing this issue with 4.1.1.

Pulse 0 votes
Comment actions Permalink
0
Avatar

@Jeff & Sid > Are you guys using the ASIO or WASAPI drivers with your FiiO devices?

Pulse 0 votes
Comment actions Permalink
0
Avatar

Will this ever be fixed? I have not used my CDJ's in a while due to this software error and have been finding myself less wanting to mix with Pioneer hardware and more so with Native Instruments Traktor. If this issue is not resolved by software ver. 5.x.x, I can not say that I will remain a part of the Pioneer family for much longer, nor will I be able to recommend any of the Pioneer product line because of this insane software issue. It should not take almost 6 months to figure out how to make drivers work with a very popular selling audio interface.

Jeff Katz 0 votes
Comment actions Permalink
0
Avatar

@Jeff > Actually, it can, given that the product you're inquiring about is discontinued. @Alexander has posted a link to a pile of drivers, and it could be that those legacy drivers solve your problem, so please give that a try and let us know if it works for you.

Pulse 0 votes
Comment actions Permalink
0
Avatar

@Pulse > please provide the link to the drivers so that I may find them. Thanks.

Jeff Katz 0 votes
Comment actions Permalink