Have a feature request or suggestion? Post your idea here!

Post

7 followers Follow
0
Avatar

Quantizing loops but not hot cues

I just downloaded RekordBox DJ to try out and I am not sure if this is possible. If not, then I guess this is a feature request.

I like the quantized loops, it makes setting up loops on the fly much less finicky but I generally do not want hot cue playback to be quantized, I find it un-intuitive and for me it is just creating headaches/mistakes.

I would like hotcues to trigger immediately, but keep quantization for loop setting enabled. Is there currently a way to acheive this with the software?

 

Reo Baird

Please sign in to leave a comment.

30 comments

0
Avatar

This is not currently possible.  However, you may find it helpful to adjust the quantize beat value.  You can find this setting in Preferences > Controller > Others.

Mark Gallo 0 votes
Comment actions Permalink
0
Avatar

Thanks Mark,

I did play with the quantization granularity, but even at 1/16 beat, if i press just a split second too late, it doesn't trigger until 1/16 past the beat. For hot-dropping stuff with the faders up, this goes from a barely perceptible mistake that I can fix immediately, to something that everyone will definitely hear.

Hopefully in the future you can consider implementing this feature?

Reo Baird 0 votes
Comment actions Permalink
0
Avatar

I can't think of any real world situations where this would be useful.  It's an on/off thing.  If you like it, use it.  If not, don't use it.  We added the adjustable timing to make it more customizable but I don't see us doing more than that.  If we start adding options for which features to apply quantizing to, the preferences menu will become even more cumbersome than it already is.  More settings for users to set incorrectly.  This is one of the biggest challenges we face as we are trying to make rekordbox dj appealing to both advanced users AND beginners.

Mark Gallo 0 votes
Comment actions Permalink
0
Avatar

Reo - It sounds like the real issue is not that you want quantize disabled for hotcues, but rather you want the hotcue to snap correctly so that it is aligned.  I haven't tested this but the logic for quantizing hotcues should be something like this. 

http://imgur.com/gallery/ZZ4CQ

DJphasim 0 votes
Comment actions Permalink
0
Avatar

^ That's a good suggestion, and definitely an improvement from the way it works now. 

Speaking of which, another suggestion: It would be nice to have an option where hitting a hotcue, in addition to jumping playback to hotcue postion, sets the cue marker to the hotcue position. This is how other DJ software works. Actually, it would be nice if this option also existed on the CDJ.

Right now, with rekordbox dj I can achieve something similar by using GATE playback mode and first click hotcue while paused, then hit cue.  On the CDJ though, and in the software gate mode off, its kind of a hassle to move the playhead to a hotcue position.

The option could called something like "Move cue marker on hotcue trigger"

Reo Baird 0 votes
Comment actions Permalink
0
Avatar

PioneerDJ/Mark - any thoughts on snap functionality like i described?  Should I put this as a feature request in another post?

DJphasim 0 votes
Comment actions Permalink
0
Avatar

@DJsimshady > This already exists.  We call it 'quantize.' Click here to see a video that illustrates your drawing from the above post.

Mark Gallo 0 votes
Comment actions Permalink
0
Avatar

To back that up, I can also confirm that it does not "snap back" as it should. Perhaps this can be a bug report in that case?

Reo Baird 0 votes
Comment actions Permalink
0
Avatar

I have no idea what you guys are talking about.  The hot cue plays when you press it.  Of course it will 'snap back.' 

Mark Gallo 0 votes
Comment actions Permalink
0
Avatar

Mark/PioneerDJ - Ok that is totally the way it behaves when you set a hot cue so no disagreement there.   The problem occurs when you playback a hotcue.   It doesn't snap back once you have passed the quantize point like I describe.  To test I slowed down a track to 30BPM and pressed the sample button just after the grid marker and you can see/hear that it snaps forward.   Can you retest on your side and confirm?  If you can't I can record a video for you but I'm 95% sure that this is happening.  My quantize is set at 1beat.  Let me know.

DJphasim 0 votes
Comment actions Permalink
0
Avatar

I also just tested in similar way (set quantize grid size to max value and lower BPM). To describe in other words, there are two cases that could occur when using quantize:

1. The audio playback should be delayed to a future date. IE: scheduled.

2. The audio playback should have occurred a small time period in the past. IE: playback should begin immediately, but the playhead should be "fast forwarded" past the cuepoint so the correct frame of audio begins playback such that the track remains aligned to the master tempo.

Strictly when playing back hotcues, but not when setting them, case 1 is always occurring.

I actually am a software engineer and I work with audio... I wrote a quantized sampling app a little while ago and from an implementation standpoint, supporting "backwards" quantizing is a bit of extra work and definitely isn't default behavior... but it definitely does make quantize much more useful and makes the experience more fluid and "instrumental". When quantize only supports future scheduling it makes the hotcues feel very sluggish and unintuitive as you have to press them well ahead of when you want playback, instead of the software "silently" fixing your small mistakes.

Reo Baird 0 votes
Comment actions Permalink
0
Avatar

@Reo > You're saying you want it to correct itself when a user hits the Hot Cue button too late?

Mark Gallo 0 votes
Comment actions Permalink
0
Avatar

PioneerDJ/Mark - Ok I've posted these.  The problem is that it does this 25% percent of the time.  Other times it seems to be ok.  Not sure if it's capturing when the button is pressed or released.  In either case you will have to try this a few times before you can see it.  I recorded the video like 5 times before it would occur.  Posting the videos separately so you can delete the post after.  Listen for the hand clap ending on cue point C.

DJphasim 0 votes
Comment actions Permalink
0
Avatar

@Mark, yes precisely... the issue with the way it is working now (not sure if bug or intentional) is that it makes the quantized hotcues a no-go for live situations for me as I was explaining above in my initial posts.

Dropping in a small fraction of a beat too late and quickly jogging forward upon hearing the mistake (or having quantize skip ahead for me) really is no big deal... but having playback end up an entire beat off of the intended moment because of a 1/32 beat mistake is pretty much a trainwreck.

As it stands, I generally keep all the "fancy" stuff (master tempo, sync, quantize, etc.) off to avoid these issues, but I really do like quantized looping and would love to use these features without having to worry about a hotcue or sync trainwreck.

 

 

 

Reo Baird 0 votes
Comment actions Permalink
0
Avatar

Ok... after slowing down to 10bpm I can reproduce this at will.  It 100% does not snap back.  I can easily tell that the sample starts on the next beat (snapping forward).  I am guessing the snap back behavior is not based off the halfway point in my image that I posted and different from the way hotcues are created.  If you check with an engineer, I think they would concur.  Let us know.  This explains why sample playback is "off" during my sets.

DJphasim 0 votes
Comment actions Permalink
0
Avatar

Ok, so what is happening is that quantize doesn’t snap to the nearest point, it goes to the NEXT point.  I will create a ticket for this and keep you posted with updates as I receive them.

Mark Gallo 0 votes
Comment actions Permalink
0
Avatar

PioneerDJ/Mark - yep you got it.  Just tested again and snapping seems to work fine when you are playing hotcues but not for samples.

DJphasim 0 votes
Comment actions Permalink
0
Avatar

PioneerDJ/Mark - discovered another "bug".  When pressing hotcues a bit early it snaps but it is not synced correctly to the grid.  When pressing late it snaps correctly.  I noticed this as well when playing in the club last week as well but thought I was crazy.   Video to posted in a separate comment so you can delete.

DJphasim 0 votes
Comment actions Permalink
0
Avatar

**UPDATE**

The engineering team has added this to their list of fix requests.  What we don't know is where it ranks in priority.  There is no time table as to when this will be addressed but I wanted you all to know that it is not being ignored.  Thank you in advance for your patience.

Mark Gallo 0 votes
Comment actions Permalink
0
Avatar

Is that for the sampler playback not quantizing or for the hotcue one? 

DJphasim 0 votes
Comment actions Permalink
0
Avatar

Hey All, just pinging this.  I still have this issue even on 5.4 Beta.  

So glad to have hear that it's essentially a snap issue with the snap only rounding up to the quantize amount, but never down.  I was going seriously crazy with this.  I'm a new user coming from Traktor and def didn't understand the situation.  

So...any word on the fix?

CLS 0 votes
Comment actions Permalink
0
Avatar

@CLS > Do you have the QUANTIZE MODE setting for "Jump before reaching the next beat" set to on or off?

Pulse 0 votes
Comment actions Permalink
0
Avatar

Hey @Pulse.  I have it set to 1. Turns out I might have been smoking crack, as now in performance mode it will snap ahead and behind to the beat...most of the time.  I believe what was likely the issue was my analysis mode, I had it set to Dynamic and was using BPM sync rather than BEAT sync.  Reanalyzing with Normal and changing to BEAT sync set seems to work much better with the snap.  Though I have noticed a few times where it does not seem to snap to the beat.  Unfortunately I don't have a list of steps to reproduce.  

For now, perhaps this can be closed.  

CLS 0 votes
Comment actions Permalink
0
Avatar

@CLS > Keep playing and let us know if you need further help.

Pulse 0 votes
Comment actions Permalink
0
Avatar

This is still a problem, I just switched from Traktor after buying a DDJ-1000 and couldn't figure out why quantizing wasn't working.

With "Jump before reaching the next beat" unchecked, it waits for the next beat if you hit the cue even a fraction of a millisecond too late, and with it checked it doesn't seem to quantize at all - the timing of the grid relative to the other track changes depending on how early/late you hit a hotcue, just like with quantize disabled.

What needs need to happen is when you hit a hotcue, it jumps to that cue point but maintains the existing timing relationship with it's sync master.

Example: Track A is already playing, you cue up Track B and hit play but say the beatgrid isn't perfect or the kick drums in the two tracks are out of phase so you manually nudge Track B forward slightly to compensate. The beatgrids are no longer in perfect sync, but the tempo is and musically they are. When I reach the point that I want to hit the hotcue it should jump in relation to the NEAREST grid marker (whether ahead or behind) but not re-sync directly back on the grid, it should maintain the manual adjustment that was made earlier while cueing.

This is how it works in Traktor and it feels very natural/intuitive, the way it works in Rekordbox seems to always lead to either the hotcue being delayed, or having to redo manual adjustments with the jog wheel after each time a hotcue is pressed.

Dan Dubois 0 votes
Comment actions Permalink