Have a feature request or suggestion? Post your idea here!

Post

3 followers Follow
0
Avatar

Rekordbox Performance Mode XDJ-RX Mixer Not Functional?

Hey, just got my XDJ-RX today and I'm trying to figure out how to set it up in performance mode with rekordbox.

I got pretty far but I'm missing something still.The mixer doesn't seem to have any effect on the audio. Otherwise the play buttons work, the turntables work, but pretty much everything in the middle section related to mixing has no effect.

I have the unit plugged in via USB. 
Rekordbox is set to use an external mixer (this was the only way I could even get audio to play). 
The audio output in Rekordbox is set to my computer sound card, and I do get audio.
I have Output Deck's 1-4 set to output to channels 1 and 2.

So what is the proper combination of settings so that I can use the mixer on the unit, headphones and then output to my computer speakers through the USB connection to the computer?

Kevin A

Please sign in to leave a comment.

14 comments

0
Avatar

@Rick, which video specifically addresses my goal?

@DJ Hairless, you have mixer mode set to Internal, I have mine set to External. I also have my audio set to my computer sound card output. Are you saying that configuration in that picture allows for only the USB cable to be used to output sound from the computer speakers and still be affected by the mixer on the XDJ?

Kevin A 0 votes
Comment actions Permalink
0
Avatar

@ Kevin A : I'm using this configuration and had no problem's at all.

Dj Hairless 0 votes
Comment actions Permalink
0
Avatar

Yeah everything is configured properly as shown in the video. My issue seems specific to the ASIO driver not working properly. I've tried uninstalling, reinstalling, rebooting. The device shows up properly in the device manager yet still I continue to get error opening when trying to select it in the preference menu.

Kevin A 0 votes
Comment actions Permalink
0
Avatar

@ Kevin A : Sorry to hear that.May be Pulse or Mark can help u.

Dj Hairless 0 votes
Comment actions Permalink
0
Avatar

@Kevin > It you're having a problem where it says the ASIO device drivers are unavailable, you may not have fully updated Windows or need to install the drivers with the signature mode disabled. Try these steps to do that. You can also right-click and select "Run as Administrator" when installing the drivers once you've disabled the driver signing.

Pulse 0 votes
Comment actions Permalink
0
Avatar

@Pulse, so I've managed to fix the ASIO issue but it didn't actually solve my original goal which was to get audio output on my computer while still allowing the mixer to function WITHOUT using any of the audio outputs on the unit, only the USB.

Is this simply not possible? I may need to return the unit if it is not possible as that is an issue for me.

I want the USB connection and power to be the only thing required to use rekordbox in performance mode and get sound output on my computer while still being able to use the mixer. A DJ controller without a working mixer is pointless.

Kevin A 0 votes
Comment actions Permalink
0
Avatar

@Kevin > Sorry, maybe I missed that -- you want the audio to come out of the computer but not the RX? So why not set the output to Internal on the audio device selection? I'm not sure I understand what it is you're trying to accomplish.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Essentially I'm trying to bypass the need to hook up any audio cables to the RX. To only utilize the USB and power on the unit. I don't have a setup where it is easy to move the input of my studio monitors from my computer to the master out on the RX. 

So yeah, I'd like rekordbox dj to output to my computer audio card which already has connections to my speakers but I'd also like the mixer to still have an impact on the audio that is output to my computer. So I'd use my sound card as the audio device and set the mixer to internal? is that all I'd need to do? I don't recall that setup working when I tried before.

Kevin A 0 votes
Comment actions Permalink
0
Avatar

@Kevin > Okay, now I follow -- your best solution would be to use ASIO4ALL to create a multi-output device incorporating the headphone outputs from the RX, and your internal card's outputs. This will make 4 outputs from ASIO4ALL, and you simply assign the headphone out to the pair which is assigned to the RX headphones (it could be 1/2 or 3/4 depending on how A4A orders them), and the master output as the other pair.

Pulse 0 votes
Comment actions Permalink
0
Avatar

(And you should have the RX in MIDI mode with the rekordbox mixer setting to INTERNAL).

Pulse 0 votes
Comment actions Permalink