Have a feature request or suggestion? Post your idea here!

Post

3 followers Follow
0
Avatar

Clicking interference with the the latest version of Rekord box whe using master Tempo

I have noticed a clicking sound when using the latest version of Rekordbox.

It happens when I engage the Master Tempo and is annoying enough for me to want to go back to an earlier version of Rekordbox.

This interference dissappears when i disengage the MT button.

 This was not an issue with version 4,0 and I wish to go back to that version until this issue is sorted. Is there a webpage with previous versions??

Philip Whittingham

Official comment

Avatar

The reason you're hearing a click is when the algorithm engages/disengages, the edge of the audio doesn't perfectly align with the audio before it, so it's interpreted as a click. My advice would be to either not switch it on/off, or to hit it on a beat so it's less audible.

Pulse
Comment actions Permalink

Please sign in to leave a comment.

23 comments

0
Avatar

QUESTION AVALANCHE!

What exactly do you mean by "clicking"?

Can you record an audio sample?

Are you using a controller when this happens?

If so, does it have the latest drivers installed?

Can you tell me the spec of your computer?

What is the operating system, and do you have all of the latest updates installed?

 

Pulse 0 votes
Comment actions Permalink
0
Avatar

Hi Pioneer, 

please respond to the issue above. 

Kind regards,

Peter

Peter 0 votes
Comment actions Permalink
0
Avatar

Sorry, that audio sample is no longer available - can you please post a video instead of the audio-only file?

Pulse 0 votes
Comment actions Permalink
0
Avatar

I don't hear anything wrong in the audio of what you're recording; the master tempo can't perfectly smooth out the audio at such extreme pitch ranges, and as such, you hear the artefacting of the algorithm. This is perfectly normal. 

Pulse 0 votes
Comment actions Permalink
0
Avatar

wow - very interesting. Have you noticed when I turn on and off the MT? Maybe you have missed that?

I have Cross DJ working in parallel - with that you hear everything sounding fine, just with a different pitch. 

 

Peter 0 votes
Comment actions Permalink
0
Avatar

How often are you engaging / disengaging the Master Tempo that there is a problem with this? Are you doing it while the song is actually playing live to the mains?

Pulse 0 votes
Comment actions Permalink
0
Avatar

thank you for your prompt reply! I am doing this sporadically. I do this both before a song is playing and also while a song. Master Tempo for me is one of the most important features to be able to keep the pitch while changing the tempo. 

Peter 0 votes
Comment actions Permalink
0
Avatar

Hi guys,

I have recorded a comparison with Cross DJ and Rekordbox with the same sequence. 

I hope this will show the difference: Cross DJ with the same tempo nice and clear - Rekordbox with bad audio. 

Honestly - it seems that everything is working slower and with delay. It is NOT ONLY the bad sound with master tempo, it also has a delay when using the jog wheels

And: it is not only with this one computer - I have the same issues on my macbook air. 

I created 2 more videos to demonstrate this. In the jog wheel video you can see that there is a delay on rekordbox compared to Cross DJ:

https://mdocs.sap.com/mcm/public/v1/open?shr=ppon2PVDVIIccM05Y4u4F2HAjR6zQrabGwm5jAnxOIU

files:

- compare mt cross-dj and rekordbox.mov

- jog wheel delay.mov

Please help and let me know if you plan to fix the issues.

For now I can just use Cross DJ as Rekordbox is with the current release useless!

Regards,

Peter

 

PS: I just checked the CPU activity: 

no song playing, no analysis: Rekordbox 33,1%, Cross DJ 8,6%

1 song playing: Rekordbox 36,2%, Cross DJ 31,8%

so this would also be nice to reduce the CPU consumption in idle mode.

Peter 0 votes
Comment actions Permalink
0
Avatar

Does that delay only happen when you have both applications open at the same time?

Pulse 0 votes
Comment actions Permalink
0
Avatar

Hello, no there is no difference when playing one or two apps in parallel. 

Interestingly i have the same issue as mentioned on both my iMac and my Macbook Air with Rekordbox. 

Peter 0 votes
Comment actions Permalink
0
Avatar

Hello,

buffer size in Rekordbox is set to maximum, 2016 samples (45.7ms).

In Cross DJ 512 samples (11.6ms).

I then changed the buffer in Rekordbox to 512. This has a positive impact, but still no such clear sound as in Cross DJ.

 

Peter 0 votes
Comment actions Permalink
0
Avatar

@Peter > The audio buffer being 4x the size in rekordbox would certainly make a difference in the performance and response of the players.

I'm still not sure what you are having an issue with in terms of "clear sound." Your samples don't really illustrate much of an issue with rekordbox.

Pulse 0 votes
Comment actions Permalink
0
Avatar

hello again,

especially for you I did create 4 audio recordings, hopefully this makes it clearer for you. 

In the share (https://mdocs.sap.com/mcm/public/v1/open?shr=ppon2PVDVIIccM05Y4u4F2HAjR6zQrabGwm5jAnxOIU), I have created a folder called 

"audio recording crossdj vs rekordbox". 

I recorded both the beginning of a song at 200% speed with Master Tempo enabled in both Rekordbox and Cross DJ. Each with 512 and 2016 samples. The biggest difference you can hear when you compare both 2016 samples versions, but a difference is still clearly noticable (at least for me) with the 512 samples versions.

Peter 0 votes
Comment actions Permalink
0
Avatar

I don't need to listen to a sample at 200% to tell you that it's not going to sound good, nor should it be expected to sound decent at that high a percentage, and it wouldn't matter what the buffer size is for that. Master Tempo is intended for best performance under 16%, anything outside of that will certainly have more audible artifacts.

Pulse 0 votes
Comment actions Permalink
0
Avatar

This is a VERY disappointing answer. This encourages me even more to use a software like CROSS which sounds much better AT ANY SPEED compared to REKORDBOX. 

I recorded the samples at 200% because you were apparently not able to hear the difference at a lower speed. So now you say that I should not do this above 16% because it sounds bad anyway.  

Why do you think it sounds better with Cross DJ.

Are you able to hear a difference? 

Peter 0 votes
Comment actions Permalink
0
Avatar

You're kidding, right?

"My car makes a noise when I speed, so in order to make it REALLY apparent, I drove WAAAAY over the limit!"

If you're not able to hear the difference at a lower percentage, what is the complaint? How often are you outside of a 16% pitch shift?

Pulse 0 votes
Comment actions Permalink
0
Avatar

Ok. I will argue no longer. I accept that this is your level of customer support where it seems more important to argue against feedback than to generate customer satisfaction.

Peter 0 votes
Comment actions Permalink
0
Avatar

If you are interested in resetting the RR to check if that resolves the issue, the steps are as follows:

1) Power ON with holding Headphone CUE(Deck 1) + SAMPLER SYNC button, PADs 5-8 will illuminate white.

2) Press SHIFT(Deck 2) two times. PAD 3 will illuminate red.

3) Press and hold SYNC buttons of both decks. All PADs will turn red when the settings are reset.

Power cycle the hardware and test it with rekordbox to see if the latency issue still exists.

Pulse 0 votes
Comment actions Permalink