Have a feature request or suggestion? Post your idea here!

Post

6 followers Follow
0
Avatar

Waveforms not showing on cdj 2000 nexus with Rekordbox 4.2.1

Rekordbox 4.2.1 Rev.8297-9071-9067 X64 (also tried the 32 bit version. Same problem)

Setup;
2x CDJ-2000 Nexus
1 DJM-900 Nexus
Dell laptop running Intel core I5, 6GB RAM.
Using Pro DJ Link with Netgear 8 port switch (It's a Gigabit switch if that makes any difference)

Recently upgraded from Rekordbox 4.1.2
I am not getting wave forms or BPM reading on the players. Neither The large wave forms or the small ones. The small wave forms populate as the song plays but not the large wave forms.

Hot cues and memory points load to the players just fine. If I jump to a memory point the BPM appears briefly then disappears.

The music also plays normally.

Went back to Rekorbox 4.1.2 and everything works fine. Is there something I need to do to get the new version of Rekordbox to show the wave forms & BPM on my players or is this a bug?

 

DJ KennyD

Please sign in to leave a comment.

31 comments

1
Avatar

Same issue here after upgrading today.
2 x cdj2000nxs ver 1.3
1 x djm2000nxs
No waveforms - and have had no problems until update!

toby spin 1 vote
Comment actions Permalink
0
Avatar

Just got back to test this - also my sync does not work anymore. Not with hot cues or looping, so I guess the CDJ cannot see the grid.

Using
Win 7 Ultimate SP1 32bit
RB 4.2.1 - Rev 829790719067
Cdj2000nxs firmware 1.3
Pro DJ link via DJM2000nxs ver 3.2

As stated before - opening up RB 4.1.2 fixes this.
Please let me know if I can provide more info.

toby spin 0 votes
Comment actions Permalink
0
Avatar

Thanks Toby. Glad I am not the only one with this problem but also hate I'm not the only one at the same time...I am running firmware ver 1.25 on my CDJ's so am glad to know it's not the firmware. The latest firmware update (ver 1.30) stated that it was only needed if you are running new hardware with old (Nexus and Nexus2 product on the same link) so I did not update mine. I have even tried to set the waveform color to "RGB" in Rekordbox but that didn't help. I haven't tried Sync since I never use it, but it makes sense that it wouldn't work since the beat grid information and BPM aren't showing up on the CDJ's.

DJ KennyD 0 votes
Comment actions Permalink
0
Avatar

Just got a brand new XDJ-RX unit last week and it is having the exact same problems. Updated firmware to ver 2.10 and when I use Pro DJ Link to drop tracks to the decks I get a message on the XDJ-RX that Rekordbox analysis needs to be done in order to show the waveforms and beat grid (not exact wording, but you get the point). All of my music has been analyzed already so there is obviously a problem with the new version of Rekordbox and some "older" hardware using the link feature.

I must state also that Rekordbox 4.2.1 works fine with this hardware if the music is exported to a USB flash drive. However, I like to have access to all 30,000+ songs in my library. That won't fit on a 32GB USB drive (not to mention trying to navigate a small screen compared to the laptop). I need link to work.

Using the old Rekordbox  version 4.1.2 works perfectly with Pro DJ Link.

DJ KennyD 0 votes
Comment actions Permalink
0
Avatar

Sounds like you guys are both having a problem with network connectivity - please read the rekordbox read-me article for troubleshooting tips. Be sure you are connecting directly, have either disabled or configured the firewall properly, and that you have the network set to a private (home) network with all other sharing and security software disabled.

Pulse 0 votes
Comment actions Permalink
0
Avatar

No Joy uninstalling & re-installing still does not work.

I have tried 2 x network adaptors - both the built in one and a USB one - both still show no waveform or have any Sync features.

toby spin 0 votes
Comment actions Permalink
0
Avatar

I spent about 4 hours troubleshooting and uninstalling/re-installing. I am still stuck with Rekordbox 4.1.2 on my laptop (what I actually use to perform with) and 4.2.1 on my desktop (which I use to prepare with).

Here is the documentation;

Laptop,

windows firewall is OFF
file and printer sharing is OFF
Wireless is OFF
I do not use any 3rd party software for security
The network is set to private
I am connected directly to the XDJ-RX with the Ethernet cable that came with it. I even tried a different cable.

Link works but when loading tracks to the XDJ-RX I get a message stating "rekordbox track analysis required for QUANTIZE feature". The music plays but no waveform or beatgrid appears on the display.

Uninstalled Rekordbox 4.2.1 X64 version
Restarted PC
Reinstalled Rekordbox 4.2.1 X64 version
I get no firewall warnings or requests when starting rekordbox (Windows probably retains these preferences). Looking at the firewall configuration looks like every required item is authorized to pass through, I don't see anything that pertains to edb_streamd, or rekordbox that isn't allowed through. I don't see psvnfsd or psvlinksysmgr at ALL. None of this should matter though should it? since at this point I have the firewall off (the pc keeps reminding me I need to turn it on).

Again, Link IS working but I get the message "rekordbox track analysis required for QUANTIZE feature" and the waveform & beatgrid does not show on the player. I do not see what else I can do.

Very frustrated.

Uninstalled Rekordbox 4.2.1 X64 version
Installed Rekordbox 4.2.2 X64 beta version
I let everything through the firewall (public and private) upon startup since for some unexplained reason windows firewall is now back on.
Link appeared in Rekordbox. Activated link and the XDJ-RX appeared. Loaded a song to player A. I still get the message "rekordbox track analysis required for QUANTIZE feature" and the waveform and beatgrid do not appear (same as with rekordbox 4.2.1). The songs play, but no waveform or beatgrid shows.

I loaded about 15 different audio files. Both mp3 and WAV. No waveforms or beatgrids show, but the audio plays fine.


Closed Rekorbox 4.2.2 beta. Turned windows firewall OFF. Restarted Rekorbox 4.2.2 beta. The problem still remains.
I get the same problem on my CDJ-2000 Nexus players. Link works and audio plays but no waveforms or beatgrids appear on the displays. I even tried skipping the network switch and connecting directly from CDJ-2000 Nexus player to PC. Problem remains. Link works and audio plays but no waveforms or beatgrids on the player.

Rekordbox 4.1.2 works fine with Pro DJ Link and both CDJ's and XDJ-RX (but not at the same time of course).

Very frustrated.

Tried a DIFFERENT PC (my desktop machine). Using Rekordbox 4.2.1 X64 Connected one CDJ-2000 Nexus to ethernet directly. Dropped a song to the CDJ over Link. Immediately got "media file is collapsed or unavailable - E-8302: CANNOT PLAY TRACK(C658)" error on the player. Tried 2 other songs with the same results. 3rd song I tried actually loaded fine and even showed the waveform and beatgrid (I was amazed). Loaded 5 more songs and they worked flawlessly but the next 10 I loaded gave the same E-8302 error. Switched over to the XDJ-RX. Received "E-8306 UNSUPPORTED" error for the songs that would also not play on the CDJ. The songs that worked on the CDJ also worked flawlessly on the XDJ-RX.
Created a Homegroup (still on desktop machine). turned windows firewall off (again). Now everything seems to work correctly! All songs load...all songs I tried played in Rekordbox 4.2.1. This proved to me that the new software DOES indeed work correctly over link with Windows 10 (had to jump through hoops to get it to though).

Moved back to my laptop. Uninstalled the 4.2.2 X64 beta. Re-installed Rekordbox 4.2.1 X64. My Ethernet connection was set to public. The only way I found to change public to private was to try and create a homegroup (impossible with a public network). Go through the Windows troubleshooter and wait for it to offer to change my network location from public to private. Once that was done I verified the network was set to private, Disabled the firewall, Re-started Rekordbox 4.2.1 and loaded a track to my XDJ-RX. Still no waveform or BPM and the same warning that analysis needs to be done to use Quantize feature.

This makes no sense to me. I realize through my troubleshooting that it IS possible to get link to work correctly with the latest version of Rekordbox and Windows 10 (at least on my desktop machine). I don't see anything else I can change at this point to get Rekordbox 4.2.1 (or the 4.2.2 beta) to work on my laptop (where I need link to work). I will just stick with Rekordbox 4.1.2 on my laptop for now. At least it works (even with my network set to public and firewall on (I can't get it to stay set to private after a restart)).

Disappointed and frustrated. I give up for now.

DJ KennyD 0 votes
Comment actions Permalink
0
Avatar

@Kenny > The fact it you can't get it to stay as a private network leads me to believe the problem is related there somehow.

I'm also curious as to why you're using the 64bit version, are you running / planning on running video? If not, please try with the standard 32bit version.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Pulse, Thanks for the response. On your request I switched to the 32bit version. I usually install 64bit versions of software whenever possible because they are usually faster. I do not have any immediate plans to do video.

I am still having the same problem.

Here was my process;

Uninstalled Rekordbox 4.2.1 X64
Installed Rekordbox 4.2.1 X32
Now the current version is 4.2.1 Rev 8297-9071-9067
Restarted PC
Connected XDJ-RX to Ethernet
Started Rekordbox 4.2.1 (I also noticed it takes longer to read the library than the 64bit version did)
Link showed up almost immediately
Drag & dropped a song to player A
The note "rekordbox track analysis required for QUANTIZE feature". appeared on the XDJ-RX screen. The music plays but no waveform or beatgrid appears on the display.
Closed Rekordbox and turned firewall off, Restarted PC and XDJ-RX
Opened Rekordbox and loaded a Song to player A over Pro DJ Link
The note "rekordbox track analysis required for QUANTIZE feature". appeared on the XDJ-RX screen. The music plays but no waveform or beatgrid appears on the display.
Closed Rekordbox
Changed the Ethernet "Unidentified network" location from public to private using gpedit.msc (I found this solution through an internet search)
Restarted PC and verified the Ethernet connection is set to private.
Disconnected and restarted the XDJ-RX (just to be safe)
Reconnected Ethernet to XDJ-RX and verified the network is still set to private
Had to turn the firewall off again since it is now back on (I did not turn it on).
verified the network is still set to private again
Restarted Rekordbox 4.2.1
Dropped a song to player A over Pro DJ Link
The note "rekordbox track analysis required for QUANTIZE feature". appeared on the XDJ-RX screen. The music plays but no waveform or beatgrid appears on the display.
Loaded 5 more songs to player A and player B. All gave the same results.

As an experiment I left the Homegroup. Restarted PC. Restarted the XDJ-RX. Verified the firewall is still off. Verified the network is still set to private.
Reconnected the XDJ-RX to PC using Ethernet
Started Rekordbox and activated Link
Dropped a song to player A
The note "rekordbox track analysis required for QUANTIZE feature". appeared on the XDJ-RX screen. The music plays but no waveform or beatgrid appears on the display.
Loaded 10 more songs with the same results (a mix of mp3 and WAV files).

I am clueless as to what to try next.

DJ KennyD 0 votes
Comment actions Permalink
0
Avatar

Updated to Rekordbox 4.2.2 X32. I still cannot get waveforms to show up on CDJ-2000 Nexus using Link. Firewall is configured and file sharing is disabled. Network is set to private.

Haven't tested on my XDJ-RX because it is currently stored away.

Went back to Rekordbox 4.1.2 and everything is working fine with the CDJ-2000 Nexus

This is very frustrating because, honestly, I haven't had any problems with my pc other than with Rekordbox over Pro DJ Link. I am guessing it's something to do with Windows 10 but I have no idea what. I even uninstalled my Ethernet controller and let windows detect it on a restart. Didn't help at all.

DJ KennyD 0 votes
Comment actions Permalink
0
Avatar

having the same issue with cdj900nxs. I also fell back onto 4.1.2 because that still works properly with link. Really annoying issue.. i liked the features of the newer rekordbox.. really hope this issue is resolved soon.

Justin Johnson 0 votes
Comment actions Permalink
0
Avatar

IF you have updated to a new version of the software, you must configure the firewall to allow the 4 new instances through the firewall in order for the link to work! Simply having them configured from a previous rekordbox installation WILL NOT provide adequate permissions for the app!

Pulse 0 votes
Comment actions Permalink
0
Avatar

if you're referring to the bombardment of network permissions windows defender brought up at the time after installation i approved all of them. i'll try reinstalling again and double check to see if my network is private.. pretty sure it is but doesn't hurt to check. i'll also try temporarily turning off the firewall to see if that is the issue

 

thanks for your input! long time lurker, and just wanna say you're definitely appreciated for always being there to help

Justin Johnson 0 votes
Comment actions Permalink
0
Avatar

@Justin > Thanks for the comments!

One thing to try is to simply disable the firewall outright. If it works there, that's a good indicator the network traffic is being blocked by the firewall.

Pulse 0 votes
Comment actions Permalink
0
Avatar

currently at work.. off in a few hours. feeling optimistic! will report back later.

Justin Johnson 0 votes
Comment actions Permalink
0
Avatar

Disabling firewall does nothing for me. Still no waveform.

One thing I noticed on install is a new pop up window - can't remember what it is offhand - but on Windows 7 it had to install an extra piece of code for C+ or something. First time I have ever seen that window come up is with 4.2.1

toby spin 0 votes
Comment actions Permalink
0
Avatar

Same here. Disabling the firewall did not help and I do remember that extra code. I think it was some C++ maybe? Not sure if that has anything to do with this problem. I have had a major Windows update since I tested this last (a new build). Will have to reinstall the latest version of Rekordbox and test.

DJ KennyD 0 votes
Comment actions Permalink
0
Avatar

Ok Reinstalled version 4.2.2 on latest build of windows. Turned firewall off. checked network environment and it is private. Still no waveforms on CDJ-2000 nexus using Pro DJ Link. Audio plays fine but no waveforms are showing on the players. Reinstalled version 4.1.2 and everything works perfectly over Pro DJ Link. Guess I am stuck using older version for now. Need Link to work. It's one of the main reasons I switched from Serato to Rekordbox over a year ago. this is the first real problem I have had to deal with since the switch.

DJ KennyD 0 votes
Comment actions Permalink
0
Avatar

sadly, turning off the firewall didnt work.. i even installed the new 4.2.3. in both x86 and x64. i also just reverted back to 4.1.2. 

 

perhaps its time to change my 900nxs to xdj1000mk2 lol

Justin Johnson 0 votes
Comment actions Permalink
0
Avatar

Have tried Rekordbox version 4.2.4 x32. Using Pro DJ Link with CDJ2000Nexus. I get audio on the players but no wave forms or BPM shows up on the player screens. Even with Windows firewall turned off. The only security other than the firewall is Windows Defender (virus protection which you apparently have to live with). I turned the real time protection off to be sure it wasn't interfering but it didn't help.

Uninstalled version 4.2.4 x32 and re-installed version 4.1.2 and everything works fine. I just don't get why no version after 4.1.2 works correctly with my setup. This shouldn't be this difficult.

DJ KennyD 0 votes
Comment actions Permalink
1
Avatar

Hi Pulse and thanks for pointing this out!

I tried the new public beta version on my XDJ-RX but it didn't help.

As before, when using Pro DJ Link the music plays on the player but I am still not getting a waveform on the player screen and a message stating rekordbox track analysis required for QUANTIZE feature pops up on the screen for a few seconds when I load a song. I took a picture of the screen as the message appeared.

It will be a few days before I can test the new beta on the CDJ 2000 nexus players.

DJ KennyD 1 vote
Comment actions Permalink
0
Avatar

Hello,

 

same problem on my XDJ RX.... 

I went back to 4.1.2

Please fix it.!

 

thanks

Regards

 

Manuel 0 votes
Comment actions Permalink
0
Avatar

I also tested the new Beta version with my CDJ-2000 Nexus players. Still no wave forms on the players while using Pro DJ link. Even tried it with the firewall off. 

DJ KennyD 0 votes
Comment actions Permalink
0
Avatar

Same here.

No firewall. 32 Bit. Pro DJ Link via DJM2000nxs. CDJ2000NXS.

No waveforms - also it did not want to let me drag and drop the tracks direct to CDJ icon  in RB. Which is a new problem for me.

4.1.2 Still functional.

toby spin 0 votes
Comment actions Permalink
0
Avatar

Just tried the latest beta version (4.2.4 advanced5) with my CDJ-2000 nexus players using export mode over Ethernet with Windows firewall turned off. No wave forms or BPM info shows on the players when loading tracks. The audio does play. I tried both the 32 and 64 bit versions.

uninstalled beta versions and re-installed version 4.1.2 and everything works correctly. Although I might add that now (and since a few tests ago) some of the boxed info on my screen is bunched up and hard or impossible to read (when hovering over the player 1 or 2 boxes in the link section at the bottom for example).

DJ KennyD 0 votes
Comment actions Permalink
-1
Avatar

hello sir my cdj900 nxs   wave not display  pls help sir   small display working but big not show.  i try  track anlays with rekordbox but same 

 

 

Deepak Mali -1 votes
Comment actions Permalink
0
Avatar

I have tried every version since 4.1.2 (including the just released beta version 4.2.6) and still have no waveforms or beatgrid/BPM info when using in export mode over network on my CDJ2000 Nexus players or my XDJ-RX. The XDJ-RX says that I need to analyze my tracks in Rekordbox to use the quantize feature (no waveforms or BPM show on this product either).

I have also tried version 4.2.5 on 3 different pc's. Two running windows 10 and One running windows 7. All with the same results as stated above.

Version 4.1.2 is still functional although some of the pop up info on the pc screen is scrunched up now. Not sure if there is a fix for that.

 

DJ KennyD 0 votes
Comment actions Permalink
0
Avatar

Tonight I tried the new 4.3.0 rev.9578-10845-10843 BETA2 x64 version and am happy to report that I am seeing wave forms on my CDJ-2000NXS players again in export mode over Pro DJ Link.

I love how much quicker the 64 bit version responds.

I hope to test my XDJ-RX this weekend as I was also having problems with it as noted in previous posts.

Fingers crossed.

 

DJ KennyD 0 votes
Comment actions Permalink