Have a feature request or suggestion? Post your idea here!

Post

6 followers Follow
0
Avatar

DDJ-RZ becomes sluggish

I'm not entirely sure if this is a driver or RB issue, so if it's wrong feel free to move.

I've had a recurring issue now on the last few days where I will be playing along fine, then suddenly my RZ will start to freeze up. The flashing lights will all start flashing really slowly (such as the play and cue buttons) and the pitch fader will become unresponsive (I could move it, and nothing will happen for about 10 seconds).

The play and cue buttons work fine though and music stops (and starts) right away if pressed.

At this time, the blue bar in RB is still down low - and checking my CPU usage it's only at around 137% (Mac Air 2011 i7).

Usually lasts for about a minute, then just starts working fine again.

I haven't been able to catch it on video yet, but I'll see if it happens again tomorrow...

H3X Answered

Post is closed for comments.

21 comments

0
Avatar

could the unit be going into auto standby or demo mode ? 

is your music on the laptop or a external drive 

hugsta 0 votes
Comment actions Permalink
0
Avatar

Hey guys - had already done all that.

I might have found out a clue though.

Although I couldn't replicate it today, I did find that if I scroll up and down through the track listing quickly, the CPU usage moves up to 380% (it's a quad core) and then locks up the RZ whilst this is happening (as in, the lights all freeze up until I stop scrolling).

This seems more like an RB bug then - no way should the CPU be spiking just from scrolling through a song list!

H3X 0 votes
Comment actions Permalink
0
Avatar

Ok, doing it again today. Hadn't scrolled the track list, so i guess it's not that 😕

H3X 0 votes
Comment actions Permalink
0
Avatar

Are there any other applications running in the background at the time?

Pulse 0 votes
Comment actions Permalink
0
Avatar

Nope.

 

Today it didn't do it - and WIFI was off. Not sure if that's a correlation or not.

H3X 0 votes
Comment actions Permalink
0
Avatar

@H3X > Shouldn't be, but then again... we do recommend having it off if you don't need it. How often does it occur (how long between occurrences)?

Pulse 0 votes
Comment actions Permalink
0
Avatar

Ok, now I've worked out the pattern (although can't reproduce at will)

It's caused by loading a new track, simple as that.

I'll be playing fine, but as soon as I hit the load button, it will lock up. Takes about 30 seconds to recover.

H3X 0 votes
Comment actions Permalink
0
Avatar

It's been doing it so much these days, I managed to get it on video.

It wasn't the controller locking up though, as my friend who was plugged into the other USB port could use it fine (she was able to control her Mac as normal, whilst mine did nothing)

https://www.youtube.com/watch?v=niMCXlgbCYM

As you can see, moving the pitch fader does nothing, nor does using the touch pads. However, play, cue and scratching are unaffected, as well as the EQing.

I should have checked the FX, but forgot.

So hopefully that helps.....

H3X 0 votes
Comment actions Permalink
0
Avatar

I guess support aren't following this anymore, but one more thing.

When it's locked up, using the mouse to click on one of the touch pad selectors (hot cue, splice etc) it will properly switch the led lights to the correct pads and usually unlock the pitch control...

H3X 0 votes
Comment actions Permalink
0
Avatar

have you found a solution. same problems happening me on my DDJ RX. 

David hammond 0 votes
Comment actions Permalink
0
Avatar

No. I was thinking maybe my laptop was just under powered, but the same issue has now happened on my gfs quad core mbpro!

H3X 0 votes
Comment actions Permalink
0
Avatar

Ok, it happened a lot again today, and every time I was able to "unlock it" - by simply clicking the "Hot Cue" bank selector.

I guess then this means it is a RB bug, so I'll put this in as a ticket now :)

H3X 0 votes
Comment actions Permalink
0
Avatar

thanks Hex, ill give that a go when it happens again.

David hammond 0 votes
Comment actions Permalink
0
Avatar

@David > Your RX issue may be resolved by resetting the hardware; try this fix:

1. Disconnect the USB from the RX
2. Turn on the power of RX while pressing [SHIFT] button on the left deck and [DECK 1] button at the same time. 
3. Wait for about 5 seconds.
4. Press the [SYNC] button on the both decks for 3 seconds.

When the [SYNC] buttons' LED is turned off, reconnect the USB and launch rekordbox to see if the latency has improved.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Great, thanks for the information Pulse. I will get onto that this afternoon. 

 

David hammond 0 votes
Comment actions Permalink
0
Avatar

@Pulse I have the same issue as David and tried what you have suggested. It worked for about 15-20 minutes and then the same thing occurred. Do you have any other suggestions? 

Ivan Polikarpov 0 votes
Comment actions Permalink
0
Avatar

David/Ivan - At the lock up time, are you able to use the play and cue buttons like I am?

Does it also "unlock" if you click on a Pad Mode selector in the RB software itself?

I am in discussion with support now and it would be good to confirm if the RX is having exactly the same issue.

H3X 0 votes
Comment actions Permalink
0
Avatar

H3X Play and cue buttons work, but I haven't tried clicking on a pad mode in rb to unlock. what did support tell you? I saw other posts describing the same issue on rx as well 

Ivan Polikarpov 0 votes
Comment actions Permalink
0
Avatar

I can use the Play Cue buttons but using pad mode selector in Rb software does nothing

David hammond 0 votes
Comment actions Permalink