Have a feature request or suggestion? Post your idea here!

Post

6 followers Follow
1
Avatar

Lighting mode using external mixer mode not working?

Just got my RB-DMX1.  Lighting on Deck 2 doesn't seem work in external mode.  Using two XDJ-1000MK1s in HID mode and Rane MP2015 mixer.  Deck 1 works fine, but as I'm mixing a song on Deck 2 in and finally stop the song on Deck 1, the lights go out.

This begs the question, how does the software know when to change the lighting scenes from Deck 1 to Deck 2?  Also in that regard, what about the transition period when both songs on Deck 1 and Deck 2 are playing and mixing?

As a hunch, I tried internal mode.  I figured out that when you move the internal crossfader from Deck 1 to Deck 2, the lighting scenes change also to Deck 2. So I MIDI mapped the internal crossfader to my MP2015, then changed back to external mixing mode, but no dice, that didn't work as the disables the internal crossfader entirely.

Please do not tell me that Lighting mode only works in Internal mode, or with Pioneer only mixers/controllers.  If so, that's a huge oversight that I haven't seen stated anywhere, and I will be returning the RB-DMX1 promptly if that is the case.  

 

Todd Konwinski

Please sign in to leave a comment.

20 comments

1
Avatar

Anyone?  Tried the new beta 5.3 hoping it would make a difference, no luck. The only time lights work is when song in playing on Deck 1 in external mode.  Tried setting each deck to Master, both in the software, and on my XDJs, but doesn't make a difference.  Lights only work on Deck 1 no matter what. Unless of course I set it to Internal mode and use the internal software crossfader, then it works, on all decks,  but I use external mode :/

Is this a bug? I hope it gets fixed.

Todd Konwinski 1 vote
Comment actions Permalink
0
Avatar

Hey Todd,

Sorry to hear you're having these issues. That MPC2015 is a helluva mixer!

It's certainly not limited to Internal Mode and I believe the lights react to whatever song becomes the "Master" deck (@Pulse can correct me on this). So if you were riding the crossfader in the middle (mixing from A to B), the lights would switch once B was fully mixed into, becoming the Master deck.

It's certainly perplexing that you're able to get the lights from Deck One and not Deck Two. Since the lights are reacting to Deck One, we know there's communication going on. Just to confirm, you're hearing music from Deck 2, it's just the lighting that's not active. Is that correct?

A couple questions to help narrow things down:

Have you tried assigning a different channel, other than Deck 2? I believe the MPC2015 is a 4-channel rig, is that accurate?

When you mix from Deck 1 to Deck 2, does the Master assignment switch respectively within Rekordbox DJ?

How are you connecting your devices? In other words, is everything plugged directly into your laptop via USB or are there any Hubs involved in your setup? Is the MPC2015 acting as your audio interface or do you have an aggregate setup with the XDJ-1000 decks?

Do the XDJ Deck assignments match their respective Rekordbox DJ counterparts?

Sorry for the barrage of questions. The more detail provided, the more we can help narrow down the problem.

lostnthesound 0 votes
Comment actions Permalink
0
Avatar

I've got the lighting team looking into this, not sure why that's occurring. 

Pulse 0 votes
Comment actions Permalink
0
Avatar

Just to follow up, I’m actually having the same issue (using an NXS2 mixer rather than MPC. The one thing I’m noticing is that the second CDJNXS2 isn’t showing up in the device list in preferences. Though I’m still able to use it in Performance Mode despite not being listed, the Lighting Mode is not communicating with that deck’s data. Also, even when cutting the volume on Deck 1/Channel 1 (or the fader) the lights continue to follow the phrasing as if the music was never cut in volume (or mixed to a new track). FWIW, currently using the latest RB release.

lostnthesound 0 votes
Comment actions Permalink
0
Avatar

There's an identified issue where lighting users with external mixers are only able to use lighting on deck 1; the next update will have a feature to assist with switching between decks (as the software can't detect which deck is the primary for lighting with an external mixer). Thanks for your patience.

Pulse 0 votes
Comment actions Permalink
0
Avatar

I have the same issue with my 2000Nexus (CDJ/DJM) setup. Major let down.

djsvazquez 0 votes
Comment actions Permalink
0
Avatar

Can I run the license on my computer with my DDJ-SX2 in the interim?!?!?!

djsvazquez 0 votes
Comment actions Permalink
0
Avatar

@Steven > Yes! And external mixer mode will be coming in the next release. It's a bit of a work-around because of some technical hurdles presented with non-Pioneer DJ mixers, but it will certainly get the job done.

Pulse 0 votes
Comment actions Permalink
0
Avatar

@Pulse > For Pioneer mixers/dj setups (example: DJM-900NXS2 + 2 x CDJ2000NXS2) will the next release have a fix the same problem and will it be an actual fix versus a workaround?

lostnthesound 0 votes
Comment actions Permalink
0
Avatar

It will only be a workaround at this time, a proper fix may be included at a later update.

Pulse 0 votes
Comment actions Permalink
0
Avatar

I have a djm900nxs with internal mode I can see the A&B buttons for the lighting but the auto button is grayed out. You can only map those buttons to an external midi device and not the actual cross fader on the djm900nxs. This is deal breaker for me. I thought this was automated with Pioneer gear when i bought it. This was suppose to simplify my mobile gigs. Do we know if this work around will work with the djm900nxs and cdj2000nxs? 

rodney smith 0 votes
Comment actions Permalink
0
Avatar

@rodney > You can't use automatic mode with an external mixer configuration. But yes, you could actually map those buttons to a crossfader, it would just take a bit of extra work to do so as the crossfader signal is not what rekordbox is expecting to receive for those two buttons. You'd need to use a MIDI translator app to set it so the low value on the left sends one control change signal, then the high value on the right sends a different control change.

Pulse 0 votes
Comment actions Permalink
0
Avatar

I downloaded the Bome midi translator and was able to get it to work. Thanks you for giving me the ideas.

rodney smith 0 votes
Comment actions Permalink