Have a feature request or suggestion? Post your idea here!

Post

4 followers Follow
0
Avatar

Major Bug in Toraiz sp-16 sequencer

The sp-16 has a major bug whereby the MIDI clock seems to be a fraction of a second late. It looks like offsetting MIDI by one step works but that means when composing you have to avoid the first step and/or the last one. Otherwise this causes the music to stutter when switching from one scene from another or even just when melodies are looping, for example.

Also, MIDI capture is on SAMPLE channel so all MIDI data is not captured (velocity etc.)  Capture is also monophonic, there is no note length and on the wrong octave.

bandit meerkat

Official comment

Avatar

Hello Bandit,

I have not had seen this problem on the Sp-16. Could it be your connection or your settings with your other modules. 

D.j. Creme
Comment actions Permalink

Please sign in to leave a comment.

10 comments

0
Avatar

Not on mine.  I can run both an external sequence on my SH-01A alongside an SP-16 sequence (ch 1) - the SH-01A is set to polyphonic, so it plays both at the same time - and have another sequence playing from the SP-16 into a Bass Station II (ch 2) and the timing is solid.  The internal sequence in the SH-01A is set to 100 steps, so it does not follow the same 16 steps as the SP-16, but both are perfectly in sync with each other.

Does anything in particular trigger this behavior?  

Blue Monster 65 0 votes
Comment actions Permalink
0
Avatar

i have two scene this issue  also i feel we need independent track control for rolls whie being able to mute other pads

 

DJ HIPNOTIC STARR 0 votes
Comment actions Permalink
0
Avatar

I can only log in to UK website, not USA so they will not see this comment

I had no problems like this when I was using a laptop and a DAW so I am certain it is pioneer. Just go ahead and create a two bar sequence to sequence an external synth, create notes in the first bar with a note on the last step (1 step length) and leave the next bar blank and the note should repeat endlessly.

bandit meerkat 0 votes
Comment actions Permalink
0
Avatar

Sorry, man, but I still don't have that problem.  I tried to set the note length longer, but it didn't do it then, either.  

I did as you said: set a 2-measure pattern with notes only in the first measure (and the last note on step 16, plus I tried notes on 13, 14, and 15) and the note doesn't carry on for me.  

Not sure what's up with yours, but I cannot repeat what you're doing.   If you think of something else to try, I'd be happy to.  

Blue Monster 65 0 votes
Comment actions Permalink
0
Avatar

Thanks for all the replies.

I have just created an intro to a track - scene 1 pattern 2 is the 1st four bars, then link that up in the arranger to scene 1 pattern 3 for the next four bars of (differing) melody then go to scene 1 pattern 1 for the track itself. I've removed all triggers for the instrument in question scene 1 pattern 1 but the melody (last note) repeats endlessly. I made the demo's on a DAW and in most instances I am perfectly replicating what I created there on the Toraiz and had no problems (on the DAW).

Having said that whe I tried the previous example I gave earlier...

(create a two bar sequence to sequence an external synth, create notes in the first bar with a note on the last step (1 step length) and leave the next bar blank and the note should repeat endlessly)

I was not able to re-create the flaw (but had previously)

So, the problem seems to come and go and I cannot isolate the  conditions under which the results vary.

 

Re: MIDI capture, I tried to capture a 4 note bassline but was only able to record 2 notes but persisted until I recorded three notes from the bassline (which was played back off the bass machine's sequencer, not played manually).

 

Does anyone else experience these kind of problems?

bandit meerkat 0 votes
Comment actions Permalink
0
Avatar



Even worse, I have discovered that not only does one note interfere with another on the same track but there is a knock on effect onto other tracks. Track 5 & 6's notes repeat endlessly (going from scene 1 pattern 3) into a blank track (scene 1 pattern 1), unless I shorten the notes so they finish before the end of the bar) but they also interfere with my drum track (4) unless I offset the notes on track 5 & 6 so they don't all trigger at the same time.

bandit meerkat 0 votes
Comment actions Permalink
0
Avatar

Dunno what to tell you!  I haven’t had the same problems, but sympathize with your frustration.

Are there certain samples and external synths that you’re using when things go awry or does it happen with any sample/external combination?

Blue Monster 65 0 votes
Comment actions Permalink
0
Avatar

No, I have a complete set of Roland Aira's which I use for aevery track and I had no problems with the same tracks on my DAW.

bandit meerkat 0 votes
Comment actions Permalink
0
Avatar

Here's another one, when switching scenes I send MIDI to my mixer (Aira MX-1) but the signal is 1 step (1/4 note slow) so it sounds poor - I will have to mute 3 channels manually on my mixer because the Toraiz's timing is latent.

bandit meerkat 0 votes
Comment actions Permalink