Have a feature request or suggestion? Post your idea here!

Post

8 followers Follow
0
Avatar

Rekordbox DVS not working with DJM 250 Mk. 2

Hi,

A week ago I purchased a DJM 250 mk2 which came bundled with RB-VD1-K control vinyl and Rekordbox DJ + DVS (both activated on the computer.)

I am using a macbook pro running High Sierra 10.13.4, have the latest firmware installed on the mixer (as well as the drivers installed on the mac.) I am also running the latest update of Rekordbox.

When I connect the mixer to the mac and enter rekordbox the software registers that the mixer is connected, however when I play the control vinyl and go to the DVS setup page the calibration circles do not appear and the software does not seem to register that they are playing.

Pioneer phone support have not been very helpful with this at all, and I feel like I've tried everything! Thanks in advance for any help!

Patrick Dixon

Please sign in to leave a comment.

20 comments

0
Avatar

Hi there, thanks for your reply. I am not getting a system extension blocked message when installing the drivers so not sure if this is an issue?

Patrick Dixon 0 votes
Comment actions Permalink
0
Avatar

You may not receive an alert during the installation process -- it may appear to work just fine, but when you go into the control panel, you'll see that button is available to disable the driver security.

Pulse 0 votes
Comment actions Permalink
0
Avatar

HI there,

I have also been having the same issue. The DVS was working prior to my MAC software update to high sierra. I have also downloaded the newest firmware and driver without any luck. LIkewise there seems to be no security warning when i downloaded the new driver software. Please help!!!

Dylan Swanborough 0 votes
Comment actions Permalink
0
Avatar

@Dylan > As above, you won't SEE a warning, you simply have to install, then disable the driver security, then install AGAIN. What you might try doing is using the driver uninstaller from the download package, then running those steps.

Pulse 0 votes
Comment actions Permalink
0
Avatar

This is just crap service from Pioneer.  I've been trying for 7 days to connect my $400 DJM-250 to my MacbookPro.  Hopeless.  Impossible to do.  Online support is a joke.  Two basic emails a day from someone who cant speak english.  Wish I'd bought another product. 

Simon Barrett 0 votes
Comment actions Permalink
0
Avatar

@Simon > Sorry about that -- I just looked at your ticket, and you have someone who speaks English quite well. In fact, she's not only the head of our customer resource & support team, but also the lead translator for the engineers in Japan. So by selecting Japan as your country, you've managed to get the best possible agent dealing with your issue.

And I have to say, they've been quite active on your ticket, responding to your inquiry within our 24hr window, then providing several responses over the following 6 hours.

I will ask if you disabled the driver security when you installed the drivers the first time? If not, run the driver installation again, disable the security, then install them once more immediately.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Hi, having the same problem with the DJM 250MK2, running Rekordbox performance mode with channel 1 and 2 set to relative (dvs licence actived) on Windows 10 with 2 Rekordbox control vynils running on 2 Audio Technica ATLP 120 USB connected to the mixer through phono channels 1 and 2 and selected phono inputs on the mixer. I can see on the LEDs the control signal being received by the mixer (and i actually hear the signal on the my speakers) but no signal is showing on my calibration page in Rkdbx (only a small dot in the center of the calibration grid, no frequencies at all).

Just updated drivers and firmwares again as per the latest ones present on the pioneer website for the DJM 250 MK2 today, December 7th 2018 just to make sure.

Chabana 0 votes
Comment actions Permalink
0
Avatar

Have you tried opening the DJM-250MK2 Settings Utility and toggling the input selector from TIMECODE (PHONO) to another option, and back?

Pulse 0 votes
Comment actions Permalink
0
Avatar

I'm having this exact same issue. Have tried restarting, reinstalling, everything, and cannot seem to get the DVS to work. Mixer works great otherwise, and I get the sine tone when I switch to the line in, but nothing in Rekordbox.

Have tried swapping between Phono / Line / USB and nothing.

Please advise.

Nels Tate 0 votes
Comment actions Permalink
0
Avatar

I solved it by switching source to USB, the green rings popped right up. It is counter intuitive to not be on phono, that's why it is so puzzling

Chabana 0 votes
Comment actions Permalink
0
Avatar

It's not PHONO because that would be the input source to the channel; you want the audio coming from the USB source. The routing of the phono input would then go to the software, and the software output to the mixer.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Yes, have the slider on the USB selection. Previously in the comments, they suggested switching between USB and the phono input to reset the mixer? Either way, I definitely cannot get the DVS control again after updating to the latest version (worked fine before).

Nels Tate 0 votes
Comment actions Permalink
0
Avatar

Im having this same problem and still having trouble trying to figure it out. Can some one please make a youtube video on how to set it up. Would have thought there would have been mutiple tutorials for the mk2 and rekordbox but i cant find any reliable sources.

 

rene diaz 0 votes
Comment actions Permalink
0
Avatar

I have the problem since i purchased the DJM-250mk2. I never saw the message about allow the Pioneer developer for install the driver. I check both ways. When I install the driver never i get any message, i tried to search it in the security and privacy setting and i don't find nothing. The driver it's installed always without problems but can't work with RekordBox. Anyway, it's a real crap make this "tricks" in a brand new software. Please Pionner: try to made a vídeo with the instruction and what I'm supposed to do if in any case i don't have the message to allow Pioneer. I installed and reinstalled several times trying to get the sacred message. Bad for Pioneer.

GONZALO FREDES 0 votes
Comment actions Permalink
0
Avatar

Sorry, but these "tricks" are Apple security, not something Pioneer DJ has done. Instructions are here, as was previously linked.

Please open the System Information application and click the Disabled Software item under Software. If you see the Pioneer DJ driver there, you didn't allow it through security.

Pulse 0 votes
Comment actions Permalink
0
Avatar

And what I'm supposed to do for this two type of cases?:

1- When I install the driver i didn't get any message to allow Pioneer. That's includes any message in the security and privacy window too.

2- In system information app, in the tab Dissable Software, the list it's empty. I mean, no Pioneer DJ driver.

Off course, the DJM250 don't run in both cases on RekordBox.

I can't allow Pioneer DJ in any part on my Macbook. No message, any alert in the Security and Privacy window, and any message on the Disabled Software tab.

GONZALO FREDES 0 votes
Comment actions Permalink
0
Avatar

1. macOS 10.13 never prompts with any alerts; this is a function of the OS. You have to click into the security window to see it. Fortunately 10.14 and 10.15 do alert the user.

2. If it's JUST the DVS not working, did you also allow rekordbox access to the microphone (audio input)? Go to System Preferences > Security & Privacy > Privacy > Microphone (left) and click the box beside rekordbox (right).

If nothing is working at all, follow these steps:

  1. Unplug the USB from the DJM.
  2. Go to your Applications and open the Utilities folder, launch the Terminal app
  3. Type (or copy/paste) the following command: 
    sudo kextcache --clear-staging
    That's a space after "kextcache" then two hyphens.
  4. You will need to enter your Mac user password (or just hit enter if you don't have a password); it will not show any characters onscreen as you type, press return when you are done and the process will run.
  5. Download the driver.
  6. Open the driver package and run the uninstaller file.
  7. Reboot your computer.
  8. Open the driver package and run the driver installation file.
  9. After the installation has completed, give the drivers permission.
  10. Reboot your computer.
  11. Reconnect the DJM and test as normal.
Pulse 0 votes
Comment actions Permalink
0
Avatar

I'm having real problems with this. Have followed the post directly above and that does push the install process to ask the question again.

I then disable the driver security as per the instructions. It still doesn't work. For some reason, it doesn't ask approval for Pioneer app to have access. It's some other company name. Presuming that's just a holding company or something. 

Please help someone. I've spent all day installing, uninstalling and re-installing this driver to no success.  :-(

Andrew Payne 0 votes
Comment actions Permalink
0
Avatar

@Andrew > Is it possibly trying to install another driver? The DJM-250MK2 drivers certainly are signed by the right company:

Pulse 0 votes
Comment actions Permalink