Have a feature request or suggestion? Post your idea here!

Post

9 followers Follow
0
Avatar

How To: Split Cue on the DDR-RZ (and maybe others)

Ok so this isn't the perfect solution, but it's good enough for me.

Many thanks to @Hentoneuf's post (https://forums.pioneerdj.com/hc/en-us/community/posts/206876286/comments/207866526) for pointing me in the right direction.

I've found two different configs to achieve this, I personally prefer the second one, but I'll put them both :)

You need to edit the "rekordbox3.settings" file which on Windows can be found in the "AppData\Roaming\Pioneer\rekordbox" folder. (Use shortcut %AppData% to quickly get there)

Then once that file is open, scroll down until you find the section DEVICESETUP with the audioInputDeviceName="DDJ-RZ ASIO" - it should look roughly like below:

The important settings we will modify in that block are:

OutputChannel_Master_L="0" OutputChannel_Master_R="1"
OutputChannel_Cue_L="2" OutputChannel_Cue_R="3"

As you might guess, the numbers 0 - 3 represent the different physical outputs on the RZ, and by changing these we can achieve SC.

Config 1 - Master Left Earphone, Cue Right Earphone

Make the following changes (in bold):

OutputChannel_Master_L="2" OutputChannel_Master_R="2"
OutputChannel_Cue_L="3" OutputChannel_Cue_R="3"

This will give a true Split Cue, however has the downside of *always* being like that (so you cannot get both sides playing the master if you wanted to)

 

Config 2 - Master both Earphone, Cue Right Earphone

I much prefer this, as when not cueing up, you can listen to the master on its own in both ears (the equivalent or taking off your headphones when in the mix usually), to do that, make the following change (in bold):

OutputChannel_Master_L="0" OutputChannel_Master_R="1"
OutputChannel_Cue_L="3" OutputChannel_Cue_R="3"

I also like this method as if the cue is too quiet (or even too loud) - you can use the Cue/Master blend knob to adjust.

 

And that's it - remember to also turn on the "Master Cue" (top right of the unit) but apart from that, you can just select cue channels as normal :)

H3X Answered

Official comment

Avatar

I'll add the recommendation that anyone trying this should create a copy of their settings file BEFORE modifying it, and if you're using the Mac TextEdit app, you should disable the Smart Quote setting in the preferences.

Pulse
Comment actions Permalink

Post is closed for comments.

11 comments

0
Avatar

** Amendment to Config One (True split cue) **

Realised there is a better solution, the config should be:

OutputChannel_Master_L="0" OutputChannel_Master_R="0"
OutputChannel_Cue_L="3" OutputChannel_Cue_R="3"

This way, you can still use the Cue/Master blend knob to modify the balance between the two (some of my cue tracks are way too quiet for example, so you can twist the knob towards cue to make the master quieter, then use the headphone volume to raise the cue volume)

Again, remember to turn on the "Master Cue" (top right) to get any master sound out.

And yes, as Pulse says - back up the file first :)

H3X 0 votes
Comment actions Permalink
0
Avatar

I've tried this approach on DDJ-1000 as I would love split cue function. Sadly, it doesn't seem to work on DDJ-1000. Would be interested to hear if anyone else with DDJ-1000 has had success...

 

srkeevil 0 votes
Comment actions Permalink
0
Avatar

Hey - I have a DDJ-1000 as well and it works fine on that (also my RR and RB :))

I've had an issue where it hasn't worked the first time, but if I close RekordBox and edit again it started to function properly.

H3X 0 votes
Comment actions Permalink
0
Avatar

Hey H3x,

So, I just revisited this and gave it another go. This time it works! There are a few entries in the XML file that look like potential candidates for editing. I guess I picked the wrong one last time. I've gone with the option for main cue through L&R and cue through R only. Working a treat! Many thanks for the advice... :)

 

srkeevil 0 votes
Comment actions Permalink
0
Avatar

Hi, I've just come across this and it works nicely for decks 1&2. Is there a way to set this up for decks 3&4 for my turntables? At the moment i hear the mix in my right ear but when mixing in on the turntable to cue tune is through both L&R. thanks for any help. 

Chris Woods 0 votes
Comment actions Permalink
0
Avatar

Where can I find rekordbox3.settings file on MacOS:
~/Library/Application Support/Pioneer/rekordbox6/

Manuel Weiss 0 votes
Comment actions Permalink
0
Avatar

Hello, I just tried H3X various configurations and it worked, but I got hit with a few surprises. So here are my added comments to help anyone else out.

My setup (DDJ-1000 with macos 11.7.6 with RB 6.7.2). Like Manuel mentionned, I found the settings file in ~/Library/Application Support/Pioneer/rekordbox6/. I would expect this path to change according to the future major versions of RB.

Start off by making a backup of the settings file. Very useful for doing diff or reverting back.

Originally I edited the very end of the XML. Using vi as an editor, I jumped to the end and reversed searched for the first DDJ-1000 section I found. However that didn't work. So looking more closely at the XML file I found out they are several sections for my controller. I found two for the exportmode sound configuration, and two for the performancemode. I was able to split cue once I had edited both performance mode sections for my controller.

Another thing I noticed, don't edit this file while RB is running. I found it partially wrote over my changes. So make sure RB is not running, edit, then start RB.

Lastly, in my case, I wanted the reverse to H3X, so I applied this config to get master on right ear et cue in left.

OutputChannel_Master_L="1" OutputChannel_Master_R="1"
OutputChannel_Cue_L="2" OutputChannel_Cue_R="2"

Thx to H3X for doing all the leg work.

Emery Guévremont 0 votes
Comment actions Permalink
0
Avatar

Gonna add another comment concerning this setup. After having recorded a mix, the master output was low on the left side, so I ended putting back the master output as it was before like so:

OutputChannel_Master_L="0" OutputChannel_Master_R="1"
OutputChannel_Cue_L="2" OutputChannel_Cue_R="2"

Emery Guévremont 0 votes
Comment actions Permalink