Have a feature request or suggestion? Post your idea here!

Post

3 followers Follow
0
Avatar

Plug and Play DVS with all DJM Mixers in Rekordbox

I've been struggling to get DVS to work with a DJM Mixer and Rekordbox, it should be just as simple as plugging your mixer into your computer and just switching the inputs on the mixes itself. I shouldn't have to be a tech wizz to use rekordbox, I should just be able to rock up into the club as a total n00b and plug my laptop into the mixer, switch the inputs and be able to play in a matter of seconds.

Ash C Answered

Please sign in to leave a comment.

8 comments

0
Avatar

It might be more helpful to provide the Pioneer staff with some information. 

 

Which DJM mixer are you trying to connect with?

Which OS are you using with Rekordbox?

Which version of Rekordbox are you running?

Ves 0 votes
Comment actions Permalink
0
Avatar

So I'm on a Late 2013 Retina Macbook Pro with 16gig of ram and a Intel Core i5 running Mac OS Mojave 10.14.5
I'm running Rekordbox 5.6.0 with the DVS plus pack that came with my DJM 250, and I bought a pair of Rekordbox Control Vinyl (in translucent blue, very sexy).

I have a DJM 250mkII Settings Utility installed, with the USB inputs set to:
USB 1/2 -> CH1
USB 3/4 -> CH2
USB 5/6 -> AUX

The USB outputs are set to:
USB 1/2 -> CH1 Control Tone PHONO
USB 3/4 -> CH2 Control Tone PHONO
USB 5/6 -> Record Output

Everything is set to USB/DVS on the physical switches on the mixer.

In the Rekordbox preferences window I have the Enabled DVS Function box ticked, and that's where I'm stuck.
When I play the Rekordbox Control Vinyl there is no signal coming into Rekordbox and there is nothing on the scope on the calibration window.


What am I missing? What am I doing wrong? Will I ever be able to get this working?

Ash C 0 votes
Comment actions Permalink
0
Avatar

Might be a silly question but on page 15 if the guide in the link Pulse, could you check if the DVS mode is set to INT in your Rekordbox, if so change it to REL or ABS.

Ves 0 votes
Comment actions Permalink
0
Avatar

Just did a search and saw a few people with similar issues. 

 

The only things I can think of to try a double check to see if the security driver was disabled.. https://www.pioneerdj.com/-/media/pioneerdj/downloads/other/troubleshooting/troubleshooting_highsierra_003_e.pdf?la=en&hash=F926BC62D3C490CB95D98DE599E8D04797D2C6F8

Double check if the firmware of the DJM-250 MKII is the latest. Re-install it https://www.pioneerdj.com/en/support/software/mixer/djm-250mk2/

Reinstall the driver, this needs to be reinstalled after certain OS version updates

Ves 0 votes
Comment actions Permalink
0
Avatar

I'll look into that tomorrow, fingers crossed it'll work. Thank you for your help

Ash C 0 votes
Comment actions Permalink
0
Avatar

The other thing to verify is that your audio device settings are configured properly in the rekordbox preferences.

Sometimes, even changing the output settings on the device manager from PHONO to LINE and back can help it.

Pulse 0 votes
Comment actions Permalink