Have a feature request or suggestion? Post your idea here!


2 followers Follow

my Xdj r1 is not recognised by the software



i have this problem: my consolle (Pioneer Xdj r1) is not recognised by Traktor software. I have tryed different Usb Cables and the problem is still sthe same. I have tryed also to change from a Windows pc (my actual Pc) to a Macbook and in this last case the software works with the consolle (on my old Macbook i have installed Traktor 2.6.7).

I have WIndows 10 with Traktor

i 've already downloaded Midi Ox (a program that tests if the console sends midi inputs ) and everything seems to work.

I have updated the system. i have updated the drivers. I'm becoming mad.

The strange thing is that till the next week it worked and it stopped and i don't know why.

Have you got any suggestions?


Peter Flow

Post is closed for comments.



I'm talking about control. I have already downloaded the midi files and i had set the r1 asio as the device in the settings.

The traktor software loads the xdjr1 as soundcard but it doesn't answer to my commands. If i try to move the knobs, the faders and all the buttons, the software doesn't recognise them. How is possible , considering the fact i had used it for two years?

Is possible that the last windows update had a sort of impact on the software? 

Note that it doesn't work both with Traktor 2.6.7 and with my last update to traktor

Please help me!!!

Peter Flow 0 votes
Comment actions Permalink

I can't say with any certainty why it would have stopped responding to the signals; have you tried using a MIDI monitor to see if the data being transmitted by the R1 matches the mappings you have set within Traktor?

And yes, it's always possible that a Windows update has somehow interfered with the settings / configuration of either the drivers or the software.

Pulse 0 votes
Comment actions Permalink