Have a feature request or suggestion? Post your idea here!


2 followers Follow

USB stick suddenly not visible

Rekordbox users. Can anyone help me please.
My new 128gb sandisk stick has been working fine. Last night I bought and added a new track, saw it sync the single track to the stick. This morning I went to listen to the new tune and it claims the stick is empty. I can see the actual audio files are there in the finder on my Mac. Then I noticed the folder 'Pioneer' was missing from the stick. 

Ive done the next bit twice. Reformatted it exactly the same way as it was in the first place. Hours pass. Done. And still no Pioneer folder and thus the RX2 cant see anything on the stick. It even cant see any files in the way you would if you weren't using Rekordbox to prepare.

So what about formatting. Ive read somewhere on this Pioneer site that it doesn't matter which format is used, FAT32 or GUID. Ive tried both in the past and they have worked fine. 
And as I said it all works fine on the Mac, in the finder and within Rekordbox the files can all be seen.

Lee Jones

Please sign in to leave a comment.

1 comment


Before I dive in, just to clarify -- FAT32 is the file system, GUID is the boot record format. It may not be recognized because you need it to be set to MBR (Master Boot Record), not GUID.


Pulse 0 votes
Comment actions Permalink