Have a feature request or suggestion? Post your idea here!


4 followers Follow

can't record audio from djm 900 nexus 2 with ableton line 10

record djm900NXS2 audio with ableton live 10

hello everyone.

I haven't been able to record audio coming from djm900nxs2.

With ableton 9 on my other computer, there is no problem, everything works fine. But when I try to do the same thing with my new computer where I have ableton live 10 installed, there is no signal coming from the mixer to the channels

i have:

Operating System: Catalina

djm 900nxs2 driver: 2.0.1

Vasilii Alexander Golub Answered

Official comment


Did you allow Ableton access to your mic (which controls audio line-in) through the MacOS preferences? Open System Preferences > Security & Privacy > Privacy and select the Mic at the left, then tick the box beside Ableton on the right.

Comment actions Permalink

Post is closed for comments.



OOH!! That's why!

Just fallowed your steps. Now it works:)

Thank you very much, and happy new year

Vasilii Alexander Golub 0 votes
Comment actions Permalink

i have the same issue but mic is enabled through privacy.


I also have no soundcard option at all for audio outputs in ableton and operating system.


pls help!


Ryan Crowe 0 votes
Comment actions Permalink

I'm having the same problem. I followed the instructions, clicking Allow when prompted in Security & Settings. DJM 900NXS2 is being recognized as a device, and when I view set it as an input on Sound settings in Mac OS, it appears to be getting a signal as the meter in the Sound settings reacts, but when I try Audacity or OBS there's no sound when using DJM 900NXS2 as the input device. 

I've also checked the mic enablement in Privacy Settings and everything is checked. I've tried uninstalling and reinstalling many times today and haven't had any luck. I've never had this much trouble installing anything.

Any suggestions beyond the link you already shared, because that isn't doing it.


simfonik 0 votes
Comment actions Permalink