Have a feature request or suggestion? Post your idea here!


3 followers Follow

Beatport Link with 5.8.2

Good Day. Is there a known issue or a fix for Beatport Link not working with the new update? Login works great, I can see my playlist, I can see the tracks but cannot for some reason get them to load. I'm on a Mac and using 10.13.6 Mac OS High Sierra

Brian C Gaignard

Please sign in to leave a comment.



Starting yesterday I couldn't get Beatport Link to work with my Macbook Pro (2017). Every Beatport track gave the "Track Loading Error". Since I recently got a new Mac, I was okay to fully wipe this one and reinstall a fresh copy of Catalina. Now it's working. I'm not sure what was wrong before, but that OS had been upgraded many times, and restored from Time Machine backups on one occasion. I definitely tried removing and reinstalling RB, and reseting my library, and all the tricks, but nothing worked until I did a full wipe of macOS. I'm not sure how "worth it" Beatport Link is to you, if you want to try what I did. My first experiences with Beatport Link and RB using my NXS2 hardware is okay, but there are already annoying things like not being able to make local playlists using the streaming tracks. Streaming tracks are not added to your history lists either. I guess you know all about it. Good luck.

robert91303 0 votes
Comment actions Permalink