Have a feature request or suggestion? Post your idea here!

Post

3 followers Follow
0
Avatar

BUG REPORT - Beat grids not staying where I place them

I'm using v5.8.3, with Windows 10.  This problem also happened in older RB versions. I have been getting a consistent bug, occurring very often in one specific situation:

First, I move the beat grid for a particular track (either by clicking on the spot where I want a new beat 1 to be located, or by using the buttons to nudge the grid left or right). I do this first step in "1 player" view.  Then, to see if the beat sounds right when I sync with another track, I switch to "2 player" view and load a second track.  Then I play the two tracks, with beat sync on.

The problem arises as soon as I activate beat sync.  The beat grids that I adjusted a moment before have now moved from where I placed them.  That's it.

I can avoid this problem by activating "analysis lock" before I play the two tracks with beat sync on.  This is annoying though - I should not have to (and do not want to) activate analysis lock until I have completed any and all adjustments.

Thank you

Version 5.8.3

Windows 10 Pro

John

Please sign in to leave a comment.

7 comments

0
Avatar

@John > Are you still in the grid edit mode when this happens?

Pulse 0 votes
Comment actions Permalink
0
Avatar

The problem happens whether I am in grid edit mode or not.  I suspect you can easily recreate this behavior on your own.  Have you tried?

John 0 votes
Comment actions Permalink
0
Avatar

I don't have performance mode.  I bought a DJM-900 Nexus 2 and three XDJ-1000's, none of which include a Rekordbox DJ license lol

John 0 votes
Comment actions Permalink
0
Avatar

One additional piece of info - the spontaneous movement of the beat grids appears to be visual bug only.  If I re-load the same track that is exhibiting the bug, the grids move back to where I had previously placed them.

John 0 votes
Comment actions Permalink