Have a feature request or suggestion? Post your idea here!

Post

4 followers Follow
0
Avatar

XDJ-XZ not appearing as audio output in Rekordbox

I am trying to connect my Mac laptop (Big Sur OS) to my XDJ-XZ.  I have uninstalled and reinstalled the drivers.  The XDJ-XZ can see the tracks I have on the laptop and I can load the tracks into the XDJ-XZ's deck BUT the audio output is the laptop's internal speakers.

I have looked in my Rekordbox Preferences in the audio tab.  Under the heading "audio" I don't see the XDJ-XZ as a choice.  I have installed the driver numerous times and see XDJ-XZ listed as a control device at the bottom of the audio menu. 

What can I do to change the audio output?  I have also looked in Utilitiies/Audio Midi Device, but I don't see the XDJ-XZ there either.

 

Thanks!

-ted

Ted Wang

Post is closed for comments.

17 comments

0
Avatar

So I don't know whether I did it properly the first time, but I went back and uninstalled the drivers and tried to reinstall them.  I had two different problems doing that

a. I didn't get the security popups that the instruction refers to

b. After uninstalling the software, I still see the driver listed in "disabled software" and there's no "allow button"

I've tried to uninstall the software a bunch of times.  Any other ideas?

Ted Wang 0 votes
Comment actions Permalink
0
Avatar

Try this:

  1. Unplug the USB from the XDJ-XZ.
  2. Go to your Applications and open the Utilities folder, launch the Terminal app
  3. Type (or copy/paste) the following command: 
    sudo kextcache --clear-staging
  4. You will need to enter your Mac user password (or just hit enter if you don't have a password); it will not show any characters onscreen as you type, press return when you are done and the process will run.
  5. Download the drivers here.
  6. Open the driver package and run the uninstaller file in the uninstall folder.
  7. Reboot your computer.
  8. Open the driver package and run the installation file.
  9. After the installation has completed, give the drivers permission. It's important that you actually open the System Preferences > Security page and allow the driver to be installed.
  10. Connect the XDJ-XZ and test it out.
Pulse 0 votes
Comment actions Permalink
0
Avatar

Thanks.  I followed all of the steps and at Step 8, the installation failed.  I got a message that said "Installation Failed".  Any other ideas?

Ted Wang 0 votes
Comment actions Permalink
0
Avatar

I should add that I now see the XDJ-XZ in my finder as a "location".

Ted Wang 0 votes
Comment actions Permalink
0
Avatar

I used the updated drivers and still not working.   I can load a song from my laptop onto the XDJ-XZ.  I cannot, however, get the output to work.  I went to audio preferences on the Rekordbox app on my laptop and did not see the XDJ-XZ as a choice.  I also don't see it as a location on my Finder on the laptop.  I do see XDJ-XZ(1) and XDJ-XZ(2) in the audio preferences menu under "Control Device Information" but that has been there for a while.  Perhaps the uninstall didn't delete it?  I am lost.

Ted Wang 0 votes
Comment actions Permalink
0
Avatar

I have experienced similar issues as above. In fact, in order to get the XDJ_XZ recognized, I need to click on the black "driver" button just below and to the right of the audio drop menu - install the driver and then it appears. This seems to be the case every time I go to connect it. Surely this is a glitch or a compatibility issue (with MACs at least)

I am running
macOS Big Sur 11.6
rekordbox 6.5.3

Michael.C 0 votes
Comment actions Permalink
0
Avatar

We are aware of an issue where some users still have troubles with the OS loading the drivers automatically when the device is connected after the computer has been restarted. You can force the drivers to load by opening Terminal and inputting this command:

sudo kmutil load -p 'XDJ-XZ USBAudio.kext'

Enter your user password when prompted, then you'll be good to go. Hopefully this is resolved in a future update.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Hi - thank you for the reply and I will give it a go. Can you confirm if this is something I would need to do each time, or is this a one-off and then everything is back to being peaches and cream?

Michael.C 0 votes
Comment actions Permalink
0
Avatar

Hi - so I tried the above advice and received an error message (see below) - any ideas?

 

Michael.C 0 votes
Comment actions Permalink
0
Avatar

Hi - just checking in on this.... I have upgraded to the latest version of RB6 and this continues to be an issue. I have tried your suggestions above, but it still does not work. The only way to get the XDJ-XZ recognized is to install the audio driver each time. Thank you.

Michael.C 0 votes
Comment actions Permalink
0
Avatar

Hi, can someone from Pioneer answer to this? I've also tried everything from above and still cannot see XDJ-XZ as an output device. I get the same message from terminal when I try to do it.

Marin Butorac 0 votes
Comment actions Permalink
0
Avatar

Hi Marin

After all was said (or not said) and done - I was able to resolve the issue by updating the RB software (6.6.1) to the latest drivers and also making sure my laptop (in my case an MBP) was running the latest update to Big Sur (11.6.1). I have not yet upgraded to Monterey as I have been reading posts from people stating things are still a bit buggy. 

Michael.C 0 votes
Comment actions Permalink
0
Avatar

I updated my RB software but it's then probably due to my mac still being on high sierra. 

Marin Butorac 0 votes
Comment actions Permalink
0
Avatar

That is would be my educated guess. For me, I was not running that latest version of Big Sur - apple had it hidden, trying to get me to upgrade to Monterey. Once I installed the latest BigSur OS (and had the latest RB install) - everything worked perfectly. I might search some forums and see if maybe running an older version of RB solves the conflict - otherwise, I would just follow the steps I outlined further up about having to manually install the driver each time I connect (annoying yes, but it did work). Good Luck!

Michael.C 0 votes
Comment actions Permalink
0
Avatar

High Sierra is not supported; macOS Mojave (10.14) or higher is required.

Pulse 0 votes
Comment actions Permalink