Have a feature request or suggestion? Post your idea here!


2 followers Follow

Moved from Windows 10 to new Mac M1 (monterey) - nightmare scenario

Hi there before importing to MAC  i backed up database on windows device -  to onedrive - and all music files are on onedrive too.

I installed RB 6 onto new mac.  Downloaded onedrive music folder to MAC , and restored library in RB from onedrive.

ALL onedrive files were downloaded to mac prior to import.

good news all tunes are in collection.  bad news part 1 is that 540 out of 2000 are not found.  ALL folders and subfolders have been added in settings - "auto relocate search folders" and relocate tried . i could add them manually and it would be ok.  but prefer not to would take a while....

Bad news part 2 (this is really not good) - EVERY single file including those clearly in the collection and not needed to be relocated are showing in the RB explorer as not imported.  So let's say i wanted to import some new tune there is no way of knowing what in the explorer is imported or not.  On previous windows collection all files in the explorer section if imported were obvious to see they had been imported.  when i like at my music folders all the files are showing as not imported.

Please help me out !

Running RB 6.6.3 and monterey version 12.2.1

Paul Demarco

Post is closed for comments.

1 comment


Yep likewise. I've just moved from Windows 10 to M1 Macbook Pro and thus far I'm absolutely appalled at Rekordbox's functionality on Mac. (Currently running RB.6.6.3 and Monterey Version 12.3.1) 

After backing up my library on Windows 10 and restoring onto my new Macbook it says over 1000 tracks are missing (they're coming from a music folder within my Dropbox so the file architecture is identical) and when I relocate a track manually Rekordbox then says it can't find any other file even if it's in the same folder (I tried it back on Windows 10 after Macbook failed and it auto-relocates everything else in the folder no probs).

Worse still Rekordbox is saying tracks are missing and, when I relocate them in the Missing File Manager window it says "this track is already in your collection" and won't re-add it. I've tried deleting the track from my library to re-import fresh but once I've deleted it from the library it simply doesn't ever appear again if I click "import"

Additionally exporting a 10gb playlist to USB on Windows 10 takes 38 minutes. I formatted the drive and exported the exact same playlist to the exact same memory stick on M1 and it took five and a half hours.

It also beachballed whilst exporting to a previous USB and my XDJ-XZ can't read it whatsoever, even after a factory reset.

It's an absolute joke. Strongly considering selling this M1 and just buying a high powered Windows laptop but really Pioneer should actually be making some effort to keep up with tech developments and making sure Rekordbox functions properly on new devices rather than customers having to decide what to buy based on whether Pioneer can be bothered to sort their software out.

From a professional perspective DJing has just become twice as difficult.

Matthew D Bayfield 0 votes
Comment actions Permalink