Have a feature request or suggestion? Post your idea here!

Post

2 followers Follow
0
Avatar

rekordbox using 1.4GB of ram for two tracks?

both tracks are no more than 320kbps mp3 files. no filters are on. rekordbox starts maxing out my ram and one of the songs starts skipping. anyone know why?

Ryan Buckley Answered

Official comment

Avatar

If 1.4GB is "maxing out," then your system is probably near the minimum requirement at only 4GB of RAM.

Even without songs loaded, you'll find that there is over 1GB in use, but that's perfectly normal.

Stuttering wouldn't be due to the RAM but more likely the CPU. Check that you've disabled any of the unnecessary rekordbox elements like DVS, Lyric, Video, and Lighting (if you don't use them).

Pulse
Comment actions Permalink

Please sign in to leave a comment.

7 comments

0
Avatar

Thanks for the quick reply. This is super helpful to know. It seems my defaults had DVS, Lyrics, and Video enabled.

My laptop ram is 16GB though, with a 2.8GHz Intel Core i7 4-core processor.

My physical disk space is getting close to full, but I don't imagine that's part of the stuttering issue is it? It occurs even when no other applications are running.

Ryan Buckley 0 votes
Comment actions Permalink
0
Avatar

I cleared off a big chunk of data from hard drive and the issue almost completely disappeared, but still persists. I'm planning to upgrade my computer when the new models become available, but surprised I need as much juice as I do for rekordbox without any of the extras enabled.

Ryan Buckley 0 votes
Comment actions Permalink
0
Avatar

If you had less than 10% disk space available, that would certainly be a big compromise to your system performance due to caching and memory swapping.

Other things to try are:

- increase the audio buffer size
- ensure other background tasks and applications are closed
- disable the Intel Turbo Boost using this tool
- lower the waveform drawing rate to MEDIUM in the preferences

Pulse 0 votes
Comment actions Permalink
0
Avatar

It happened again yesterday, so I rebooted my computer and opened Activity Monitor to close off any and all unnecessary apps. Then, I ran a few more tracks and suddenly it started occuring again. What's surprising is that when I loaded a second track and played it, the second track played fine, but the first one was still glitching. After switching through some other tracks and coming back to that original one, it played fine again.

Increasing the buffer makes it much worse. I'll try the turbo boost and other suggestion you made next time I get to test again.

 

*Also curious is when I play through my laptop speakers and try to turn down the volume all the way to 0 when a track it glitching, there's still sound of the glitch coming through.

Here are my specs:
2.8GHz quad‑core 8th‑generation Intel Core i7 processor, Turbo Boost up to 4.7GHz
Intel Iris Plus Graphics 655
16GB 2133MHz LPDDR3 memory
512GB SSD storage

Ryan Buckley 0 votes
Comment actions Permalink
0
Avatar

It's happening again, and so I took a screenshot of my activity monitor to give an idea of resources being used. (This is after making the waveform adjustments and turning off TurboBoost as suggested, along with the previous suggestions as well)

Ryan Buckley 0 votes
Comment actions Permalink
0
Avatar

I should also add, this happens when when the controller isn't connected too. I tried without, to see if it might be an issue with my DDJ-400, but even just playing songs on Rekordbox will reproduce the error. These files also play fine in other media players.

Ryan Buckley 0 votes
Comment actions Permalink