Have a feature request or suggestion? Post your idea here!

Publicación

4 seguidores Seguir
0
Avatar

migrating database - not working AGAIN

so again i tried to migrate my database, and again no luck.

has ANYONE out there successfully migrated to a new machine?

I'm following the directions EXACTLY.

I have bought a new laptop running windows 7 64-bit

I'm attempting to migrate from old laptop running windows 7 32-bit.

I moved all the files EXACTLY as described in the tutorial post.

My tracks and playlists all show (just as they did last time when i tried to

migrate back when i switched from vista to 7)

but no artwork, no wave form, no beatgrid, and all the tracks read

a bpm rounded up to the nearest whole number ( ie:  125.00 or 126.00)

can anyone enlighten me?

DubLN

Iniciar sesión para dejar un comentario.

20 comentarios

0
Avatar

@DubLN > The waveforms etc aren't appearing in Rekordbox or after you have exported the tracks?

Gavin 0 votos
Acciones de comentarios Permalink
0
Avatar

waveforms etc aren't showing uip in RB. i haven't exported anything yet.

i copied everything the tutorial said to:

crashes folder

PIONEER folder

datafilebackup.edb

datafile.edb

dummy.edb

rekordboxsettings

upmgr rekordboxsettings

DubLN 0 votos
Acciones de comentarios Permalink
0
Avatar

UPDATE.

I re-analyzed a few of my tracks and now the beatgrid is showing. but now I have to

go back and fix all the beatgrids that are off again. A lot of work to go though if you consider that

rekordbox gets about 1 in 5 tracks wrong. re adjusting hundreds of beatgrids again will

take weeks of spare time - LOL, like i have spare time.

(side note: PIO should really consider working on their analyzation formula )

in order to get the artwork back i selected the tracks and did a tag reload.

soooo, the database migration doesn't seem to be as easy as Pio would leave you to

believe. just a FYI for anyone needing to do it. beware, it'll take some time to get back to

normal.

DubLN 0 votos
Acciones de comentarios Permalink
0
Avatar

@DubLN > Thanks for letting us know your update.

Gavin 0 votos
Acciones de comentarios Permalink
0
Avatar

I read months ago the (closed topic) "Migrating Your Rekordbox Database" and al worked fine as I use the same external HD with the home PC and on the laptop (that i use when I travel)

Maybe the question is stupid, but what is the difference between this system (moving files and folder manually) and the function in rekordbox called "Library" backup (and restore)

If i save the file of the backup "rekordbox_2011y12m06d_datafile.edb" on a usb stick and then import that with the function File -> Library _>restore in my laptop (of course using the same external  HD with the same letter) in my laptop haveI   the same result ?

Ty Orio

ORIO DJ 0 votos
Acciones de comentarios Permalink
0
Avatar

@Orio > Unfortunately it will not have the same result because all of your analyzed data files will be missing in Rekordbox. It will import your collection properly, but you also need the hidden "PIONEER" folder which contains all the analyzed data and extra information Rekordbox has stored about your collection.

Foster 0 votos
Acciones de comentarios Permalink
0
Avatar

Im having the exact same issue, I use windows 7 on both laptops and the same letter drive.

After i transfered the database and opened rekordbox, all the tracks were there but when i drag a track to the cdj 2000 icon the track loads into the deck without the waveform

I have hidden files visable and heres the list i copied

Crashes (folder)

PIONEER (folder)

datafile.backup.edb

datafile.edb

dummy.edb

license

rekordbox.settings

Upmgr rekordbox.settings 

 

Can anyone help please ?

Novation 0 votos
Acciones de comentarios Permalink
0
Avatar

@Novation > You can attempt what DubLN did and try to re-analyze a few of the tracks and see if it shows up for the rest of them maybe after you quit and restart Rekordbox. However, if this doesn't work, you could remove the file "datafile.edb" then change the name of the file "datafile.backup.edb" to say "datafile.edb" and then open Rekordbox and see if it corrected replaced them.

Foster 0 votos
Acciones de comentarios Permalink
0
Avatar

Hi Foster,

Nope that didn't work, I just dont understand whats wrong... if i place back the original "datafile.edb" and then anaylize a new track then drop it into the deck it loads fine. it won't work with the backed up version

Novation 0 votos
Acciones de comentarios Permalink
0
Avatar

btw white the backed up 'datafile.edb' is in place i cant even transfer a newly anaylized track to the deck, i get the same problem, as i said above, if i place back the original file everything works.

Novation 0 votos
Acciones de comentarios Permalink
0
Avatar

@Novation > Hmm, migrating has a higher probability of issues. Have you right clicked on a track where there is no waveform, and selected "Reload Tag". Make sure the CDJ's aren't connected in the first place, try the "Reload Tag" and turn them on and see if it updates the waveform.

Does the waveform display itself within Rekordbox when you play it?

Foster 0 votos
Acciones de comentarios Permalink
0
Avatar

I Just tried the reload tag and it hasn't made a difference, all i see on my deck when i load the track is my markers... also if i click on 'Adjust BPM/BeatGrid in rekordbox and then click it again to close the beatgrid the BPM of the track going to ZERO

Novation 0 votos
Acciones de comentarios Permalink
0
Avatar

I know for a fact i have everything exactly the same of both systems except the system name, Ones named Novation and the other one is named John. Could display be the problem ? must both systems have the same name ?

Novation 0 votos
Acciones de comentarios Permalink
0
Avatar

Problem Solved!!!!

I had to change my laptops username to match the other laptops name... or you can simply create a new account with the same username of the other machine. 

Novation 0 votos
Acciones de comentarios Permalink
0
Avatar

@Novation > Awesome you got it working! :D Thanks for posting you findings too!

Foster 0 votos
Acciones de comentarios Permalink
0
Avatar

Either that or you do a mass search/replace on the path in the database, but I don't recall it as being human-readable.

The instructions for migration don't explicitly state it, but your source and destination paths must be the same; this means the user name must be identical.

Pulse 0 votos
Acciones de comentarios Permalink
0
Avatar

How i figure out the problem was by first opening the datafile.edb with a text editor, most of it was a mess because of the file format but i was able to see the track paths, Thats when i knew what needed to be done.

 

@ Foster, No worries, I hope this comes in helpful to others... Also have a great christmas folks.

Novation 0 votos
Acciones de comentarios Permalink
0
Avatar

@ Pulse, The first thing i tried was changing the paths inside datafile.edb but rekordbox wouldn't load it afterwards, Must be because of its format.

Novation 0 votos
Acciones de comentarios Permalink