Have a feature request or suggestion? Post your idea here!


1 seguidor Seguir

New laptop but no Link...

I just bought a new laptop for use with CDJ-2000 and DJM-900, but I cant get Link to work...

The new laptop has the same OS, same version of RB, same settings etc, but it just wont work :-(

0) Have you read the "READ ME FIRST" thread in its entirety before posting: Yes, I swear it!

1) Operating System: Windows 7

2) OS Type: 64bit

3) Rekordbox version: 1.5.3 

4) Using LINK: No, but I would like to

4a) LINK Connection method: D-Link DES-105 

4b) Using with CDJs: Yes, 2 x CDJ-2000

5) Hard drive / Flash drive / SD card file system: Not using external drives 

5a) Does the device have multiple partitions: N/A

5b) If it's a flash drive, is it a U3 device: N/A

5c) With what utility did you format the device: N/A

6) Have you scanned your files for errors: Yes

7) Have you scanned your drive for errors: Yes

8) Is Rekordbox crashing at all: No

8a) If crashing, is it resulting in: N/A

8b) If not crashing, are there any error messages: No

9) Are you able to repeat / reproduce the problem: No/yes

9a) If yes, can you do it consistently: Yes

10) Any other notes regarding your setup only:

Provide as much detail of the issue here:

I see the the Link icon flashing very briefly in RB, but no Link...


Iniciar sesión para dejar un comentario.

5 comentarios


Disable wireless on your laptop.

Disable the Windows Firewall or allow the RekordBox Link service when prompted.

Apps like Norton are known to really mess up the ability to Link.

Mark90 0 votos
Acciones de comentarios Permalink

I have tried everything, the installation is identical to the one on my old laptop (which links fine)...

The Link icon in RB flashes on and off very briefly, but i never stays...

Fixed link:  http://www.youtube.com/watch?v=aZrpZBJCUes&feature=g-upl

I think I finally fixed the issue by deactivating my WWAN/3G card in Windows device manager...

Tracebuzta 0 votos
Acciones de comentarios Permalink

Ah, I should've been more specific and said "make sure you only have one (eg. ethernet) connection active."  If there's more than one active, RekordBox will refuse to offer Pro Link.


Another post which drives home my suggestion to allow users to select their desired network connection from within RekordBox properties.  Or fix it's rather bizarre (and undocumented) behaviour towards networks.

Glad you sorted your problem.

Mark90 0 votos
Acciones de comentarios Permalink

@Mark90: I know, but it worked just fine with 3G running on my old laptop, so I didnt think I would need to uninstall my 3G card....


@Gavin: Yes, I think so, I will test some more though.



Tracebuzta 0 votos
Acciones de comentarios Permalink