Have a feature request or suggestion? Post your idea here!


4 seguidores Seguir

LINK not working after Rekordbox update: Players not visible in Rekordbox.

Have you read the "READ ME FIRST" thread in its entirety before posting: Yes

Operating System: Windows 7

OS Type: 64bit

Rekordbox version: 2.01

Using LINK: Yes

LINK Connection method:  Ethernet: PC > Netgear switch > CDJs.

Using with CDJs: 2*CDJ900

Is Rekordbox crashing at all: No

If not crashing, are there any error messages: No

Are you able to repeat / reproduce the problem: Yes

If yes, can you do it consistently: Yes

Any other notes regarding your setup only: My PC has two network interfaces. One PCI card that is used to connect to my ISPs Router for Internet access (wired) and the onboard network interface is used for Rekordbox.

Provide as much detail of the issue here:

Since the update to Rekordbox 2.01 I am having problems with LINK:  The CDJs are communicating properly via LINK if I use a USB stick in one of the players, but the Link between Rekordbox and the CDJs does not work.

When I connect the Ethernet cable, the Link button in the bottom of Rekorbox is visible and clickable and turns blue after clicking. Also, in the configuration menu on the players, the link status is displayed as ‘connected.’ However the player icons in the bottom of the Rekordbox window do not appear. I also waited for 10 minutes but the players still did not appear, also after restarting Rekordbox and clicking on the Link button a couple of times.


The Rekordbox network is a ‘public network’ , my Windows firewall is configured to give the four Rekordbox applications access (edb_streamd.exe, Pro DJ Link NFS Server, etc) and I have updated the firmware of the CDJs to 4.20. There is no wireless connection on my PC.

I also tested to completely disable the Firewall, connect a player directly to the PC, set the CDJ player numbers manually and auto, but the problem persists: Link button appears and is clickable, but the player icons are missing in Rekordbox.

Yesterday I got it to work once after I had disabled the firewall, removed Rekordbox, cleaned the registry, restarted the PC and re-installed Rekordbox. However after turning the PC off and on again, the player icons were again no longer visible in Rekordbox.

Before the Rekordbox update I had no problems at all and was also able to use both networks at the same time, ie browse the internet and use Rekordbox/link.

Any thoughts?

Thank you.


Iniciar sesión para dejar un comentario.

6 comentarios


I'm having this same issue.  I see your post was in November so I guess you must have found a solution?  Can you share your solution?

Jo 0 votos
Acciones de comentarios Permalink

Hi Jo,


Unfortunately my problem has not been solved. Really dissapointed by Pioneers support. We pay a fortune for their equipment and I did not even get a  response..


Canadadada 0 votos
Acciones de comentarios Permalink

I have the same problem for a while now, but if I turn off my firewall it works. It doesn't work when firewall is on. And yes rekordbox is in the permission list of my fire wall so it should work, but it doesn't.

Anny ideas ? 

DJ Meks 0 votos
Acciones de comentarios Permalink

If you turn the firewalls off and it works then that is your problem for sure and you need to configure them properly.

Here's what you need to allow through the firewall (Windows or otherwise):

C:\program files_yourusername_\rekordbox version-number\edb_streamd.exe - TCP

C:\program files_yourusername_\rekordbox version-number\psvnfsd.exe - UDP

C:\program files_yourusername_\rekordbox version-number\psvlinksysmgr.exe - TCP

C:\program files_yourusername_\rekordbox version-number\rekordbox.exe - TCP

You need to configure this each and every time you install a new version of rekordbox* if* your firewall is not set to alert you to new connections, otherwise you'll see a pop-up alerting you to the connection and you simply allow it through (and set it to remember / always allow it).

  • Try disabling your firewall
    If you still have problems trying to configure the firewall, try disabling it to see if perhaps it's a setting or permission within that's blocking it.  An important note if you're disabling the firewall in Windows Vista or Windows 7 - there are two separate configurations for each of the Private / Home networks and the Public networks.  If you are using the CDJs / DJM connected without a router, you will likely find the IP addresses are self-assigned in the 169.254.x.x range and the network type will default to Public - Unidentified.  Because public networks are more likely to have outside problems, they are subject to more stringent security and limited connections.  Be sure to test by disabling the Public firewall as well!
Nick Hilton 0 votos
Acciones de comentarios Permalink

Ok I'm on a macbook and I got rekordbox and edb_streamd allowed. So how to I allow psvnfsd and psvlinksysmgr? 

I don't find it if I search for it.


DJ Meks 0 votos
Acciones de comentarios Permalink