Have a feature request or suggestion? Post your idea here!


3 seguidores Seguir

Non-functioning ProDJ Link on XDJ-Aero, after upgrading to fw > 1.02 - [Solved] (maybe...)


The problem is that you start RB and se the active link, but if you try to choose a song with the rotary nothing happends, and if you drag a song to the icon, it disappears.

(and the Aero drops the connection)

I have tested every combo of channels and channel-width and I have tested it on Win7 (x86 & x64), so I don't know if the issue exists on Win XP.

I have tried using the Aero as an AP, and as a client to my home network to no avail.

The solution... (for me at least)

Change the encryption-method to WPA or Open

When I set the Aero to WPA2 the problem comes back.

My guess is that when they fixed the network issue that existed with multiple devices (1.02 -> 1.06), something went wrong with the encryption handling, because i had no issues before the upgrade.

If you have this issue on Win7 please test this and see if it works for you.

If you do or don't have this issue with Win XP, please reply to this tread, so the engineers get as much info as possible to work with.



Iniciar sesión para dejar un comentario.

2 comentarios


I have the same problem.  Using Windows 7.  I have tried all 3 different Security settings and turned off Windows Firewall.  The DJ icons disappear when I drag a track to them.  The connection with the Aero drops out..  I have not been able to correct this issue.  Rekordbox 2.03

Steve Dixon 0 votos
Acciones de comentarios Permalink

Have the sake problem heren. Turned of my firewall and than started recordbox again. It worked.

Mark Touw 0 votos
Acciones de comentarios Permalink