Have a feature request or suggestion? Post your idea here!


3 seguidores Seguir

New CDJ-2000NEXUS USB Stick in Player 1 'Now Loading' Screen freeze. Player 2 no problem at all.

Pioneer CDJ 2000 Nexus Problems reading files from USB
Hi, hope you are well.
Below are the Specs of all my connected gear and then the problems I have been encountering in the past month of setting it all up.
Computer Manufacturer: Falcon (From http://www.music-pc.com)
Computer Model Name: Falcon Ace 15 Laptop
Processor: Intel Core i5 4310M 2.70 GHz Dual Core
Main Drive: Crucial M550 128GB Solid State Drive
Secondary Drive: 750 GB Laptop SAT 7200RPM 16MB Cache (Where all my Music Files are stored for recordbox)
OS: Windows
Version Used: Windows 7 Home Premium 64bit
RAM: 4 x 2GB 1600MHz SODIMM DDR3 Laptop RAM

USB Stick Details
Manufacturer: SanDisk
Model: SanDisk Extreme 3.0
Size: 64GB
Format: FAT32

110 Music files on both the USB’s which have been Analysed and synced to them using recordbox.

Manufacturer: hama
Spec.: USB 2.0
Size: 32GB
Format: FAT32

Decks (x 2)
Manufacturer: Pioneer
Model: CDJ2000NEXUS
Firmware: Version 1.23 (Updated both decks)

Switching Hub Information
Manufacturer: TP-Link
Model: TL-SG105 (5-Port Gigabit Desktop Switch)
LAN Cable
Type: CAT5e (2 x Pioneer Supplied cables and 1 x from ebay)

Recordbox Details
Version: 3.2.2

Manufacturer: Rane
Model: MP 2016 Rotary Mixer and XP 2016 External Processor
Connections: CDJ’s are connected via analogue rca connectors only.

The following details are of what I have been experiencing.
20 June 2015
I bought all of this equipment about a month ago to try and streamline a radio show I am producing. It took me two weeks to go through all the manuals first.
Updated the Firmware on the CDJ’s. 1.22 and as of 27 July 2015 1.23
I then connected everything.
I had recorded some tracks from my vinyl collection using Digital Performer on an old mac I had before all this gear arrived and saved them to AIFF at 2304kbps (24bit) at 48000 Hz.
I moved these over to my new Falcon Ace 15 Laptop from http://www.music-pc.com
First of all I imported around 20 tracks [AIFF 2304kbps (24bit) 48000Hz] into recordbox and figured out how to analyse them, set cue points and beat grids.
I then synced them to my USB.
I set up my Players as Player 1 and Player 2 on the CDJ’s, set my preferences (Jog Brightness, 24 Bit, etc.), set them to Jog Mode: Vinyl.
(I also tried the setting as AUTO on both Player 1 & 2 and the same thing happens, explained later.)
I inserted the USB stick, pressed USB on Player 1 and pressed Link on Player 2.
I then set about figuring out how all the buttons worked on the CDJ’s.
While I was doing this Player 1 froze. I pressed the USB Stop Button to eject the USB, turned both decks off and disconnected the main plug for the system I am running from the wall.
After a few minutes I turned everything back on, inserted the USB and started playing again.
I noticed that every time I used the needle search function on Player 1 everything was fine for a few tracks, but after that, player one froze again and I got info come up on the player saying ‘E-8302: Cannot Play Track (3658)’ then said ‘Media. Or File is Collapsed or Unavailable’
The player just said ‘Now Loading’.
So I waited, and waited…and waited for around 5 minutes but nothing happened.
I then pressed the USB Stop button to eject it but the light never stopped flashing. I waited and waited again and tried the USB Stop button again and the red light kept on flashing.
In the manual it states that if this happens and you turn the CDJ off the files may be corrupted.
I turned the CDJ off because I couldn’t leave it on all night. My files were fine when I tried it all again.
I left the system for around two weeks and read up a little more but couldn’t find any info on the problems I was experiencing. I also had to dedicate most of my time to the Radio Show which I am still running using vinyl
I then tried a few things once I had eventually narrowed the issue down to the Needle Search Function on Player 1.
The same file that was having the problems on Player 1 had no problems on Player 2 while using the Needle Search Function in Vinyl Jog Mode with my finger on the Top of the Jog Dial.
There were two different files playing on each deck. I wasn’t trying to play the same two files at the same time on each deck. I only tried this to test if it was a fault on the deck.
I then pressed the USB Stop button and the light wouldn’t stop flashing again. I turned the whole lot off again and switched it all on again.
I then swapped the Player 1 to 2 and Player 2 to 1 and plugged the USB Stick into the new Player 1, pressed USB and then Pressed Link on Player 2. Effectively swapping the whole thing round to see if it was the Deck that was causing the problem.
No, the same thing happened when using the Needle Search Function. Player one sent the ‘E-8302: Cannot Play Track’ message again and ‘Media. Or File is Collapsed or Unavailable.’ message again and said ‘Now Loading…’ but never loaded the track. I tried the same track on Player 2 and it was perfect. Everything worked as normal.
I pressed USB Stop again and the same thing happened again. Switched it all off and swapped player numbers back to the way it was originally after turning it all on again.

I am stumped as to where the problem lies. Is it the USB? Is it the player? (From my test, I don’t think so), is it the TP-Link? Is it recordbox? (I don’t think so because I am not running the files from recordbox) Is it the file type? (AIFF 24bit 48000 KHz)
I tried every file type I had, and the same thing happens with each on Player 1.
My own vinyl Recordings to AIFF and WAV 24bit 48KHz.
Traxsource WAV files 16bit 44.1 KHz
Juno Download WAV files 16bit 44.1 KHZ
Beat Port WAV files 16bit 44.1 KHz
They all do exactly the same thing.
I just can’t figure it out. I have exhausted every possible avenue I can possibly think of and have to try get on with the show now. I have spent hours trying my best to get this sorted, I hope I have helped narrow things down for you to get to this point.
Please help me.
I look forward to hearing from you.
Kind regards,
P.S. I have contacted DV247 who sold me the decks to try and resolve any issues with the ‘details on the Communications Devices, Security Software and Operating System’ I am using. (Extract from the CDJ-2000NXS software manual ENpdf which is right at the end of the document.) I am also talking to Rick at www.music-pc.com to try help me resolve the connection issues.
I kept going round in circles on the various support pages and couldn’t get in touch with anyone. This is why I have written to you.
Please help. I don’t want my show to fall apart. I need to start playing digital files soon.

Part 2.
26 July 2015
After writing this, I went back and managed to connect the laptop to the CDJ’s and get that side of it working fine. This proves that the USB stick I was using could possibly be at fault.
The problem I have is that if I use the laptop to run recordbox, I cannot stream my show live to the World Dance Radio servers and record the show all at the same time from the same laptop because using the RJ45 port for the CAT5e cable to the switcher and then decks the wireless internet reverts to the RJ45 Port.
I need a reliable USB device or separate SSD-USB drive to stream my 24bit 48 KHz WAV, AIFF files via the Sync Manager function in recordbox to the device and connect that up to the CDJ’s so that I then have the laptop free to record my set and stream (upload to the world dance radio servers) at the same time separately.
Can you suggest/recommend a reliable USB memory stick, SD or SDHC card, USB to Solid State Drive that I can use to do this without having to connect my laptop up to the CDJ’s?
I look forward to hearing from you.
Kind regards,

Part 3
27 July 2015
I spoke with Raamiz at DV247 who sold me the gear and he said he has never encountered any problems like this. He suggested using another USB stick.
I tried the hama 32GB USB 2.0 FAT32 formatted stick. Synced it via Recordbox and then connected it up to the CDJ’s selected a track.
Played it for a bit and then tapped around on the needle search strip and the same thing happened. Player two works fine again. It is as quick as it should be.
I spoke to a dj friend of mine who plays around the world on these things and says he uses SanDisk 32GB SD cards with MP3 320 files on them. He has two with exactly the same Sync on them just in case he gets to a place where there is no link cable. He also suggested not using the Switching hub. Just take the CAT5e cable supplied by Pioneer and plug one side into Player 1 and the other into Player 2.
Tried this and there has been no difference in the problem. Screen Freeze on Player 1. Hard Reset by turning all of and on again.
I will be buying an SD card now and testing it when it arrives.

I can’t understand why this is only happening on whichever player the USB stick is plugged into.

I have found a workaround though. Not ideal and haven’t tested it extensively yet…just don’t use the Needle Search function. Use the FF and REW buttons to scroll through the track. I am sure there is something in the CDJ firmware that is corrupting the Needle Search strip in the player where the USB stick is plugged into.
Will record a video of this and post it too this thread as proof of what is happening.
Bearing in mind these are a pair of brand new Pioneer CDJ-2000NEXUS players from a reputable dealer. I don’t think paying over £2500 for this gear and experiencing this kind of hassle is fair at all…shouldn’t this kind of thing have been sorted before these were released? I mean really…over two and a half grand and I am now testing this gear for free every night till around 1am and then to bed, up for work at 6:30 am back at 5:30 pm and straight onto trying to get all this sorted in amongst family life and the radio show.
I am not sure how much more of this I can take before I send them back for a refund to buy something that is a little more stable…like a record player and some more records. LOL. You just got to laugh haven’t you. I mean really…can’t Pioneer be held accountable for this kind of false advertisement…’’leave your computer at home’’...should read...''Don't forget your Vinyl at Home''

Please help me. I am that tired of this that I am now laughing at my own jokes...it has to be bad, c'mon now. Please, let’s get this sorted so we can all get along. Isn't that what music is about?

Gareth Millers Respondida

Comentario oficial


Hello Gareth,

We will finally update the firmware of CDJ-2000Nexus to support the file type of AIFF (24bit/48kHz) soon in the next release.


  • Playback of an AIFF music file (24bit/48kHz) stopped and tracks could not be loaded to a deck.

Thank you very much for reporting this issue.

Best regards,

CRM, Pioneer DJ

Acciones de comentarios Permalink

La publicación no admite más comentarios.

17 comentarios


OK. So after all that.
I received an email from SanDisk, which I though was very efficient...sent on Sunday...replied by Monday and they suggested I reformat the USB Stick to FAT32 using this link

I then downloaded

and reformatted my SanDisk Extreme USB 3.0 64GB twice using this tool. I reformatted it three times to be sure.
The settings I used were Partition Drive:...My Drive
Allocation Unit Size: I randomly chose 1024
Volume Label: I called it RECORDBOX64

Once that was done I disconnected it then lugged it back in, opened recordbox and used Sync Manager to sync the files.

Disconnected it from the laptop and then inserted it into the CDJ's

And what do you know...it all seems to work fine now. Although Player 1 still seems a little slow.

I will email them now to find out what the correct settings should be when reformatting it to get the best performance for m file sizes, between 50 and 70 MB's and will post their suggestions on here later today... got to get to bed now because it is nearly 1am again...well...what do you know...the early bird catches the worm...

Gareth Millers 0 votos
Acciones de comentarios Permalink

Sent this to SanDisk now and will hopefully get an answer back by this evening.
I will still have to run some more tests with the needle search function but have been trying to get it to do the same as before but nothing has happened yet. Fingers crossed. The only thing is that Player 1, where the USB is plugged into has a little lag and player two loads a little slower than before. The needle search doesn't seem to be as precise though, that's what the FF and REW buttons are for... get it close with your finger and then forward or rewind it with the FF and REW buttons like you were putting the needle on the record and then spinning it forwards or backwards to get the point in the track you wanted...just a new way of doing things jumping straight from vinyl in 2015 into the digital age...I know...I have always been a little slow to catch on...tapes and vinyl...cant beat them for that feel and sound but digital...it is so much more convenient...especially for emerging artists and producers...we are all working together on this...lets get it sorted.

Hi Gianna
I have reformatted my USB stick using 2Tware FAT32 Format 1.13 and it seems to be working fine now.
I would like to know what the Optimum settings would be for my specific drive using their software.

What should I choose as the ‘’Alloction unit size’’
Bearing in mind I am using WAV and AIFF music files between 30 MB and 70MB streaming two files at the same time to two decks only.

It Has the following to choose from before formatting:
Allocation unit size: Default, 512, 1024, 2048, 4096, 8192, 16K, 32K.

For the’ Volume Label:’ I named it’ RECORDBOX64’

I chose 1024. Not sure if that is entirely correct. There does seem to be a little lag on the player that the USB is plugged into but nothing near what was happening before. I just want to format the USB to the optimal settings and would like a suggestion as to what this will be.

• Capacity of your USB – 64GB
• All product codes / serial numbers on the product – BN150324687B – SDCZ80-046G – SanDisk Extreme USB 3.0
• Date and place of purchase – 13 June 2015 from Amazon EU S.a.r.l
I hope this helps.

I have an inkling that the Allocation unit size should be bigger, maybe, to help speed things up?

I thank you for your help so far and the speedy reply.
I am truly grateful.
I look forward to hearing from you.

Kind regards,

Gareth Millers 0 votos
Acciones de comentarios Permalink

Seems like recordbox doesn't like 24 48 file size in AIFF, neither does the FW in the CDJ's.
Formatted the USB stick to Sandisk recommendations and seems a little better but the bigger file size is not as responsive as the 16 44.1 file sizes.
Changed the AIFF 24 48 files to WAV 24 48.
Deleted my playlist with the AIFF 24 48's and nameda new one and added the WAV 24 48's and never messed with the grid markers, only set the first cue points as memory points.
The Firm Ware on the CDJ's just seems to slow down a lot with the 24 48 files.
The USB seems fine. I now think it is the files.
Does anyone have any suggestions?

Gareth Millers 0 votos
Acciones de comentarios Permalink

Just at a gig, but responding to this as you mentioned a "5 page rant with no answer" and I went looking...

1) Some Sandisk units are known to have problems, it's not something Pioneer can change with firmware.

2) Try using the HP Formatting Tool; run it twice, give your drive a new, unique, name.

3) There are no problems using AIFF in 24bit/48k.

Pulse 0 votos
Acciones de comentarios Permalink

1) Got that. Thank you. You said before.
2) Have done all that you have said above and the problem persists. The HP Formatting tool included, ran that three times.
3) Ok. I will re-record them and see how that goes. I will get back to you.
Everything works fine with my 32GB SanDisk SDHC cards, those files included.

I will wait and see if anyone else suggests any other usb sticks.
Fabio has said he has used the Verbatim 128GB SSD with great effect. He had a problem formatting it. Verbatim actually supply their own formatting tool/software.
Wasn't having a go at you guys. I was talking about the Barry at Pioneer Customer Technical in the UK. I called the week before last and still nothing.
It wasn't a '5 page rant', it was a fact finding mission on my part so I could get as much info together to present to you all so that you could help by reading what I had done and in turn eliminate any further things I had not tested.

Gareth Millers 0 votos
Acciones de comentarios Permalink

@Gareth > I know, and I appreciate that you're frustrated and just looking for answers, so no worries. I just want to make sure that users get all the information that we have available and sometimes it gets repeated or spread across places.

Sorry to hear the HP tool didn't help, that leads me to believe with more certainty that it is an issue with the drives themselves and not the data therein.

Pulse 0 votos
Acciones de comentarios Permalink

Thank you. I have purchased a Verbatim 128GB USB SSD Drive on the recommendation of one of the guys on another thread I posted about Which USB sticks is everyone using. Will let you know how I get on when it arrives.
Kind regards,

Gareth Millers 0 votos
Acciones de comentarios Permalink

Please answer these questions for me.
1. I have now spent over £200 on different USB sticks and SSD drives and every single one of them doesn't like 24Bit 48KHz file sizes. How much more money do I have to spend to get players that work with the USB Sticks?
2. If you have read the above section where I have spent hours trying to iron out the problem before posting this you will see that this is only happening with the USB devices. I use a SDHC card and nothing like this happens using those.
How long is it going to take before anyone takes me seriously?
3. If it says it will play from USB then why doesn't this product do as it states on the tin and why is no one from Pioneer getting back to me? I called the guys three weeks ago, Barry in Technical, and I still haven't heard a stitch from anyone yet.
4.The screen freezes in the player that has the USB plugged into no matter which one I plug it into. The other player plays the file with no problem at all and I can operate the needle search function with no problem on the player without the USB plugged into too.
The problem persists and if anyone thinks I am going away, they are wrong. I have spent hours trying my best to get this sorted and I have rights too. Consumer rights. Somebody has to tell me what the heck is going on and run the tests I have run with the files I gave them and using the videos I gave them.
I would love some valid answers please because I am tired of being brushed off with. How can this lead anyone to beleive that the drives are the problem when the same file that has frozen the screen in the player with the USB in, will play fine in the other player connected via LAN. To me, that sounds like the player that has the USB stick inserted has a problem with the USB Stick being inserted and has a problem reading the USB stick...not the USB stick has a problem with the player! If there is a problem with the USB stick, how come the same file plays in the other player connected to the LAN with no problem at all?
Surely if the USB stick is faulty then the problem should exist in both players?
It doesn't.
It only exists in the player with the USB inserted.
The other player plays fine.
Why doesn't anyone believe what I am saying?
It's not like I am being paid to pester anyone. I have spent a lot of money and I want my purchases to work as it says on the tin. Is that too much to ask?

When I scroll through the file with the 'Search' forward and backward buttons everything works fine, nothing freezes. If it was a problem with the USB stick and how it distributes the data then this process would surely take up more effort to carry out than using the Needle Search function by pressing the top of the Jog Dial down and then selecting a place in the file with a finger depressed on the Needle Search strip.

This problem does not exist with MP3 files at all.
Why do I have to convert everything to MP3?
I like my sound quality and don't appreciate why I have to now go and convert all my files to MP3 for the machine to work.
I am not being snobby, I want to play better quality files. MP3 is convenient not quality.
I was led to believe that these players could meet that quality standard but this experience has left me quite unsure of what to do next.
Please, do your best at looking into this for me as I am not sure how much more I can do to help. I can't carry on spending money like it grows on trees.
I just want someone to look into this seriously for me please.
I look forward to hearing from anyone.
Kind regards,
Why isn't anyone taking this serious enough?

Gareth Millers 0 votos
Acciones de comentarios Permalink

@Gareth > No, I hadn't read the entire thread -- as I noted, I was at a gig when one of your other posts caught my attention and I wanted to ensure that you knew your post(s) were being read, and yes, taken seriously.

I've asked our engineers to take a look and if they need any specific files for testing, I'll pass that information along.

Your patience is appreciated in the meantime.

Pulse 0 votos
Acciones de comentarios Permalink

The engineers are aware of the issue and are now investigating the root cause and a solution.

Thanks for your continued patience!

Pulse 0 votos
Acciones de comentarios Permalink

That is fantastic news. Thank you.

Gareth Millers 0 votos
Acciones de comentarios Permalink

FYI: We haven't forgotten about this issue and should have the fix available in an upcoming update.

Pulse 0 votos
Acciones de comentarios Permalink

I look forward to getting a fix for this issue. It has been a long time coming. I have heard Grant Nelson also has the same type of problem. Like me, these guys don't want to play MP3's because most of their music consists of awesome bass and the MP3's take away from this. It would be great not having to sync a few WAV file folders to a 32 GB from Recordbox. I'd rather have my whole collection of WAV files on USB. For some reason I can't Format a high capacity SD Card to FAT32 using the Hewlett Packard formatting tool suggested in a previous article, nor any of the others in fact. Anyway, I am looking forward to this fix. Thank you for getting back to me and letting me know you haven't forgotten about the issue. Kind regards, Gareth.

Gareth Millers 0 votos
Acciones de comentarios Permalink

Hi Keiko. Thank you for your message. i look forward to the fix in the next update. Will this fix also sort out problems with WAV and AIFF 16Bit 44.1kHz files too? I look forward to hearing from you. Kind regards, Gareth

Gareth Millers 0 votos
Acciones de comentarios Permalink

Oi, Oi you beauties. Thank you, thank you, thank you! I managed to do a whole show using AIFF 16 44.1 files and I tested the 24 48 files too and they all work fine. They were all on my Verbatim 128 GB SSD USB Drive and although they load slowly, once they are loaded they stay loaded with no warnings. Thank you for working so hard on this. I really appreciate all your hard work and effort. Thank you for listening to me. Kind regards, Gareth

Gareth Millers 0 votos
Acciones de comentarios Permalink