Have a feature request or suggestion? Post your idea here!

Publicación

5 seguidores Seguir
0
Avatar

DJM 900nxs2 midi issues

Hi guys,

Just bought the djm900nxs2 and having some trouble setting it up with traktor (latest version) on my macbook pro running os sierra.  All firmware and drivers are up to date.

1.  I can't get the mixer nor the traktor software to receive midi clock signals.  One of the two options would be fine, as long as i can get the djm's fx to sync with traktor or vice versa.  I did all the necessary settings in traktor.  I can see in the software that it's receiving midi messages as i touch the controls on the mixer, but it's not getting any midi clock data in.  As i can't find any reference of the nxs2 being midi clock slave to external gear/software I presume that's not even possible?  Or is it?

2. My second issue is: when the usb cable connecting my computer with the mixer is plugged in I can't turn of the midi send on the mixer.  The buttons stays lit and traktor keeps on receiving midi messages when I use a control on the mixer.  I've tried resetting it to factory settings, but that didn't work.

I really hope someone can help me out with these issues!?

Karsten Van Campenhout Respondida

Comentario oficial

Avatar

The DJM doesn't send MIDI clock, only BPM data. It also doesn't receive data, it's send-only. There will not be a firmware update to include receive functionality as the hardware was not designed for it.

Pulse
Acciones de comentarios Permalink

Iniciar sesión para dejar un comentario.

21 comentarios

0
Avatar

Sorry for the delayed response.  Have you got this sorted yet or do you still need some help?  

Mark Gallo 0 votos
Acciones de comentarios Permalink
0
Avatar

No, I haven't found a solution yet.  I mailed Pioneer about it too but didn't get any reply for now.   A side from the fact that i need midi clock send or receive to use traktor, I'm thinking of adding an external drum computer to my set up so i really hope this can be resolved.  Some help would be greatly appreciated.

Karsten Van Campenhout 0 votos
Acciones de comentarios Permalink
0
Avatar

Unless I'm mistaken, the DJM can only send MIDI data, not receive it. In other words, it's only a host. While this may seem a little backwards seeing as how the mixer can adapt/quantize when in a NXS setup, it's my understanding the tech behind ProDJ Link isn't MIDI, rather, data packets.

With regards to Traktor, I'm not as familiar with its MIDI setup as I never dove that deep into the program. That said, the newest update of Traktor includes Ableton Link ability so you can sync Link-supported apps to Traktor.

I'm not sure what would be causing the MIDI to continuously send to the program. You're connecting the mixer to the computer using one of the USB ports on the left side of the mixer, correct?

lostnthesound 0 votos
Acciones de comentarios Permalink
0
Avatar

Thanks for your reply.  The mixer is not sending midi clock data to traktor only controller data.  I want it the other way around. That way I could input the bpm holding the tap button and turning the time knob (at least i hope that would be possible?).  I am using the usb ports on the left side of the top panel.  The midi set up in traktor shouldn't be the problem as it worked fine with my Xone DB4 i was using before.  In fact i had the option to make it midi slave or host.  I don't understand that the djm900nxs2 is advertised as the industries standard and can not receive midi clock and obviously it can not send midi clock neither.   There are plenty of other and cheaper mixer which can.  I hope this can be solved in a future firmware update.  This is quite dissapointing, fortunately i didn't sell my old mixer yet.

Karsten Van Campenhout 0 votos
Acciones de comentarios Permalink
0
Avatar

Hey @Pulse, just for clarification (because I know it will be asked), what type of BPM data is being sent? In other words, what electronic protocol or data is being sent if not MIDI tempo? Example: Rekordbox packets.

lostnthesound 0 votos
Acciones de comentarios Permalink
0
Avatar

Over MIDI? It's BPM - standard MIDI business. I believe it's measured in time difference between intervals.

There's other additional data sent via the Pro DJ Link (BPM, measure, grid, etc.), but that's not general public info.

Pulse 0 votos
Acciones de comentarios Permalink
0
Avatar

Got it! My bad, I was using the term MIDI Clock interchangeably with BPM rather than using them as two completely separate things. Thanks for the clarification sir. Now we just need the eggheads at Pioneer to develop something similar to Ableton Link. :-)

lostnthesound 0 votos
Acciones de comentarios Permalink
0
Avatar

@Pulse, can you explain the difference between midi clock and BPM data and what the lather is used for?  Is this an other kind of tempo protocol?  If so, do you think there's is some way to convert it into midi clock?  Or an other work around?

Karsten Van Campenhout 0 votos
Acciones de comentarios Permalink
0
Avatar

MIDI Clock is a timer that sends signals every 1/24th of a second (although some systems can go higher than that) in order to maintain sync between MIDI devices.

MIDI BPM uses a signal to essentially "pulse" the BPM at that rate, just like tapping it out. If you were playing something at 120BPM, it would send that value twice per second.

Pulse 0 votos
Acciones de comentarios Permalink
0
Avatar

@Pioneer, you guys never answered the fact that the "On/Off" green button next to USB A/B input ports does not turn off when computer is connected to DJM-900NXS2 (stays lit). This is an issue as the mixer knobs (low EQ specifically in my case) is somehow controlling the playback mode of the track, without any way to disable it.

Here's a video clip demonstrating this exact issue. Please note how the LOW EQ fast forwards through the Traktor Deck 1 playback, without any ability to turn this off.

https://vimeo.com/204313328

Anton Tumas 0 votos
Acciones de comentarios Permalink
0
Avatar

There certainly is a way to disable that control within Traktor, regardless of whether the MIDI remains on. Go into your Traktor preferences and have it stop listening to input from the DJM-900.

The alternative is to try updating your firmware and drivers to the latest version.

I just tested and was able to toggle MIDI on and off with my DJM-900NXS2, verified using a MIDI monitor.

Pulse 0 votos
Acciones de comentarios Permalink
0
Avatar

None of these suggestions work.  Updated the firmware and the driver and made sure there is no midi input set from the 900 to the computer in traktor preferences.  Still turning knobs on the 900 make the midi input indicator in traktor blink.  There is no way of toggling off the midi button when connected to the computer WITH traktor running.  When i close traktor however it is possible to turn the midi button off. IMHO the midi implementation in this mixers sucks: no way of syncing the beat FX to external midi clock, midi on/of toggle doesn't work... Pioneer claims that this mixer is the standard in the industry.  Well then they should resolve this otherwise it is a joke.

Karsten Van Campenhout 0 votos
Acciones de comentarios Permalink
0
Avatar

Version 2.11.0.  Traktor service center does not indicate that there is an update available for me so I guess it's the latest version.

Karsten Van Campenhout 0 votos
Acciones de comentarios Permalink
0
Avatar

@Karsten > Yes - that's the latest version.

Since the DJM-900NXS2 was certified as an official mixer for Traktor, there are some functions which are pre-set (and MIDI ON/OFF is one of them).

None of the DJMs receive MIDI signal, and the Beat FX are only designed to receive any kind of tempo signal from the Pro DJ Link (rekordbox beat grid) data from CDJs / rekordbox. The BPM can be detected by the audio signal of the channel selected. I don't see how the lack of this one feature makes the MIDI implementation "suck" or "a joke."

@Anton > Check in the Traktor preferences > Controller Manager page and ensure that there are no mappings listening for activity on the same channel your DJM's MIDI is on; you could always go into the mixer utility and change the output MIDI channel, but if the software is listening on all channels, it won't make a difference.

Pulse 0 votos
Acciones de comentarios Permalink
0
Avatar

So in case of this mixer because it's traktor certified it can't be stopped from sending midi cc messages to traktor?  I can't see why pioneer would take away the midi on/off function for this.

Traktor is used by a hole lot of pro dj's around the world so I would think that a mixer claiming to be the best out there should be able to receive external midi clock for its beat fx.  Other brands top mixers do have this feature.  So honestly, yes, i am disappointed its not the case in a djm-900nxs2.  I understand pioneer does this intentionally to push dj's to use CDJ's and thus have the advantages of the pro dj link.  

Don't get wrong here, I think this is a fantastic mixer apart from these midi issues and I'm for sure not considering selling it because of these gripes.

Karsten Van Campenhout 0 votos
Acciones de comentarios Permalink
0
Avatar

@Karsten > The DJM series has never been able to receive MIDI signal of any kind; it's send-only.

If you don't want to have the unit sending MIDI signal, disable any commands within Traktor.

Pulse 0 votos
Acciones de comentarios Permalink
0
Avatar

@Pulse > As you probably know for traktor to receive midi data from a controller you have to create a "generic midi device" in the controller manager in the traktor settings.  There is no generic midi device in my controller manager for the djm900, like you suggest should be the case... nevertheless traktor is still receiving midi cc messages from the mixer.  I have about 8 devices at home that can be used as a midi controllers, none of these make traktor receive midi info if there is no generic midi device created in the controller manager.  So the midi on/off button is not only not working if the mixer is connected to a computer running traktor, the mixer somehow sends midi cc to traktor even when traktor is deliberately setup not to receive any.  I hope i can say this is a gripe for me on this mixer.  More so, if you know pioneer has not resolved this in the latest firmware update for the mixer all though they were well aware of the problem.

Karsten Van Campenhout 0 votos
Acciones de comentarios Permalink
0
Avatar

@Karsten > As you know, each and every function within Traktor that is set to be controlled by some MIDI hardware has an entry on the controller manager; if you don't want the track to fast-forward when you turn the LOW EQ knob on CH1 on the mixer, find that line in the MIDI configuration and either change the input for it or disable it.

Pulse 0 votos
Acciones de comentarios Permalink