Have a feature request or suggestion? Post your idea here!

Publicación

3 seguidores Seguir
1
Avatar

Pro DJ link not working: Link icon not showing

Hi All,

I am having issues connecting my Rekordbox library to my XDJ's via ethernet (in export mode). On Monday everything was working fine, today (Friday) I can't get any connection to my XDJ's at all. 

I have been looking on the forum's and the most common cause for this issue seems to be the firewall blocking the connection. I turned off my firewall in windows defender, but this did not help in my case (I do not have any other anti-virus/firewall software).

Does anybody have any clue on how to solve this issue? I am out of ideas at the moment. Below I have listed what I’ve tried already: 

  1. Disabling windows defender firewall
  2. Checked that there is no active VPN connection
  3. Checked my networking settings for my network interface (everything on default, automatic IP assignment)
  4. Check if I have an IP address on the network interface (PC IP= 192.254.212.113)
  5. Restarting the network interface
  6. Disabled all other network interfaces
  7. Restarting my PC
  8. Checked the connection on all XDJ's. They all indicate they are connected, and have a player number.
  9. Updated firmware on XDJ's to the latest version
  10. Connected my PC to one XDJ with a new cable and without a switch
  11. Checked if all my ethernet cables and the switch are functioning correctly

 

Thanks in advance!

 

0) Have you read the "READ ME FIRST" thread in its entirety before posting:  Yes, of course

1) Operating System: Windows 10 1903

2) OS Type: 64bit

3) Rekordbox version: 5.8.5 & 6.0.0 

4) Using LINK: Yes

4a) LINK Connection method: Ethernet from a separate network interface on my PC. XDJ's connected through a basic 5 port unmanaged 100 Mbit switch.

4b) Using with CDJs: 2x XDJ-1000, 1x XDJ-1000 MK2

5) Hard drive / Flash drive / SD card file system: Not applicable

5a) Does the device have multiple partitions: My PC doesn't have multiple partitions

5b) If it's a flash drive, is it a U3 device: Not applicable

5c) With what utility did you format the device: Not applicable

6) Have you scanned your files for errors: No

7) Have you scanned your drive for errors: No

8) Is Rekordbox crashing at all: No

8a) If crashing, is it resulting in:  Not applicable

8b) If not crashing, are there any error messages: No

9) Are you able to repeat / reproduce the problem: Yes

9a) If yes, can you do it consistently: Yes

10) Any other notes regarding your setup only: No

Tom VG

Iniciar sesión para dejar un comentario.

2 comentarios

2
Avatar

+1 to this. Except I'm on 3 x XDJ 1000 Mk2, with a DJM-750 Mk2.

Having the exact same problem - MASSIVE annoyance, this is my standard playing pipeline, and it's just stopped working.

Understood this was consciously stopped for RB 5, and we had to upgrade.

Have done that - No link button. 

As a software and interface developer, I find this massively annoying that the button isn't there always, while buttons I NEVER want to use are permanent fixtures (Largest button on the entire interface is 'Search Mobile', what a waste of screen real estate).

You could have the Link button there, and a mouseover status could imply why it's not available, which may be useful to help troubleshoot for any and all involved.

Dan Toose 2 votos
Acciones de comentarios Permalink
0
Avatar

The struggle is real.I've found out that cycling the switch (on/off) make it work or powering off/on the xdj. This protocol is buggy at least and I agree with Dan toose about the waste of screen for a lot of stuff. I did not update to rb 6 and my advice is to wait at least a couple of months. Been using rb for 4 years and I've learned this the hardway

venturibox 0 votos
Acciones de comentarios Permalink