Have a feature request or suggestion? Post your idea here!

Publicación

2 seguidores Seguir
0
Avatar

DJM not recognised as input device for Chrome (Mac Big Sur)

I have tested this on a DJM750K, 750Mk2 and 900NX2
I have the latest firmware and drivers and have gone through the security and privacy checks and all fine.

I am streaming a set using sites like MelonApp (but doesn't really matter which sites) and need the input device to be the mixer (through the app).

The mixer is seen in sound settings as a USB input and output, but is not recognised as an input in the browser.

If I use an application like loopback (at $100 for full license) I can connect the mixer to work so it is clearly possible with some midi connection hack.

I also tried using this with LANDR and get the same result, their tech support are blaming Pioneer firmware.

Is there a way to get the mixer to be seen as a USB device that essentially acts as a microphone and therefore is seen in security and privacy settings as a microphone so that it is picked up in the browser?

Thanks

Thomas Parrott

Iniciar sesión para dejar un comentario.

3 comentarios

0
Avatar

Thomas,

The use of a device within the browser depends on the code accessing it -- I've used sites like Streamyard with my DJM-900NXS2 and DJM-V10 as the input device with no problem, but I know other applications which have difficulty in recognizing multiple-input audio devices will ignore them completely.

Are you sure you've allowed Chrome access to the hardware?

Pulse 0 votos
Acciones de comentarios Permalink
0
Avatar

Thanks. I am 99% certain that I allowed chrome access. I think you mean in site settings. MelonApp (and LANDR) can see all the other sound devices instantly (including Virtual Cable, Soundflower, Loopback) but not the mixer. I will check streamyard today and see if it sees the mixer. 

Thomas Parrott 0 votos
Acciones de comentarios Permalink
0
Avatar

Yeah, usually it's per-site, not app-wide (as long as you've allowed it in the System Preferences, which you said you had).

Pulse 0 votos
Acciones de comentarios Permalink