Have a feature request or suggestion? Post your idea here!


1 seguidor Seguir

CDJ-850 "USB Error. Remove USB."

Hello everyone,

My father was able to get me two CDJ-850s thanks to one of his colleagues. I had some repairs on both CDJs (change of a flat cable DDD1522, change of two 0.375A P2004 fuses on the CMPX ASSY PCB, replacement of a Select Browse Rotary Knob (DAA1259)).

Since these repairs, both CDJ's turn on and one works perfectly. But on the other, a problem persists with the USB plug. When I plug a USB stick into it, the CDJ detects it and the little LED flashes red. However, I get this message: "Error USB. Remove USB."

Do you have any idea where this fault could be coming from? I first tried with USB 3.0, but I saw that it may need to be upgraded to read it. I have tried with a USB 2.0 stick and I get the same problem. I also tried to update it with this USB 2.0, but the screen stays stuck on "Insert a USB...".

Here are some pictures of my issue:


Thank you very much for your help,



La publicación no admite más comentarios.

1 comentario


Ok, I found my issue... On opening the second CDJ 850 to take the PCB with the USB to try on the other one to diagnose the problem, I realised that the CDJ had already been dismantled by someone who was probably not very meticulous. The Ribbon cable had been plugged in on the wrong side. When I put it back together, everything works perfectly. Thanks a lot to all of you!

Dupzer 0 votos
Acciones de comentarios Permalink