Have a feature request or suggestion? Post your idea here!


2 seguidores Seguir

Syncing XDJ-RR Tempo (MIDI) to TR-8S Drum Machine

My end goal here is to be able to have my TR-8S slaved to the XDJ-RR. I really like chopping up samples on the XDJ, and would love to be able to add drums that are synced to the tracks and/or loops. Yes I can do it the old fashioned way, but eventually the tempo drifts out. It would also be dreamy to be able to change tempo on the XDJ and have the TR-8S follow. So far I've tried setting up aggregates in OS X's Audio Midi Setup app, as well as MidiPipe. I've also tinkered around in Logic. I have a UMC404HD interface with 5-pin Midi In's and Out's, so I was trying to convert the MIDI data from the XDJ's USB out-- send out through the UMC404HD Midi out to the TR-8S' Midi IN, but no dice:

XDJ usb out > MacBook Pro usb port > UMC404hd midi out > TR-8S midi in. 

I've scoured the forums, and the post pasted below is the closest thing. Pioneer's response sounds hopeful, but vaguely references an app that the OP can't track down, and then they ghost him.

I've also attached a link to XDJ-RR's midi messages, because it seems to have vast midi capability-- but i'm having trouble seeing a way to make it do a simple tempo sync with a drum machine.


Anyone have any ideas?


- Behringer UMC404HD Has 5-PIn Midi In & Out Ports

- Roland TR-8S has 5-pin Midi In & Out ports

- XDJ-RR has USB Out that transfers MIDI






Tyler Cannata Respondida

Comentario oficial


Hi Tyler,

You can use a USB MIDI host device which would allow the XDJ-RR to connect the USB to send the MIDI data, which could then output a 5-pin MIDI to the other devices for sync.





Acciones de comentarios Permalink

Iniciar sesión para dejar un comentario.

2 comentarios


Thanks for the info! I just received a USB Midi host device in the mail today (specifically the Disaster Area micro.ghost)

I connected XDJ USB Out > micro.ghost USB host In, but the micro.ghost isn't receiving any MIDI information from the XDJ (indicated by light color). I just updated all my drivers & firmware, restarted all devices, and tried different cables-- but no dice.


Pulse, what am I doing wrong here?


Tyler Cannata 0 votos
Acciones de comentarios Permalink