Have a feature request or suggestion? Post your idea here!

Publication

9 abonnés S’abonner
1
Avatar

XDJ-RX2 Rekordbox Mode not working

Hi All

Specs:

MacBook Pro (mid 2012) / OS Sierra 10.12.6  / Rekordbox 5

When I connect my MacBook to xdj-rx2 via USB and press the rekordbox button on the xdj, I get a blank screen (1st picture). Works fine connected to MacBook in MIDI mode (2nd picture). Any ideas?

Thanks in advance!



Stephen Herschel

Commentaire officiel

Avatar

Yeah - rekordbox mode is for EXPORT mode, MIDI is for PERFORMANCE mode. You're doing it right the 2nd way.

Pulse
Actions pour les commentaires Permalien

Vous devez vous connecter pour laisser un commentaire.

29 commentaires

0
Avatar

Still get a blank screen in export mode...

Stephen Herschel 0 votes
Actions pour les commentaires Permalien
0
Avatar

If you don't see the link button at the bottom left of rekordbox in EXPORT mode, you want to check your firewall and ensure you've allowed rekordbox through the network. The RX2 must be connected via ethernet for that mode.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

When I first got my RX2 I tried using it with Rekordbox with the export/link function and it worked. Ever since I activated the licence for Rekordbox DJ it's been broken.

I've already tried disabling the firewall. That didn't help 🤔

MrGuaps 0 votes
Actions pour les commentaires Permalien
0
Avatar

I'm having the same issue. Have you had any joy. It's doing my head in.

Glenn Scott 0 votes
Actions pour les commentaires Permalien
0
Avatar

I actually did. I uninstalled Rekordbox 5.0 and installed Rekordbox 4.5. This fixed it for me 👍

MrGuaps 0 votes
Actions pour les commentaires Permalien
0
Avatar

So rekordbox now works in performance mode?

Glenn Scott 0 votes
Actions pour les commentaires Permalien
0
Avatar

I haven't tried performance mode, but export/USB link works perfectly for me now

MrGuaps 0 votes
Actions pour les commentaires Permalien
0
Avatar

Just got my XDJ RX2, same problem here. Works fine on Midi Mode > Performance Mode... But got blank list on Rekordbox Mode > Export Mode.

- Rekordbox, drivers and fw all up to date.

- Firewall allowing full acess to all the rekordbox .exes

In Rekordbox software (Export mode) the Link button is active, I click it and it turns to number 1 LINK, but nothing else happens, the decks drawings that should appear right next to the Link Button won't appear.

I don't wanna downgrade my rekordbox to 4.5. Any other solution?

Rodrigo Wan-Dall 0 votes
Actions pour les commentaires Permalien
0
Avatar

I believe it was installed alongside the other drivers that popped when setting up Rekordbox for the first time, as the MIDI mode works fine, am I wrong?

Anyways, I'll try to manually install it this evening and I'll report back later.

Thank you for the info.

Rodrigo Wan-Dall 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Rodrigo > That's not part of the standard driver installation if you open rekordbox, that would just be the audio and MIDI drivers. The networking bridge is a separate installation.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Ok, so I've tried installing the Link Export drivers for Windows 10, still got nothing (maybe they should be automatically installed with the initial rekordbox setup when you select your device?). Tried restarting my computer and rx2. Nothing.

Tried disabling my other Network adapters in windows and completely disabling firewall... No success.

By the way, the "Pioneer DJ Network Adapter" the driver created under the Network Connections says "Unidentified network". Is this normal or maybe there's something to do with the problem?

Rodrigo Wan-Dall 0 votes
Actions pour les commentaires Permalien
0
Avatar

I am also having this exact issue - Cannot get Rekordbox mode working on the XDJ-RX2 at all, and I'm following instructions to the letter as far as I'm aware.

One thing I am pretty sure is central to the issue for me - You talk about a 'Link Button' - I've never seen one. It's hard to know what to look for with no images (this would massively improve your support threads in general).

The state of my setup:
- I am running on WIndows 10, with everything up to date.
- I have downloaded the USB Connection (Link Export) Drivers (and it shows up in device manager as Pioneer Network DJ Adaptor.
- I have installed RekordBox, up to version 5.03
- My XDJ-RX2 is reportedly firmware updated to 1.20
- I am able to combo my RX2 and Rekordbox on PC just fine for Performance mode when I set up using XDJ-RX2 ASIO... 100% flawless.

Possible X-factors as to why the XDJ-RX2 is getting a 'blank' in Rekordbox mode:
- I have TouchOSC Bridge installed from old audio setups. Any chance that could interfere? Same with support for MPU-401?
- When I run Rekordbox in Export mode there is an option at the top of Audio Preferences named 'LINK MONITOR' - Should this be checked? Does it matter?
- Does Export mode need to have some specific Audio device selected to enable the Rekordbox mode

Any advice would be appreciated. I feel like I'm missing a major feature... I can't even tell since I've not been able to get it to go!

Cheers

Dan

P.S. Could you please start showing us images of what you expect us to see? And possibly a step-by-step guide to follow? Something people can follow from start to finish, where you include what states things should be in so we can troubleshoot more effectively?

Dan Toose 0 votes
Actions pour les commentaires Permalien
0
Avatar

Update:
- I installed everything on my laptop (also Win 10, up to date), and this time I DID see the link button, and was able to get Rekordbox mode working on the XDJ-RX2 with Export mode in Rekordbox on the laptop. So on one hand - Success.
- Removing TouchOSC didn't help the desktop machine at all.

I REALLY want to get it working on my desktop. Any processes / advice that could be given to help identify the issue on my desktop machine would be really appreciated.

As far as I'm aware, all Rekordbox related files have firewall access. Maybe some tips on how to confirm this would be useful?

Dan Toose 0 votes
Actions pour les commentaires Permalien
0
Avatar

Solved - I had to make exceptions for public networks in my firewall with one of the files. The file name wasn't intuitive to look for, began with an 'e'

Dan Toose 0 votes
Actions pour les commentaires Permalien
0
Avatar

I could not make my Rekordbox Mode to work yet.

Haven't tryed on another computer, but I had tryed to allow all the .exes at rekordbox folders in windows firewall, I think it was 4 .exe files total.

I will check that again to see if my problem solves, still I believe it is different than Dan Toose's, as he could not see the Link button at Rekorbox software to show (as I mentioned, mine shows, but when I click it, just turns to LINK 1 and nothing else happens).

Not a big deal though, but would be nice to test my playlists before exporting to my gig drives.

Rodrigo Wan-Dall 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Rodrigo > Is your network type set to PUBLIC or PRIVATE?

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

I just checked, and it was set to Public network (don't know why, I use ethernet cable, not wifi), changed it to Private, but no cake. 

Then I went to check Pioneer network adapter, and it is set to Public as well, but I can't seem to change it. The option won't appear.

My firewall's allowing full access to Pioneer's .exes, both TCP and UDP protocols, and for both public and private networks, as you can see in my printscreen.


(sorry it is seen in portuguese, but I believe you can have the idea)

Rodrigo Wan-Dall 0 votes
Actions pour les commentaires Permalien
0
Avatar

I have the same problem, blank Export screen on my xdj rx2..

i can still press link and it connects it just doesnt show the pictures of the decks where you load tracks.. ive allowed everything through the firewall in both public and private and made sure they are allowed through in the list... ive tried turning off firewall nothing is working

Daniel McIntyre 0 votes
Actions pour les commentaires Permalien
0
Avatar

this used to work without a problem... cant get export mode to work at all.

I can hit link and nothing happens

 

Daniel McIntyre 0 votes
Actions pour les commentaires Permalien
0
Avatar

Same problem for me. I've been using it for years without a problem. Then I update to latest rekordbox version (5.8.6) and nothing happens in EXPORT mode when I press the link button. I've checked my firewall, reinstalled the networking bridge as suggested above but no luck - the decks just don't appear like they used to.

Please help Pioneer!

Pete Rollins 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hello everyone!

I have the same issue (connect players or console with an ethernet (link) cable, press "LINK" in EXPORT mode, and only appears "link1" in the left corner without the decks in the middle. 

The laptop is an Asus ROG G732LV. (2020 generation) with Windows 11.

It's not the Windows. I have this laptop since 2021 January and didn't work with the Win 10 nether. I think it's something with the privacy settings... With my old ROG, everything worked fine.

I tried both, rekordbox 5 and 6. The same thing. Tomorrow I will try with a rekordbox 4.5 but I really want to use it with the 6th gen.

Anyone who resolved this issue ?

 

Wardein 0 votes
Actions pour les commentaires Permalien
0
Avatar

Don't even bother with rekordbox 4 - we're barely supporting rekordbox 5 at this point!

Have you verified that the firewall is disabled and that the ethernet connection in Windows is set to PRIVATE type (not PUBLIC)?

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Today I have to perform on 2x CDJ2000NXS2. The Players are linked with a switch and the 3rd UTP cable is connected to the laptop. I don't have any option to change the ethernet connection. (I know where to look, I guess)

Another way I tried is to link the players with UTP cable and connect to the laptop with USB from Player 1. Same situation. 

Firewall and any other security are turned off. (With the old laptop everything worked fine without turning off anything)

I'm 100% sure that there is one tiny little setting at the connection or security.

Wardein 0 votes
Actions pour les commentaires Permalien